1b94b1134bd3bfde11ef473b34385f2c4d7379a7
[simantics/platform.git] / releng / org.simantics.sdk.build.p2.site / pom.xml
1 <?xml version="1.0" encoding="UTF-8"?>
2 <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001 XMLSchema-instance"
3         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
4         <modelVersion>4.0.0</modelVersion>
5
6     <groupId>org.simantics</groupId>
7     <artifactId>org.simantics.sdk.build.p2.site</artifactId>
8     <packaging>pom</packaging>
9     <version>1.30.0</version>
10
11     <properties>
12         <itext.version.actual>2.1.7.b1</itext.version.actual>
13         <antlr.version>3.5.2</antlr.version>
14         <commons-codec.version>1.14</commons-codec.version>
15         <lucene.version>4.9.0</lucene.version>
16         <lucene.version.actual>4.9.0.b0003</lucene.version.actual>
17         <lucene.prefix>org.apache.lucene4</lucene.prefix>
18         <jaxen.version>1.2.0</jaxen.version>
19         <jdom.version>2.0.6</jdom.version>
20         <jdom.version.actual>2.0.6.b0001</jdom.version.actual>
21         <jackson.version>2.10.2</jackson.version>
22         <jackson.version.actual>2.10.2.b0001</jackson.version.actual>
23         <javax.version>3.1.0</javax.version>
24         <jakarta.version>2.1.6</jakarta.version>
25         <!-- This can be removed once jakarta version is bumped -->
26         <jakarta.version.actual>2.1.6.b0005</jakarta.version.actual>
27         <jersey.version>2.30.1</jersey.version>
28         <!-- This can be removed once jersey version is bumped -->
29         <jersey.version.actual>2.30.1.b0006</jersey.version.actual>
30         <jfreechart.version>1.5.0</jfreechart.version>
31         <slf4j.version>1.7.30</slf4j.version>
32         <slf4j.version.actual>1.7.30</slf4j.version.actual>
33         <grpc.version>1.27.2</grpc.version>
34         <grpc.version.actual>1.27.2</grpc.version.actual>
35         <protobuf.version>3.11.4</protobuf.version>
36         <zeroturnaround.version>1.11</zeroturnaround.version>
37         <caffeine.version>2.8.1</caffeine.version>
38         <influxdb.client.version>1.5.0</influxdb.client.version>
39         <supercsv.version>2.4.0</supercsv.version>
40         <ini4j.version>0.5.4</ini4j.version>
41         <commons-collections.version>4.4</commons-collections.version>
42         <commons-compress.version>1.20</commons-compress.version>
43         <commons-lang.version>2.6</commons-lang.version>
44         <commons-logging.version>1.2</commons-logging.version>
45         <commons-io.version>1.4</commons-io.version>
46         <commons-math.version>3.6.1</commons-math.version>
47         <pdfbox.version>2.0.19</pdfbox.version>
48         <fontbox.version>2.0.19</fontbox.version>
49         <xmpbox.version>2.0.19</xmpbox.version>
50         <log4j.version>1.2.17</log4j.version>
51         <ucanaccess.version>3.0.7</ucanaccess.version>
52         <fastutil.version>8.3.1</fastutil.version>
53         <trove4j.version>3.0.3</trove4j.version>
54         <freemarker.version>2.3.29</freemarker.version>
55         <itext.version>2.1.7</itext.version>
56         <rhino.version>1.7.12</rhino.version>
57         <jna41.version>4.1.0</jna41.version>
58         <jna.version>4.5.2</jna.version>
59         <logback-classic.version>1.2.3</logback-classic.version>
60         <koloboke-compile.version>0.5.1</koloboke-compile.version>
61         <koloboke-impl-common-jdk8.version>1.0.0</koloboke-impl-common-jdk8.version>
62         <kryo.version>4.0.2</kryo.version>
63         <org.apache.aries.spifly.dynamic.bundle.version>1.2.3</org.apache.aries.spifly.dynamic.bundle.version>
64         <decompiler-procyon.version>4.3.0.Final</decompiler-procyon.version>
65         <jsoup.version>1.12.2</jsoup.version>
66         <snakeyaml.version>1.25</snakeyaml.version>
67         <jetty945.version>9.4.24.v20191120</jetty945.version>
68         <netty.version>4.1.45.Final</netty.version>
69         <jcip-annotations.version>1.0</jcip-annotations.version>
70         <pgjdbc-ng.version>0.8.3</pgjdbc-ng.version>
71     </properties>
72
73     <repositories>
74         <!--
75         <repository>
76             <id>project-specific-deps</id>
77             <name>project-specific-deps</name>
78             <url>file:///${basedir}/repo</url>
79         </repository>c.version.actual
80         --> 
81     </repositories>
82
83     <build>
84         <plugins>
85             <plugin>
86                 <groupId>org.eclipse.tycho.extras</groupId>
87                 <artifactId>tycho-p2-extras-plugin</artifactId>
88                 <version>1.0.0</version>
89             </plugin>
90             <plugin>
91                 <groupId>org.reficio</groupId>
92                 <artifactId>p2-maven-plugin</artifactId>
93                 <version>1.2.0</version>
94                 <executions>
95                     <execution>
96                         <id>default-cli</id>
97                         <!-- QUICK-START EXAMPLE -->
98                         <!--
99                         This is the default quick-start configuration.
100
101                         Expected behavior:
102                           - specified dependencies will be fetched
103                           - transitive dependencies will be fetched (no default exclusions)
104                           - jars containing source source code will NOT be fetched
105                           - jars that are NOT OSGi bundles will be "bundled" using bnd tool,
106                             if you specify instructions for these jars they will be APPLIED
107                           - jars that are OSGi bundles will be simply included
108                             if you specify instructions for these jars they will be IGNORED (see <override> option)
109                           - p2 site will be generated
110
111                         How the instructions works:
112                           - instructions are applied only to the root artifact that you specify!
113                           - instructions are not applied to the TRANSITIVE dependencies!
114                           - transitive dependencies are never overridden (see <override> option)
115                           - transitive dependencies are bundled using the default instructions:
116                               <instructions>
117                                   <Import-Package>*;resolution:=optional</Import-Package>
118                                   <Export-Package>*</Export-Package>
119                               </instructions>
120                           - other instructions, such as, Bundle-SymbolicName, Bundle-Name, Bundle-Version, etc.
121                             are calculated according to the following rules:
122                             http://felix.apache.org/site/apache-felix-maven-bundle-plugin-bnd.html
123                           - if you specify any instructions they will be applied only if
124                             the jar is not already an OSGi bundle - otherwise you have to use the override
125                             option - please see the /examples/override/pom.xml example
126
127                         The following definition of an artifact:
128                             <artifact>
129                                 <id>commons-io:commons-io:2.1</id>
130                             </artifact>
131
132                         is an equivalent of the following definition:
133                             <artifact>
134                                 <id>commons-io:commons-io:2.1</id>
135                                 <transitive>true</transitive>
136                                 <source>false</source>
137                                 <override>false</override>
138                                 <instructions>
139                                     <Import-Package>*;resolution:=optional</Import-Package>
140                                     <Export-Package>*</Export-Package>
141                                 </instructions>
142                                 <excludes/>
143                             </artifact>
144
145                         To run the example please invoke: mvn p2:site
146                         -->
147                         <configuration>
148                             <artifacts>
149                                 <artifact>
150                                     <id>org.antlr:antlr-runtime:${antlr.version}</id>
151                                     <source>true</source>
152                                     <instructions>
153                                         <Bundle-SymbolicName>org.antlr.runtime</Bundle-SymbolicName>
154                                         <Bundle-Version>${antlr.version}</Bundle-Version>
155                                         <Export-Package>*;version="${antlr.version}"</Export-Package>
156                                     </instructions>                                    
157                                 </artifact>
158                                 <artifact>
159                                     <id>org.apache.lucene:lucene-core:${lucene.version}</id>
160                                     <source>true</source>
161                                     <instructions>
162                                         <Bundle-SymbolicName>${lucene.prefix}.core</Bundle-SymbolicName>
163                                         <Bundle-Version>${lucene.version.actual}</Bundle-Version>
164                                         <Export-Package>*;version="${lucene.version}"</Export-Package>
165                                     </instructions>
166                                 </artifact>
167                                 <artifact>
168                                     <id>org.apache.lucene:lucene-queries:${lucene.version}</id>
169                                     <source>true</source>
170                                     <instructions>
171                                         <Bundle-SymbolicName>${lucene.prefix}.queries</Bundle-SymbolicName>
172                                         <Bundle-Version>${lucene.version.actual}</Bundle-Version>
173                                         <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}"</Require-Bundle>
174                                         <Export-Package>*;version="${lucene.version}"</Export-Package>
175                                         <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>
176                                     </instructions>
177                                 </artifact>
178                                 <artifact>
179                                     <id>org.apache.lucene:lucene-sandbox:${lucene.version}</id>
180                                     <source>true</source>
181                                     <instructions>
182                                         <Bundle-SymbolicName>${lucene.prefix}.sandbox</Bundle-SymbolicName>
183                                         <Bundle-Version>${lucene.version.actual}</Bundle-Version>
184                                         <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}"</Require-Bundle>
185                                         <Export-Package>*;version="${lucene.version}"</Export-Package>
186                                         <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>
187                                     </instructions>
188                                 </artifact>
189                                 <artifact>
190                                     <id>org.apache.lucene:lucene-analyzers-common:${lucene.version}</id>
191                                     <source>true</source>
192                                     <instructions>
193                                         <Bundle-SymbolicName>${lucene.prefix}.analyzers-common</Bundle-SymbolicName>
194                                         <Bundle-Version>${lucene.version.actual}</Bundle-Version>
195                                         <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}"</Require-Bundle>
196                                         <Export-Package>*;version="${lucene.version}"</Export-Package>
197                                         <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>
198                                     </instructions>
199                                 </artifact>
200                                 <artifact>
201                                     <id>org.apache.lucene:lucene-queryparser:${lucene.version}</id>
202                                     <source>true</source>
203                                     <instructions>
204                                         <Bundle-SymbolicName>${lucene.prefix}.queryparser</Bundle-SymbolicName>
205                                         <Bundle-Version>${lucene.version.actual}</Bundle-Version>
206                                         <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}",${lucene.prefix}.queries;bundle-version="${lucene.version}",${lucene.prefix}.sandbox;bundle-version="${lucene.version}"</Require-Bundle>
207                                         <Export-Package>*;version="${lucene.version}"</Export-Package>
208                                         <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>
209                                     </instructions>
210                                 </artifact>
211                                 <artifact>
212                                     <id>jaxen:jaxen:${jaxen.version}</id>
213                                     <source>true</source>
214                                 </artifact>
215                                 <artifact>
216                                     <id>org.jdom:jdom2:${jdom.version}</id>
217                                     <source>true</source>
218                                     <instructions>
219                                         <Bundle-SymbolicName>org.jdom2</Bundle-SymbolicName>
220                                         <Bundle-Version>${jdom.version.actual}</Bundle-Version>
221                                         <Export-Package>*;version="${jdom.version}"</Export-Package>
222                                     </instructions>
223                                 </artifact>
224                                 <artifact>
225                                     <id>org.jfree:jfreechart:${jfreechart.version}</id>
226                                     <source>true</source>
227                                     <instructions>
228                                         <Bundle-SymbolicName>org.jfree.jchart</Bundle-SymbolicName>
229                                     </instructions>
230                                 </artifact>
231                                 <!--
232                                 <artifact>
233                                     <id>org.ow2.asm:asm:5.0.4</id>
234                                     <source>true</source>
235                                     <override>true</override>
236                                     <instructions>
237                                         <Bundle-SymbolicName>org.objectweb.asm5</Bundle-SymbolicName>
238                                     </instructions>
239                                 </artifact>
240                                 -->
241                                 <artifact>
242                                     <id>net.sf.supercsv:super-csv:${supercsv.version}</id>
243                                     <source>true</source>
244                                     <override>true</override>
245                                     <instructions>
246                                         <Bundle-SymbolicName>org.supercsv</Bundle-SymbolicName>
247                                     </instructions>
248                                 </artifact>
249                                 <artifact>
250                                     <id>org.ini4j:ini4j:${ini4j.version}</id>
251                                     <source>true</source>
252                                 </artifact>
253                                 <artifact>
254                                     <!-- Needed by Apache POI 3.15 -->
255                                     <id>commons-codec:commons-codec:${commons-codec.version}</id>
256                                     <source>true</source>
257                                 </artifact>
258                                 <artifact>
259                                     <!-- Needed by Apache POI 3.15 -->
260                                     <id>org.apache.commons:commons-collections4:${commons-collections.version}</id>
261                                     <source>true</source>
262                                 </artifact>
263                                 <artifact>
264                                     <id>org.apache.commons:commons-compress:${commons-compress.version}</id>
265                                     <source>true</source>
266                                     <override>true</override>
267                                     <instructions>
268                                         <Bundle-SymbolicName>org.apache.commons.compress</Bundle-SymbolicName>
269                                     </instructions>
270                                 </artifact>
271                                 <artifact>
272                                     <id>commons-lang:commons-lang:${commons-lang.version}</id>
273                                     <source>true</source>
274                                 </artifact>
275                                 <artifact>
276                                     <!-- Needed by Apache POI 3.15 -->
277                                     <id>commons-logging:commons-logging:${commons-logging.version}</id>
278                                     <source>true</source>
279                                 </artifact>
280                                 <artifact>
281                                     <id>commons-io:commons-io:${commons-io.version}</id>
282                                     <source>true</source>
283                                 </artifact>
284                                 <artifact>
285                                     <id>org.apache.commons:commons-math3:${commons-math.version}</id>
286                                     <source>true</source>
287                                 </artifact>
288
289                                 <artifact>
290                                     <id>org.apache.pdfbox:pdfbox:${pdfbox.version}</id>
291                                     <source>true</source>
292                                 </artifact>
293                                 <artifact>
294                                     <id>org.apache.pdfbox:fontbox:${fontbox.version}</id>
295                                     <source>true</source>
296                                 </artifact>
297                                 <artifact>
298                                     <id>org.apache.pdfbox:xmpbox:${xmpbox.version}</id>
299                                     <source>true</source>
300                                 </artifact>
301                                 <!-- Needed by Apache POI 3.15, however these are included in third-party repository manually -->
302                                 <!--
303                                 <artifact>
304                                     <id>org.apache.xmlbeans:xmlbeans:2.6.0</id>
305                                     <source>true</source>
306                                 </artifact>
307                                 <artifact>
308                                     <id>com.github.virtuald:curvesapi:1.04</id>
309                                     <source>true</source>
310                                 </artifact>
311                                 -->
312                                 <artifact>
313                                     <id>log4j:log4j:${log4j.version}</id>
314                                     <source>true</source>
315                                     <override>true</override>
316                                     <instructions>
317                                         <Bundle-SymbolicName>org.apache.log4j</Bundle-SymbolicName>
318                                     </instructions>
319                                 </artifact>
320                                 <artifact>
321                                     <id>net.sf.ucanaccess:ucanaccess:${ucanaccess.version}</id>
322                                     <source>true</source>
323                                     <instructions>
324                                         <Bundle-SymbolicName>net.ucanaccess</Bundle-SymbolicName>
325                                     </instructions>
326                                 </artifact>
327                                 <artifact>
328                                     <id>it.unimi.dsi:fastutil:${fastutil.version}</id>
329                                     <source>true</source>
330                                 </artifact>
331                                 <artifact>
332                                     <id>net.sf.trove4j:trove4j:${trove4j.version}</id>
333                                     <source>true</source>
334                                     <instructions>
335                                         <Bundle-Name>GNU Trove 3</Bundle-Name>
336                                         <Bundle-SymbolicName>gnu.trove3</Bundle-SymbolicName>
337                                     </instructions>
338                                 </artifact>
339                                 <artifact>
340                                     <id>org.freemarker:freemarker:${freemarker.version}</id>
341                                     <source>true</source>
342                                     <override>true</override>
343                                     <instructions>
344                                         <Bundle-SymbolicName>freemarker</Bundle-SymbolicName>
345                                     </instructions>
346                                 </artifact>
347                                 <artifact>
348                                     <id>com.lowagie:itext:${itext.version}</id>
349                                     <source>true</source>
350                                     <instructions>
351                                         <Bundle-SymbolicName>com.lowagie.text</Bundle-SymbolicName>
352                                         <Bundle-Version>${itext.version.actual}</Bundle-Version>
353                                     </instructions>
354                                 </artifact>
355                                 <artifact>
356                                     <id>org.mozilla:rhino:${rhino.version}</id>
357                                     <source>true</source>
358                                 </artifact>
359                                 <artifact>
360                                     <id>javax.servlet:javax.servlet-api:${javax.version}</id>
361                                     <source>true</source>
362                                 </artifact>
363                                 <artifact>
364                                     <id>com.fasterxml.jackson.core:jackson-core:${jackson.version}</id>
365                                     <source>true</source>
366                                 </artifact>
367                                 <artifact>
368                                     <id>com.fasterxml.jackson.core:jackson-annotations:${jackson.version}</id>
369                                     <source>true</source>
370                                 </artifact>
371                                 <artifact>
372                                     <id>com.fasterxml.jackson.core:jackson-databind:${jackson.version}</id>
373                                     <source>true</source>
374                                     <excludes>
375                                         <exclude>com.fasterxml.jackson.*</exclude>
376                                     </excludes>
377                                 </artifact>
378                                 <artifact>
379                                     <id>com.fasterxml.jackson.dataformat:jackson-dataformat-csv:${jackson.version}</id>
380                                     <source>true</source>
381                                     <excludes>
382                                         <exclude>com.fasterxml.jackson.*</exclude>
383                                     </excludes>
384                                 </artifact>
385                                 <artifact>
386                                     <id>com.fasterxml.jackson.dataformat:jackson-dataformat-xml:${jackson.version}</id>
387                                     <source>true</source>
388                                     <excludes>
389                                         <exclude>com.fasterxml.jackson.*</exclude>
390                                     </excludes>
391                                 </artifact>
392                                 <artifact>
393                                     <id>com.fasterxml.jackson.datatype:jackson-datatype-jsr310:${jackson.version}</id>
394                                     <source>true</source>
395                                     <excludes>
396                                         <exclude>com.fasterxml.jackson.*</exclude>
397                                     </excludes>
398                                 </artifact>
399                                 <artifact>
400                                     <id>com.fasterxml.jackson.jaxrs:jackson-jaxrs-base:${jackson.version}</id>
401                                     <source>true</source>
402                                     <excludes>
403                                         <exclude>com.fasterxml.jackson.*</exclude>
404                                     </excludes>
405                                 </artifact>
406                                 <artifact>
407                                     <id>com.fasterxml.jackson.jaxrs:jackson-jaxrs-json-provider:${jackson.version}</id>
408                                     <source>true</source>
409                                     <excludes>
410                                         <exclude>com.fasterxml.jackson.*</exclude>
411                                     </excludes>
412                                 </artifact>
413                                 <artifact>
414                                     <id>com.fasterxml.jackson.module:jackson-module-jaxb-annotations:${jackson.version}</id>
415                                     <source>true</source>
416                                     <excludes>
417                                         <exclude>com.fasterxml.jackson.*</exclude>
418                                     </excludes>
419                                 </artifact>
420                                 <artifact>
421                                     <id>org.slf4j:slf4j-api:${slf4j.version}</id>
422                                     <source>true</source>
423                                     <override>true</override>
424                                     <instructions>
425                                         <Bundle-Name>SLF4J API Module</Bundle-Name>
426                                         <Bundle-Version>${slf4j.version.actual}</Bundle-Version>
427                                         <Bundle-SymbolicName>org.slf4j.api</Bundle-SymbolicName>
428                                         <Export-Package>*;version=${slf4j.version}</Export-Package>
429                                     </instructions>
430                                 </artifact>
431                                 <artifact>
432                                     <id>ch.qos.logback:logback-classic:${logback-classic.version}</id>
433                                     <source>true</source>
434                                     <override>true</override>
435                                 </artifact>
436                                 <artifact>
437                                     <id>com.koloboke:koloboke-compile:${koloboke-compile.version}</id>
438                                     <source>true</source>
439                                 </artifact>
440                                 <artifact>
441                                     <id>com.koloboke:koloboke-impl-common-jdk8:${koloboke-impl-common-jdk8.version}</id>
442                                     <source>true</source>
443                                 </artifact>
444                                 <artifact>
445                                     <id>com.esotericsoftware:kryo:${kryo.version}</id>
446                                     <source>true</source>
447                                 </artifact>
448                                  <artifact>
449                                      <id>org.apache.aries.spifly:org.apache.aries.spifly.dynamic.bundle:${org.apache.aries.spifly.dynamic.bundle.version}</id>
450                                      <source>true</source>
451                                  </artifact>
452                                 <artifact>
453                                     <id>jakarta.ws.rs:jakarta.ws.rs-api:${jakarta.version}</id>
454                                     <source>true</source>
455                                     <override>true</override>
456                                     <instructions>
457                                         <Bundle-Version>${jakarta.version.actual}</Bundle-Version>
458                                         <Require-Bundle>
459                                              jakarta.xml.bind-api
460                                         </Require-Bundle>
461                                         <Import-Package>!javax.*,*;resolution:=optional</Import-Package>
462                                         <Export-Package>
463                                             javax.ws.rs;version="${jakarta.version}",
464                                             javax.ws.rs.core;version="${jakarta.version}",
465                                             javax.ws.rs.ext;version="${jakarta.version}",
466                                             javax.ws.rs.client;version="${jakarta.version}",
467                                             javax.ws.rs.container;version="${jakarta.version}",
468                                             javax.ws.rs.sse;version="${jakarta.version}"
469                                         </Export-Package>
470                                     </instructions>
471                                 </artifact>
472                                 <artifact>
473                                     <id>org.glassfish.jersey.core:jersey-common:${jersey.version}</id>
474                                     <source>true</source>
475                                     <override>true</override>
476                                     <instructions>
477                                         <Bundle-Version>${jersey.version.actual}</Bundle-Version>
478                                         <Require-Bundle>
479                                              javax.annotation,
480                                              javax.inject,
481                                              javax.servlet-api,
482                                              jakarta.validation.jakarta.validation-api,
483                                              jakarta.ws.rs-api,
484                                              jakarta.xml.bind-api,
485                                              jakarta.activation-api
486                                         </Require-Bundle>
487                                         <Import-Package>!javax.*,*;resolution:=optional</Import-Package>
488                                         <Export-Package>
489                                             org.glassfish.jersey.*;version="${jersey.version}"
490                                         </Export-Package>
491                                     </instructions>
492                                 </artifact>
493                                 <artifact>
494                                     <id>org.glassfish.jersey.core:jersey-server:${jersey.version}</id>
495                                     <source>true</source>
496                                     <override>true</override>
497                                     <instructions>
498                                         <Bundle-Version>${jersey.version.actual}</Bundle-Version>
499                                         <Require-Bundle>
500                                              javax.annotation,
501                                              javax.inject,
502                                              javax.servlet-api,
503                                              jakarta.validation.jakarta.validation-api,
504                                              jakarta.ws.rs-api,
505                                              jakarta.xml.bind-api,
506                                              jakarta.activation-api
507                                         </Require-Bundle>
508                                         <Import-Package>!javax.*,*;resolution:=optional</Import-Package>
509                                     </instructions>
510                                 </artifact>
511                                 <artifact>
512                                     <id>org.glassfish.jersey.core:jersey-client:${jersey.version}</id>
513                                     <source>true</source>
514                                     <override>true</override>
515                                     <instructions>
516                                         <Bundle-Version>${jersey.version.actual}</Bundle-Version>
517                                         <Require-Bundle>
518                                              javax.annotation,
519                                              javax.inject,
520                                              javax.servlet-api,
521                                              jakarta.validation.jakarta.validation-api,
522                                              jakarta.ws.rs-api,
523                                              jakarta.xml.bind-api,
524                                              jakarta.activation-api
525                                         </Require-Bundle>
526                                         <Import-Package>!javax.*,*;resolution:=optional</Import-Package>
527                                     </instructions>
528                                 </artifact>
529                                 
530                                 <artifact>
531                                     <id>org.glassfish.jersey.media:jersey-media-multipart:${jersey.version}</id>
532                                     <source>true</source>
533                                     <!-- For some reason p2-maven-plugin does not work with the below plugin and only generates sources for that -->
534                                     <!-- <override>true</override>
535                                     <instructions>
536                                         <Bundle-Version>${jersey.version.actual}</Bundle-Version>
537                                         <Require-Bundle>
538                                              jakarta.ws.rs-api,
539                                         </Require-Bundle>
540                                         <Import-Package>!javax.*,*;resolution:=optional</Import-Package>
541                                     </instructions> -->
542                                 </artifact>
543                                 <artifact>
544                                     <id>org.glassfish.jersey.ext:jersey-entity-filtering:${jersey.version}</id>
545                                     <source>true</source>
546                                     <override>true</override>
547                                     <instructions>
548                                         <Bundle-Version>${jersey.version.actual}</Bundle-Version>
549                                         <Require-Bundle>
550                                              jakarta.ws.rs-api,
551                                              jakarta.activation-api,
552                                              javax.servlet-api,
553                                              org.glassfish.jersey.core.jersey-server
554                                         </Require-Bundle>
555                                         <Import-Package>!javax.*,*;resolution:=optional</Import-Package>
556                                     </instructions>
557                                 </artifact>
558                                 <artifact>
559                                     <id>org.glassfish.jersey.media:jersey-media-json-jackson:${jersey.version}</id>
560                                     <source>true</source>
561                                     <override>true</override>
562                                     <excludes>
563                                         <exclude>com.fasterxml.jackson.*</exclude>
564                                     </excludes>
565                                     <instructions>
566                                         <Bundle-Version>${jersey.version.actual}</Bundle-Version>
567                                         <Require-Bundle>
568                                              javax.annotation,
569                                              javax.inject,
570                                              javax.servlet-api,
571                                              jakarta.validation.jakarta.validation-api,
572                                              jakarta.ws.rs-api,
573                                              jakarta.xml.bind-api,
574                                              jakarta.activation-api
575                                         </Require-Bundle>
576                                         <Import-Package>!javax.*,*;resolution:=optional</Import-Package>
577                                     </instructions>
578                                 </artifact>
579                                 <artifact>
580                                     <id>org.glassfish.jersey.containers:jersey-container-servlet-core:${jersey.version}</id>
581                                     <source>true</source>
582                                     <override>true</override>
583                                     <instructions>
584                                         <Bundle-Version>${jersey.version.actual}</Bundle-Version>
585                                         <Require-Bundle>
586                                              javax.annotation,
587                                              javax.inject,
588                                              javax.servlet-api,
589                                              jakarta.validation.jakarta.validation-api,
590                                              jakarta.ws.rs-api,
591                                              jakarta.xml.bind-api,
592                                              jakarta.activation-api
593                                         </Require-Bundle>
594                                         <Import-Package>!javax.*,*;resolution:=optional</Import-Package>
595                                     </instructions>
596                                 </artifact>
597                                 <artifact>
598                                     <id>org.glassfish.jersey.inject:jersey-hk2:${jersey.version}</id>
599                                     <source>true</source>
600                                     <override>true</override>
601                                     <instructions>
602                                         <Bundle-Version>${jersey.version.actual}</Bundle-Version>
603                                         <Require-Bundle>
604                                              javax.annotation,
605                                              javax.inject,
606                                              javax.servlet-api,
607                                              jakarta.validation.jakarta.validation-api,
608                                              jakarta.ws.rs-api,
609                                              jakarta.xml.bind-api,
610                                              jakarta.activation-api
611                                         </Require-Bundle>
612                                         <Import-Package>!javax.*,*;resolution:=optional</Import-Package>
613                                     </instructions>
614                                 </artifact>
615                                 <artifact>
616                                     <id>org.jboss.windup.decompiler:decompiler-procyon:${decompiler-procyon.version}</id>
617                                     <source>true</source>
618                                 </artifact>
619                                 <artifact>
620                                     <id>org.jsoup:jsoup:${jsoup.version}</id>
621                                     <source>true</source>
622                                 </artifact>
623                                 <artifact>
624                                     <id>org.yaml:snakeyaml:${snakeyaml.version}</id>
625                                     <source>true</source>
626                                 </artifact>
627                                 <artifact>
628                                     <id>org.eclipse.jetty:jetty-servlets:${jetty945.version}</id>
629                                     <source>true</source>
630                                 </artifact>
631                                 <artifact>
632                                     <id>org.zeroturnaround:zt-exec:${zeroturnaround.version}</id>
633                                     <source>true</source>
634                                 </artifact>
635                                 <!-- Since 1.21.0 grpc, a manually set up plugin is provided in third-party repository.
636                                      Note: grpc-core, grpc-context, and grpc-stub (maybe others as well) must be bundled into same plug-in, since they contain split packages.
637                                      See:
638                                        * https://github.com/grpc/grpc-java/issues/2727
639                                        * https://github.com/grpc/grpc-java/issues/3522
640                                 <artifact>
641                                     <id>io.grpc:io.grpc:${grpc.version}</id>
642                                     <source>true</source>
643                                 </artifact>
644                                 <artifact>
645                                     <id>io.grpc:grpc-netty:${grpc.version}</id>
646                                     <source>true</source>
647                                     <override>true</override>
648                                     <instructions>
649                                         <Require-Bundle>
650                                              io.netty.buffer;bundle-version="4.1.27",
651                                              io.netty.codec;bundle-version="4.1.27",
652                                              io.netty.codec-http;bundle-version="4.1.27",
653                                              io.netty.codec-http2;bundle-version="4.1.27",
654                                              io.netty.codec-socks;bundle-version="4.1.27",
655                                              io.netty.common;bundle-version="4.1.27",
656                                              io.netty.handler;bundle-version="4.1.27",
657                                              io.netty.handler-proxy;bundle-version="4.1.27",
658                                              io.netty.resolver;bundle-version="4.1.27",
659                                              io.netty.transport;bundle-version="4.1.27",
660                                              io.grpc
661                                         </Require-Bundle>
662                                         <Import-Package>!io.netty.*,*;resolution:=optional</Import-Package>
663                                         <Require-Capability>
664                                             osgi.extender;
665                                                 filter:="(osgi.extender=osgi.serviceloader.registrar)"
666                                         </Require-Capability>
667                                         <Provide-Capability>
668                                             osgi.serviceloader;
669                                                 osgi.serviceloader=io.grpc.ServerProvider,
670                                             osgi.serviceloader;
671                                                 osgi.serviceloader=io.grpc.ManagedChannelProvider
672                                         </Provide-Capability>
673                                         <Bundle-Version>${grpc.version.actual}</Bundle-Version>
674                                     </instructions>
675                                 </artifact>
676                                 <artifact>
677                                     <id>com.google.protobuf:protobuf-java:${protobuf.version}</id>
678                                     <source>true</source>
679                                     <override>true</override>
680                                     <instructions>
681                                         <Import-Package>!sun.misc.*,*;resolution:=optional</Import-Package>
682                                     </instructions>
683                                 </artifact>
684                                 -->
685                                 <!-- grpc 1.21.0 dependencies -->
686                                 <artifact>
687                                     <id>io.opencensus:opencensus-api:0.21.0</id>
688                                     <source>true</source>
689                                 </artifact>
690                                 <artifact>
691                                     <id>com.google.code.gson:gson:2.7</id>
692                                     <source>true</source>
693                                 </artifact>
694                                 <artifact>
695                                     <id>com.google.android:annotations:4.1.1.4</id>
696                                     <source>true</source>
697                                 </artifact>
698                                 <artifact>
699                                     <id>io.opencensus:opencensus-contrib-grpc-metrics:0.21.0</id>
700                                     <source>true</source>
701                                 </artifact>
702                                 <artifact>
703                                     <id>com.google.protobuf:protobuf-java:${protobuf.version}</id>
704                                     <source>true</source>
705                                 </artifact>
706                                 <artifact>
707                                     <id>com.google.api.grpc:proto-google-common-protos:1.12.0</id>
708                                     <source>true</source>
709                                 </artifact>
710                                 <artifact>
711                                     <id>com.google.errorprone:error_prone_annotations:2.3.2</id>
712                                     <source>true</source>
713                                 </artifact>
714
715                                 <!-- Netty is needed by com.impossibl.pgjdbc-ng:pgjdbc-ng:0.7.1 -->
716                                 <artifact>
717                                     <id>io.netty:netty-buffer:${netty.version}</id>
718                                     <source>true</source>
719                                     <transitive>true</transitive>
720                                 </artifact>
721                                 <artifact>
722                                     <id>io.netty:netty-codec:${netty.version}</id>
723                                     <source>true</source>
724                                     <transitive>true</transitive>
725                                 </artifact>
726                                 <artifact>
727                                     <id>io.netty:netty-codec-http:${netty.version}</id>
728                                     <source>true</source>
729                                     <transitive>true</transitive>
730                                 </artifact>
731                                 <artifact>
732                                     <id>io.netty:netty-codec-http2:${netty.version}</id>
733                                     <source>true</source>
734                                     <transitive>true</transitive>
735                                 </artifact>
736                                 <artifact>
737                                     <id>io.netty:netty-codec-socks:${netty.version}</id>
738                                     <source>true</source>
739                                     <transitive>true</transitive>
740                                 </artifact>
741                                 <artifact>
742                                     <id>io.netty:netty-common:${netty.version}</id>
743                                     <source>true</source>
744                                     <transitive>true</transitive>
745                                 </artifact>
746                                 <artifact>
747                                     <id>io.netty:netty-handler:${netty.version}</id>
748                                     <source>true</source>
749                                     <transitive>true</transitive>
750                                 </artifact>
751                                 <artifact>
752                                     <id>io.netty:netty-handler-proxy:${netty.version}</id>
753                                     <source>true</source>
754                                     <transitive>true</transitive>
755                                 </artifact>
756                                 <artifact>
757                                     <id>io.netty:netty-resolver:${netty.version}</id>
758                                     <source>true</source>
759                                     <transitive>true</transitive>
760                                 </artifact>
761                                 <artifact>
762                                     <id>io.netty:netty-transport:${netty.version}</id>
763                                     <source>true</source>
764                                     <transitive>true</transitive>
765                                 </artifact>
766                                 <artifact>
767                                     <id>com.impossibl.pgjdbc-ng:pgjdbc-ng:${pgjdbc-ng.version}</id>
768                                     <source>true</source>
769                                     <transitive>false</transitive>
770                                 </artifact>
771                                 <artifact>
772                                     <id>com.github.ben-manes.caffeine:caffeine:${caffeine.version}</id>
773                                     <source>true</source>
774                                     <override>true</override>
775                                     <instructions>
776                                         <Bundle-SymbolicName>com.github.benmanes.caffeine</Bundle-SymbolicName>
777                                     </instructions>
778                                 </artifact>
779                                 <artifact>
780                                     <id>net.jcip:jcip-annotations:${jcip-annotations.version}</id>
781                                     <source>true</source>
782                                 </artifact>
783                                 <artifact>
784                                     <id>com.influxdb:influxdb-client-java:${influxdb.client.version}</id>
785                                     <source>true</source>
786                                 </artifact>
787                             </artifacts>
788                         </configuration>
789                     </execution>
790                 </executions>
791             </plugin>
792
793             <plugin>
794                 <groupId>org.mortbay.jetty</groupId>
795                 <artifactId>jetty-maven-plugin</artifactId>
796                 <version>8.1.5.v20120716</version>
797                 <configuration>
798                     <scanIntervalSeconds>10</scanIntervalSeconds>
799                     <webAppSourceDirectory>${basedir}/target/repository/</webAppSourceDirectory>
800                     <webApp>
801                         <contextPath>/site</contextPath>
802                     </webApp>
803                 </configuration>
804             </plugin>
805         </plugins>
806     </build>
807
808 </project>