Do not require bundles in jersey but make package imports optional
[simantics/platform.git] / releng / org.simantics.sdk.build.p2.site / pom.xml
1 <?xml version="1.0" encoding="UTF-8"?>
2 <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001 XMLSchema-instance"
3         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
4         <modelVersion>4.0.0</modelVersion>
5
6     <groupId>org.simantics</groupId>
7     <artifactId>org.simantics.sdk.build.p2.site</artifactId>
8     <packaging>pom</packaging>
9     <version>1.30.0</version>
10
11     <properties>
12         <itext.version.actual>2.1.7.b1</itext.version.actual>
13         <antlr.version>3.5.2</antlr.version>
14         <commons-codec.version>1.14</commons-codec.version>
15         <lucene.version>4.9.0</lucene.version>
16         <lucene.version.actual>4.9.0.b0003</lucene.version.actual>
17         <lucene.prefix>org.apache.lucene4</lucene.prefix>
18         <jaxen.version>1.2.0</jaxen.version>
19         <jdom.version>2.0.6</jdom.version>
20         <jdom.version.actual>2.0.6.b0001</jdom.version.actual>
21         <jackson.version>2.10.2</jackson.version>
22         <jackson.version.actual>2.10.2.b0001</jackson.version.actual>
23         <javax.version>3.1.0</javax.version>
24         <jakarta.version>2.1.6</jakarta.version>
25         <jakarta.activation-api.version>1.2.1</jakarta.activation-api.version>
26         <jakarta.activation-api.version.actual>1.2.1.b0001</jakarta.activation-api.version.actual>
27         <!-- This can be removed once jakarta version is bumped -->
28         <jakarta.version.actual>2.1.6.b0005</jakarta.version.actual>
29         <jersey.version>2.30.1</jersey.version>
30         <!-- This can be removed once jersey version is bumped -->
31         <jersey.version.actual>2.30.1.b0008</jersey.version.actual>
32         <jfreechart.version>1.5.0</jfreechart.version>
33         <slf4j.version>1.7.30</slf4j.version>
34         <slf4j.version.actual>1.7.30</slf4j.version.actual>
35         <grpc.version>1.27.2</grpc.version>
36         <grpc.version.actual>1.27.2</grpc.version.actual>
37         <protobuf.version>3.11.4</protobuf.version>
38         <zeroturnaround.version>1.11</zeroturnaround.version>
39         <caffeine.version>2.8.1</caffeine.version>
40         <influxdb.client.version>1.5.0</influxdb.client.version>
41         <supercsv.version>2.4.0</supercsv.version>
42         <ini4j.version>0.5.4</ini4j.version>
43         <commons-collections.version>4.4</commons-collections.version>
44         <commons-compress.version>1.20</commons-compress.version>
45         <commons-lang.version>2.6</commons-lang.version>
46         <commons-logging.version>1.2</commons-logging.version>
47         <commons-io.version>1.4</commons-io.version>
48         <commons-math.version>3.6.1</commons-math.version>
49         <pdfbox.version>2.0.19</pdfbox.version>
50         <fontbox.version>2.0.19</fontbox.version>
51         <xmpbox.version>2.0.19</xmpbox.version>
52         <log4j.version>1.2.17</log4j.version>
53         <ucanaccess.version>3.0.7</ucanaccess.version>
54         <fastutil.version>8.3.1</fastutil.version>
55         <trove4j.version>3.0.3</trove4j.version>
56         <freemarker.version>2.3.29</freemarker.version>
57         <itext.version>2.1.7</itext.version>
58         <rhino.version>1.7.12</rhino.version>
59         <jna41.version>4.1.0</jna41.version>
60         <jna.version>4.5.2</jna.version>
61         <logback-classic.version>1.2.3</logback-classic.version>
62         <koloboke-compile.version>0.5.1</koloboke-compile.version>
63         <koloboke-impl-common-jdk8.version>1.0.0</koloboke-impl-common-jdk8.version>
64         <kryo.version>4.0.2</kryo.version>
65         <org.apache.aries.spifly.dynamic.bundle.version>1.2.3</org.apache.aries.spifly.dynamic.bundle.version>
66         <decompiler-procyon.version>4.3.0.Final</decompiler-procyon.version>
67         <jsoup.version>1.12.2</jsoup.version>
68         <snakeyaml.version>1.25</snakeyaml.version>
69         <jetty945.version>9.4.24.v20191120</jetty945.version>
70         <netty.version>4.1.45.Final</netty.version>
71         <jcip-annotations.version>1.0</jcip-annotations.version>
72         <pgjdbc-ng.version>0.8.3</pgjdbc-ng.version>
73     </properties>
74
75     <repositories>
76         <!--
77         <repository>
78             <id>project-specific-deps</id>
79             <name>project-specific-deps</name>
80             <url>file:///${basedir}/repo</url>
81         </repository>c.version.actual
82         --> 
83     </repositories>
84
85     <build>
86         <plugins>
87             <plugin>
88                 <groupId>org.eclipse.tycho.extras</groupId>
89                 <artifactId>tycho-p2-extras-plugin</artifactId>
90                 <version>1.0.0</version>
91             </plugin>
92             <plugin>
93                 <groupId>org.reficio</groupId>
94                 <artifactId>p2-maven-plugin</artifactId>
95                 <version>1.2.0</version>
96                 <executions>
97                     <execution>
98                         <id>default-cli</id>
99                         <!-- QUICK-START EXAMPLE -->
100                         <!--
101                         This is the default quick-start configuration.
102
103                         Expected behavior:
104                           - specified dependencies will be fetched
105                           - transitive dependencies will be fetched (no default exclusions)
106                           - jars containing source source code will NOT be fetched
107                           - jars that are NOT OSGi bundles will be "bundled" using bnd tool,
108                             if you specify instructions for these jars they will be APPLIED
109                           - jars that are OSGi bundles will be simply included
110                             if you specify instructions for these jars they will be IGNORED (see <override> option)
111                           - p2 site will be generated
112
113                         How the instructions works:
114                           - instructions are applied only to the root artifact that you specify!
115                           - instructions are not applied to the TRANSITIVE dependencies!
116                           - transitive dependencies are never overridden (see <override> option)
117                           - transitive dependencies are bundled using the default instructions:
118                               <instructions>
119                                   <Import-Package>*;resolution:=optional</Import-Package>
120                                   <Export-Package>*</Export-Package>
121                               </instructions>
122                           - other instructions, such as, Bundle-SymbolicName, Bundle-Name, Bundle-Version, etc.
123                             are calculated according to the following rules:
124                             http://felix.apache.org/site/apache-felix-maven-bundle-plugin-bnd.html
125                           - if you specify any instructions they will be applied only if
126                             the jar is not already an OSGi bundle - otherwise you have to use the override
127                             option - please see the /examples/override/pom.xml example
128
129                         The following definition of an artifact:
130                             <artifact>
131                                 <id>commons-io:commons-io:2.1</id>
132                             </artifact>
133
134                         is an equivalent of the following definition:
135                             <artifact>
136                                 <id>commons-io:commons-io:2.1</id>
137                                 <transitive>true</transitive>
138                                 <source>false</source>
139                                 <override>false</override>
140                                 <instructions>
141                                     <Import-Package>*;resolution:=optional</Import-Package>
142                                     <Export-Package>*</Export-Package>
143                                 </instructions>
144                                 <excludes/>
145                             </artifact>
146
147                         To run the example please invoke: mvn p2:site
148                         -->
149                         <configuration>
150                             <artifacts>
151                                 <artifact>
152                                     <id>org.antlr:antlr-runtime:${antlr.version}</id>
153                                     <source>true</source>
154                                     <instructions>
155                                         <Bundle-SymbolicName>org.antlr.runtime</Bundle-SymbolicName>
156                                         <Bundle-Version>${antlr.version}</Bundle-Version>
157                                         <Export-Package>*;version="${antlr.version}"</Export-Package>
158                                     </instructions>                                    
159                                 </artifact>
160                                 <artifact>
161                                     <id>org.apache.lucene:lucene-core:${lucene.version}</id>
162                                     <source>true</source>
163                                     <instructions>
164                                         <Bundle-SymbolicName>${lucene.prefix}.core</Bundle-SymbolicName>
165                                         <Bundle-Version>${lucene.version.actual}</Bundle-Version>
166                                         <Export-Package>*;version="${lucene.version}"</Export-Package>
167                                     </instructions>
168                                 </artifact>
169                                 <artifact>
170                                     <id>org.apache.lucene:lucene-queries:${lucene.version}</id>
171                                     <source>true</source>
172                                     <instructions>
173                                         <Bundle-SymbolicName>${lucene.prefix}.queries</Bundle-SymbolicName>
174                                         <Bundle-Version>${lucene.version.actual}</Bundle-Version>
175                                         <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}"</Require-Bundle>
176                                         <Export-Package>*;version="${lucene.version}"</Export-Package>
177                                         <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>
178                                     </instructions>
179                                 </artifact>
180                                 <artifact>
181                                     <id>org.apache.lucene:lucene-sandbox:${lucene.version}</id>
182                                     <source>true</source>
183                                     <instructions>
184                                         <Bundle-SymbolicName>${lucene.prefix}.sandbox</Bundle-SymbolicName>
185                                         <Bundle-Version>${lucene.version.actual}</Bundle-Version>
186                                         <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}"</Require-Bundle>
187                                         <Export-Package>*;version="${lucene.version}"</Export-Package>
188                                         <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>
189                                     </instructions>
190                                 </artifact>
191                                 <artifact>
192                                     <id>org.apache.lucene:lucene-analyzers-common:${lucene.version}</id>
193                                     <source>true</source>
194                                     <instructions>
195                                         <Bundle-SymbolicName>${lucene.prefix}.analyzers-common</Bundle-SymbolicName>
196                                         <Bundle-Version>${lucene.version.actual}</Bundle-Version>
197                                         <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}"</Require-Bundle>
198                                         <Export-Package>*;version="${lucene.version}"</Export-Package>
199                                         <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>
200                                     </instructions>
201                                 </artifact>
202                                 <artifact>
203                                     <id>org.apache.lucene:lucene-queryparser:${lucene.version}</id>
204                                     <source>true</source>
205                                     <instructions>
206                                         <Bundle-SymbolicName>${lucene.prefix}.queryparser</Bundle-SymbolicName>
207                                         <Bundle-Version>${lucene.version.actual}</Bundle-Version>
208                                         <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}",${lucene.prefix}.queries;bundle-version="${lucene.version}",${lucene.prefix}.sandbox;bundle-version="${lucene.version}"</Require-Bundle>
209                                         <Export-Package>*;version="${lucene.version}"</Export-Package>
210                                         <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>
211                                     </instructions>
212                                 </artifact>
213                                 <artifact>
214                                     <id>jaxen:jaxen:${jaxen.version}</id>
215                                     <source>true</source>
216                                 </artifact>
217                                 <artifact>
218                                     <id>org.jdom:jdom2:${jdom.version}</id>
219                                     <source>true</source>
220                                     <instructions>
221                                         <Bundle-SymbolicName>org.jdom2</Bundle-SymbolicName>
222                                         <Bundle-Version>${jdom.version.actual}</Bundle-Version>
223                                         <Export-Package>*;version="${jdom.version}"</Export-Package>
224                                     </instructions>
225                                 </artifact>
226                                 <artifact>
227                                     <id>org.jfree:jfreechart:${jfreechart.version}</id>
228                                     <source>true</source>
229                                     <instructions>
230                                         <Bundle-SymbolicName>org.jfree.jchart</Bundle-SymbolicName>
231                                     </instructions>
232                                 </artifact>
233                                 <!--
234                                 <artifact>
235                                     <id>org.ow2.asm:asm:5.0.4</id>
236                                     <source>true</source>
237                                     <override>true</override>
238                                     <instructions>
239                                         <Bundle-SymbolicName>org.objectweb.asm5</Bundle-SymbolicName>
240                                     </instructions>
241                                 </artifact>
242                                 -->
243                                 <artifact>
244                                     <id>net.sf.supercsv:super-csv:${supercsv.version}</id>
245                                     <source>true</source>
246                                     <override>true</override>
247                                     <instructions>
248                                         <Bundle-SymbolicName>org.supercsv</Bundle-SymbolicName>
249                                     </instructions>
250                                 </artifact>
251                                 <artifact>
252                                     <id>org.ini4j:ini4j:${ini4j.version}</id>
253                                     <source>true</source>
254                                 </artifact>
255                                 <artifact>
256                                     <!-- Needed by Apache POI 3.15 -->
257                                     <id>commons-codec:commons-codec:${commons-codec.version}</id>
258                                     <source>true</source>
259                                 </artifact>
260                                 <artifact>
261                                     <!-- Needed by Apache POI 3.15 -->
262                                     <id>org.apache.commons:commons-collections4:${commons-collections.version}</id>
263                                     <source>true</source>
264                                 </artifact>
265                                 <artifact>
266                                     <id>org.apache.commons:commons-compress:${commons-compress.version}</id>
267                                     <source>true</source>
268                                     <override>true</override>
269                                     <instructions>
270                                         <Bundle-SymbolicName>org.apache.commons.compress</Bundle-SymbolicName>
271                                     </instructions>
272                                 </artifact>
273                                 <artifact>
274                                     <id>commons-lang:commons-lang:${commons-lang.version}</id>
275                                     <source>true</source>
276                                 </artifact>
277                                 <artifact>
278                                     <!-- Needed by Apache POI 3.15 -->
279                                     <id>commons-logging:commons-logging:${commons-logging.version}</id>
280                                     <source>true</source>
281                                 </artifact>
282                                 <artifact>
283                                     <id>commons-io:commons-io:${commons-io.version}</id>
284                                     <source>true</source>
285                                 </artifact>
286                                 <artifact>
287                                     <id>org.apache.commons:commons-math3:${commons-math.version}</id>
288                                     <source>true</source>
289                                 </artifact>
290
291                                 <artifact>
292                                     <id>org.apache.pdfbox:pdfbox:${pdfbox.version}</id>
293                                     <source>true</source>
294                                 </artifact>
295                                 <artifact>
296                                     <id>org.apache.pdfbox:fontbox:${fontbox.version}</id>
297                                     <source>true</source>
298                                 </artifact>
299                                 <artifact>
300                                     <id>org.apache.pdfbox:xmpbox:${xmpbox.version}</id>
301                                     <source>true</source>
302                                 </artifact>
303                                 <!-- Needed by Apache POI 3.15, however these are included in third-party repository manually -->
304                                 <!--
305                                 <artifact>
306                                     <id>org.apache.xmlbeans:xmlbeans:2.6.0</id>
307                                     <source>true</source>
308                                 </artifact>
309                                 <artifact>
310                                     <id>com.github.virtuald:curvesapi:1.04</id>
311                                     <source>true</source>
312                                 </artifact>
313                                 -->
314                                 <artifact>
315                                     <id>log4j:log4j:${log4j.version}</id>
316                                     <source>true</source>
317                                     <override>true</override>
318                                     <instructions>
319                                         <Bundle-SymbolicName>org.apache.log4j</Bundle-SymbolicName>
320                                     </instructions>
321                                 </artifact>
322                                 <artifact>
323                                     <id>net.sf.ucanaccess:ucanaccess:${ucanaccess.version}</id>
324                                     <source>true</source>
325                                     <instructions>
326                                         <Bundle-SymbolicName>net.ucanaccess</Bundle-SymbolicName>
327                                     </instructions>
328                                 </artifact>
329                                 <artifact>
330                                     <id>it.unimi.dsi:fastutil:${fastutil.version}</id>
331                                     <source>true</source>
332                                 </artifact>
333                                 <artifact>
334                                     <id>net.sf.trove4j:trove4j:${trove4j.version}</id>
335                                     <source>true</source>
336                                     <instructions>
337                                         <Bundle-Name>GNU Trove 3</Bundle-Name>
338                                         <Bundle-SymbolicName>gnu.trove3</Bundle-SymbolicName>
339                                     </instructions>
340                                 </artifact>
341                                 <artifact>
342                                     <id>org.freemarker:freemarker:${freemarker.version}</id>
343                                     <source>true</source>
344                                     <override>true</override>
345                                     <instructions>
346                                         <Bundle-SymbolicName>freemarker</Bundle-SymbolicName>
347                                     </instructions>
348                                 </artifact>
349                                 <artifact>
350                                     <id>com.lowagie:itext:${itext.version}</id>
351                                     <source>true</source>
352                                     <instructions>
353                                         <Bundle-SymbolicName>com.lowagie.text</Bundle-SymbolicName>
354                                         <Bundle-Version>${itext.version.actual}</Bundle-Version>
355                                     </instructions>
356                                 </artifact>
357                                 <artifact>
358                                     <id>org.mozilla:rhino:${rhino.version}</id>
359                                     <source>true</source>
360                                 </artifact>
361                                 <artifact>
362                                     <id>javax.servlet:javax.servlet-api:${javax.version}</id>
363                                     <source>true</source>
364                                 </artifact>
365                                 <artifact>
366                                     <id>com.fasterxml.jackson.core:jackson-core:${jackson.version}</id>
367                                     <source>true</source>
368                                 </artifact>
369                                 <artifact>
370                                     <id>com.fasterxml.jackson.core:jackson-annotations:${jackson.version}</id>
371                                     <source>true</source>
372                                 </artifact>
373                                 <artifact>
374                                     <id>com.fasterxml.jackson.core:jackson-databind:${jackson.version}</id>
375                                     <source>true</source>
376                                     <excludes>
377                                         <exclude>com.fasterxml.jackson.*</exclude>
378                                     </excludes>
379                                 </artifact>
380                                 <artifact>
381                                     <id>com.fasterxml.jackson.dataformat:jackson-dataformat-csv:${jackson.version}</id>
382                                     <source>true</source>
383                                     <excludes>
384                                         <exclude>com.fasterxml.jackson.*</exclude>
385                                     </excludes>
386                                 </artifact>
387                                 <artifact>
388                                     <id>com.fasterxml.jackson.dataformat:jackson-dataformat-xml:${jackson.version}</id>
389                                     <source>true</source>
390                                     <excludes>
391                                         <exclude>com.fasterxml.jackson.*</exclude>
392                                     </excludes>
393                                 </artifact>
394                                 <artifact>
395                                     <id>com.fasterxml.jackson.datatype:jackson-datatype-jsr310:${jackson.version}</id>
396                                     <source>true</source>
397                                     <excludes>
398                                         <exclude>com.fasterxml.jackson.*</exclude>
399                                     </excludes>
400                                 </artifact>
401                                 <artifact>
402                                     <id>com.fasterxml.jackson.jaxrs:jackson-jaxrs-base:${jackson.version}</id>
403                                     <source>true</source>
404                                     <excludes>
405                                         <exclude>com.fasterxml.jackson.*</exclude>
406                                     </excludes>
407                                 </artifact>
408                                 <artifact>
409                                     <id>com.fasterxml.jackson.jaxrs:jackson-jaxrs-json-provider:${jackson.version}</id>
410                                     <source>true</source>
411                                     <excludes>
412                                         <exclude>com.fasterxml.jackson.*</exclude>
413                                     </excludes>
414                                 </artifact>
415                                 <artifact>
416                                     <id>com.fasterxml.jackson.module:jackson-module-jaxb-annotations:${jackson.version}</id>
417                                     <source>true</source>
418                                     <excludes>
419                                         <exclude>com.fasterxml.jackson.*</exclude>
420                                     </excludes>
421                                 </artifact>
422                                 <artifact>
423                                     <id>org.slf4j:slf4j-api:${slf4j.version}</id>
424                                     <source>true</source>
425                                     <override>true</override>
426                                     <instructions>
427                                         <Bundle-Name>SLF4J API Module</Bundle-Name>
428                                         <Bundle-Version>${slf4j.version.actual}</Bundle-Version>
429                                         <Bundle-SymbolicName>org.slf4j.api</Bundle-SymbolicName>
430                                         <Export-Package>*;version=${slf4j.version}</Export-Package>
431                                     </instructions>
432                                 </artifact>
433                                 <artifact>
434                                     <id>ch.qos.logback:logback-classic:${logback-classic.version}</id>
435                                     <source>true</source>
436                                     <override>true</override>
437                                 </artifact>
438                                 <artifact>
439                                     <id>com.koloboke:koloboke-compile:${koloboke-compile.version}</id>
440                                     <source>true</source>
441                                 </artifact>
442                                 <artifact>
443                                     <id>com.koloboke:koloboke-impl-common-jdk8:${koloboke-impl-common-jdk8.version}</id>
444                                     <source>true</source>
445                                 </artifact>
446                                 <artifact>
447                                     <id>com.esotericsoftware:kryo:${kryo.version}</id>
448                                     <source>true</source>
449                                 </artifact>
450                                  <artifact>
451                                      <id>org.apache.aries.spifly:org.apache.aries.spifly.dynamic.bundle:${org.apache.aries.spifly.dynamic.bundle.version}</id>
452                                      <source>true</source>
453                                  </artifact>
454                                 <artifact>
455                                     <id>jakarta.activation:jakarta.activation-api:${jakarta.activation-api.version}</id>
456                                     <source>true</source>
457                                     <override>true</override>
458                                     <instructions>
459                                         <Bundle-Version>${jakarta.activation-api.version.actual}</Bundle-Version>
460                                         <Import-Package>*;resolution:=optional</Import-Package>
461                                     </instructions>
462                                 </artifact>
463                                 <artifact>
464                                     <id>jakarta.ws.rs:jakarta.ws.rs-api:${jakarta.version}</id>
465                                     <source>true</source>
466                                     <override>true</override>
467                                     <instructions>
468                                         <Bundle-Version>${jakarta.version.actual}</Bundle-Version>
469                                         <Require-Bundle>
470                                              jakarta.xml.bind-api
471                                         </Require-Bundle>
472                                         <Import-Package>!javax.*,*;resolution:=optional</Import-Package>
473                                         <Export-Package>
474                                             javax.ws.rs;version="${jakarta.version}",
475                                             javax.ws.rs.core;version="${jakarta.version}",
476                                             javax.ws.rs.ext;version="${jakarta.version}",
477                                             javax.ws.rs.client;version="${jakarta.version}",
478                                             javax.ws.rs.container;version="${jakarta.version}",
479                                             javax.ws.rs.sse;version="${jakarta.version}"
480                                         </Export-Package>
481                                     </instructions>
482                                 </artifact>
483                                 <artifact>
484                                     <id>org.glassfish.jersey.core:jersey-common:${jersey.version}</id>
485                                     <source>true</source>
486                                     <override>true</override>
487                                     <instructions>
488                                         <Bundle-Version>${jersey.version.actual}</Bundle-Version>
489                                         <!-- <Require-Bundle>
490                                              javax.annotation,
491                                              javax.inject,
492                                              javax.servlet-api,
493                                              jakarta.validation.jakarta.validation-api,
494                                              jakarta.ws.rs-api,
495                                              jakarta.xml.bind-api,
496                                              jakarta.activation-api
497                                         </Require-Bundle> -->
498                                         <Import-Package>*;resolution:=optional</Import-Package>
499                                         <Export-Package>
500                                             org.glassfish.jersey.*;version="${jersey.version}"
501                                         </Export-Package>
502                                     </instructions>
503                                 </artifact>
504                                 <artifact>
505                                     <id>org.glassfish.jersey.core:jersey-server:${jersey.version}</id>
506                                     <source>true</source>
507                                     <override>true</override>
508                                     <instructions>
509                                         <Bundle-Version>${jersey.version.actual}</Bundle-Version>
510                                         <!-- <Require-Bundle>
511                                              javax.annotation,
512                                              javax.inject,
513                                              javax.servlet-api,
514                                              jakarta.validation.jakarta.validation-api,
515                                              jakarta.ws.rs-api,
516                                              jakarta.xml.bind-api,
517                                              jakarta.activation-api
518                                         </Require-Bundle> -->
519                                         <Import-Package>*;resolution:=optional</Import-Package>
520                                     </instructions>
521                                 </artifact>
522                                 <artifact>
523                                     <id>org.glassfish.jersey.core:jersey-client:${jersey.version}</id>
524                                     <source>true</source>
525                                     <override>true</override>
526                                     <instructions>
527                                         <Bundle-Version>${jersey.version.actual}</Bundle-Version>
528                                         <!-- <Require-Bundle>
529                                              javax.annotation,
530                                              javax.inject,
531                                              javax.servlet-api,
532                                              jakarta.validation.jakarta.validation-api,
533                                              jakarta.ws.rs-api,
534                                              jakarta.xml.bind-api,
535                                              jakarta.activation-api
536                                         </Require-Bundle> -->
537                                         <Import-Package>*;resolution:=optional</Import-Package>
538                                     </instructions>
539                                 </artifact>
540                                 
541                                 <artifact>
542                                     <id>org.glassfish.jersey.media:jersey-media-multipart:${jersey.version}</id>
543                                     <source>true</source>
544                                     <!-- For some reason p2-maven-plugin does not work with the below plugin and only generates sources for that -->
545                                     <!-- <override>true</override>
546                                     <instructions>
547                                         <Bundle-Version>${jersey.version.actual}</Bundle-Version>
548                                         <Require-Bundle>
549                                              jakarta.ws.rs-api,
550                                         </Require-Bundle>
551                                         <Import-Package>!javax.*,*;resolution:=optional</Import-Package>
552                                     </instructions> -->
553                                 </artifact>
554                                 <artifact>
555                                     <id>org.glassfish.jersey.ext:jersey-entity-filtering:${jersey.version}</id>
556                                     <source>true</source>
557                                     <override>true</override>
558                                     <instructions>
559                                         <Bundle-Version>${jersey.version.actual}</Bundle-Version>
560                                         <!-- <Require-Bundle>
561                                              jakarta.ws.rs-api,
562                                              jakarta.activation-api,
563                                              javax.servlet-api,
564                                              org.glassfish.jersey.core.jersey-server
565                                         </Require-Bundle> -->
566                                         <Import-Package>*;resolution:=optional</Import-Package>
567                                     </instructions>
568                                 </artifact>
569                                 <artifact>
570                                     <id>org.glassfish.jersey.media:jersey-media-json-jackson:${jersey.version}</id>
571                                     <source>true</source>
572                                     <override>true</override>
573                                     <excludes>
574                                         <exclude>com.fasterxml.jackson.*</exclude>
575                                     </excludes>
576                                     <instructions>
577                                         <Bundle-Version>${jersey.version.actual}</Bundle-Version>
578                                         <!-- <Require-Bundle>
579                                              javax.annotation,
580                                              javax.inject,
581                                              javax.servlet-api,
582                                              jakarta.validation.jakarta.validation-api,
583                                              jakarta.ws.rs-api,
584                                              jakarta.xml.bind-api,
585                                              jakarta.activation-api
586                                         </Require-Bundle> -->
587                                         <Import-Package>*;resolution:=optional</Import-Package>
588                                     </instructions>
589                                 </artifact>
590                                 <artifact>
591                                     <id>org.glassfish.jersey.containers:jersey-container-servlet-core:${jersey.version}</id>
592                                     <source>true</source>
593                                     <override>true</override>
594                                     <instructions>
595                                         <Bundle-Version>${jersey.version.actual}</Bundle-Version>
596                                         <!-- <Require-Bundle>
597                                              javax.annotation,
598                                              javax.inject,
599                                              javax.servlet-api,
600                                              jakarta.validation.jakarta.validation-api,
601                                              jakarta.ws.rs-api,
602                                              jakarta.xml.bind-api,
603                                              jakarta.activation-api
604                                         </Require-Bundle> -->
605                                         <Import-Package>*;resolution:=optional</Import-Package>
606                                     </instructions>
607                                 </artifact>
608                                 <artifact>
609                                     <id>org.glassfish.jersey.inject:jersey-hk2:${jersey.version}</id>
610                                     <source>true</source>
611                                     <override>true</override>
612                                     <instructions>
613                                         <Bundle-Version>${jersey.version.actual}</Bundle-Version>
614                                         <!-- <Require-Bundle>
615                                              javax.annotation,
616                                              javax.inject,
617                                              javax.servlet-api,
618                                              jakarta.validation.jakarta.validation-api,
619                                              jakarta.ws.rs-api,
620                                              jakarta.xml.bind-api,
621                                              jakarta.activation-api
622                                         </Require-Bundle> -->
623                                         <Import-Package>*;resolution:=optional</Import-Package>
624                                     </instructions>
625                                 </artifact>
626                                 <artifact>
627                                     <id>org.jboss.windup.decompiler:decompiler-procyon:${decompiler-procyon.version}</id>
628                                     <source>true</source>
629                                 </artifact>
630                                 <artifact>
631                                     <id>org.jsoup:jsoup:${jsoup.version}</id>
632                                     <source>true</source>
633                                 </artifact>
634                                 <artifact>
635                                     <id>org.yaml:snakeyaml:${snakeyaml.version}</id>
636                                     <source>true</source>
637                                 </artifact>
638                                 <artifact>
639                                     <id>org.eclipse.jetty:jetty-servlets:${jetty945.version}</id>
640                                     <source>true</source>
641                                 </artifact>
642                                 <artifact>
643                                     <id>org.zeroturnaround:zt-exec:${zeroturnaround.version}</id>
644                                     <source>true</source>
645                                 </artifact>
646                                 <!-- Since 1.21.0 grpc, a manually set up plugin is provided in third-party repository.
647                                      Note: grpc-core, grpc-context, and grpc-stub (maybe others as well) must be bundled into same plug-in, since they contain split packages.
648                                      See:
649                                        * https://github.com/grpc/grpc-java/issues/2727
650                                        * https://github.com/grpc/grpc-java/issues/3522
651                                 <artifact>
652                                     <id>io.grpc:io.grpc:${grpc.version}</id>
653                                     <source>true</source>
654                                 </artifact>
655                                 <artifact>
656                                     <id>io.grpc:grpc-netty:${grpc.version}</id>
657                                     <source>true</source>
658                                     <override>true</override>
659                                     <instructions>
660                                         <Require-Bundle>
661                                              io.netty.buffer;bundle-version="4.1.27",
662                                              io.netty.codec;bundle-version="4.1.27",
663                                              io.netty.codec-http;bundle-version="4.1.27",
664                                              io.netty.codec-http2;bundle-version="4.1.27",
665                                              io.netty.codec-socks;bundle-version="4.1.27",
666                                              io.netty.common;bundle-version="4.1.27",
667                                              io.netty.handler;bundle-version="4.1.27",
668                                              io.netty.handler-proxy;bundle-version="4.1.27",
669                                              io.netty.resolver;bundle-version="4.1.27",
670                                              io.netty.transport;bundle-version="4.1.27",
671                                              io.grpc
672                                         </Require-Bundle>
673                                         <Import-Package>!io.netty.*,*;resolution:=optional</Import-Package>
674                                         <Require-Capability>
675                                             osgi.extender;
676                                                 filter:="(osgi.extender=osgi.serviceloader.registrar)"
677                                         </Require-Capability>
678                                         <Provide-Capability>
679                                             osgi.serviceloader;
680                                                 osgi.serviceloader=io.grpc.ServerProvider,
681                                             osgi.serviceloader;
682                                                 osgi.serviceloader=io.grpc.ManagedChannelProvider
683                                         </Provide-Capability>
684                                         <Bundle-Version>${grpc.version.actual}</Bundle-Version>
685                                     </instructions>
686                                 </artifact>
687                                 <artifact>
688                                     <id>com.google.protobuf:protobuf-java:${protobuf.version}</id>
689                                     <source>true</source>
690                                     <override>true</override>
691                                     <instructions>
692                                         <Import-Package>!sun.misc.*,*;resolution:=optional</Import-Package>
693                                     </instructions>
694                                 </artifact>
695                                 -->
696                                 <!-- grpc 1.21.0 dependencies -->
697                                 <artifact>
698                                     <id>io.opencensus:opencensus-api:0.21.0</id>
699                                     <source>true</source>
700                                 </artifact>
701                                 <artifact>
702                                     <id>com.google.code.gson:gson:2.7</id>
703                                     <source>true</source>
704                                 </artifact>
705                                 <artifact>
706                                     <id>com.google.android:annotations:4.1.1.4</id>
707                                     <source>true</source>
708                                 </artifact>
709                                 <artifact>
710                                     <id>io.opencensus:opencensus-contrib-grpc-metrics:0.21.0</id>
711                                     <source>true</source>
712                                 </artifact>
713                                 <artifact>
714                                     <id>com.google.protobuf:protobuf-java:${protobuf.version}</id>
715                                     <source>true</source>
716                                 </artifact>
717                                 <artifact>
718                                     <id>com.google.api.grpc:proto-google-common-protos:1.12.0</id>
719                                     <source>true</source>
720                                 </artifact>
721                                 <artifact>
722                                     <id>com.google.errorprone:error_prone_annotations:2.3.2</id>
723                                     <source>true</source>
724                                 </artifact>
725
726                                 <!-- Netty is needed by com.impossibl.pgjdbc-ng:pgjdbc-ng:0.7.1 -->
727                                 <artifact>
728                                     <id>io.netty:netty-buffer:${netty.version}</id>
729                                     <source>true</source>
730                                     <transitive>true</transitive>
731                                 </artifact>
732                                 <artifact>
733                                     <id>io.netty:netty-codec:${netty.version}</id>
734                                     <source>true</source>
735                                     <transitive>true</transitive>
736                                 </artifact>
737                                 <artifact>
738                                     <id>io.netty:netty-codec-http:${netty.version}</id>
739                                     <source>true</source>
740                                     <transitive>true</transitive>
741                                 </artifact>
742                                 <artifact>
743                                     <id>io.netty:netty-codec-http2:${netty.version}</id>
744                                     <source>true</source>
745                                     <transitive>true</transitive>
746                                 </artifact>
747                                 <artifact>
748                                     <id>io.netty:netty-codec-socks:${netty.version}</id>
749                                     <source>true</source>
750                                     <transitive>true</transitive>
751                                 </artifact>
752                                 <artifact>
753                                     <id>io.netty:netty-common:${netty.version}</id>
754                                     <source>true</source>
755                                     <transitive>true</transitive>
756                                 </artifact>
757                                 <artifact>
758                                     <id>io.netty:netty-handler:${netty.version}</id>
759                                     <source>true</source>
760                                     <transitive>true</transitive>
761                                 </artifact>
762                                 <artifact>
763                                     <id>io.netty:netty-handler-proxy:${netty.version}</id>
764                                     <source>true</source>
765                                     <transitive>true</transitive>
766                                 </artifact>
767                                 <artifact>
768                                     <id>io.netty:netty-resolver:${netty.version}</id>
769                                     <source>true</source>
770                                     <transitive>true</transitive>
771                                 </artifact>
772                                 <artifact>
773                                     <id>io.netty:netty-transport:${netty.version}</id>
774                                     <source>true</source>
775                                     <transitive>true</transitive>
776                                 </artifact>
777                                 <artifact>
778                                     <id>com.impossibl.pgjdbc-ng:pgjdbc-ng:${pgjdbc-ng.version}</id>
779                                     <source>true</source>
780                                     <transitive>false</transitive>
781                                 </artifact>
782                                 <artifact>
783                                     <id>com.github.ben-manes.caffeine:caffeine:${caffeine.version}</id>
784                                     <source>true</source>
785                                     <override>true</override>
786                                     <instructions>
787                                         <Bundle-SymbolicName>com.github.benmanes.caffeine</Bundle-SymbolicName>
788                                     </instructions>
789                                 </artifact>
790                                 <artifact>
791                                     <id>net.jcip:jcip-annotations:${jcip-annotations.version}</id>
792                                     <source>true</source>
793                                 </artifact>
794                                 <artifact>
795                                     <id>com.influxdb:influxdb-client-java:${influxdb.client.version}</id>
796                                     <source>true</source>
797                                 </artifact>
798                             </artifacts>
799                         </configuration>
800                     </execution>
801                 </executions>
802             </plugin>
803
804             <plugin>
805                 <groupId>org.mortbay.jetty</groupId>
806                 <artifactId>jetty-maven-plugin</artifactId>
807                 <version>8.1.5.v20120716</version>
808                 <configuration>
809                     <scanIntervalSeconds>10</scanIntervalSeconds>
810                     <webAppSourceDirectory>${basedir}/target/repository/</webAppSourceDirectory>
811                     <webApp>
812                         <contextPath>/site</contextPath>
813                     </webApp>
814                 </configuration>
815             </plugin>
816         </plugins>
817     </build>
818
819 </project>