Tons of dependency fixes and updates
[simantics/platform.git] / releng / org.simantics.sdk.build.p2.site / pom.xml
1 <?xml version="1.0" encoding="UTF-8"?>
2 <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001 XMLSchema-instance"
3         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
4         <modelVersion>4.0.0</modelVersion>
5
6     <groupId>org.simantics</groupId>
7     <artifactId>org.simantics.sdk.build.p2.site</artifactId>
8     <packaging>pom</packaging>
9     <version>1.30.0</version>
10
11     <properties>
12         <itext.version.actual>2.1.7.b1</itext.version.actual>
13         <antlr.version>3.5.2</antlr.version>
14         <commons-codec.version>1.10</commons-codec.version>
15         <lucene.version>4.9.0</lucene.version>
16         <lucene.version.actual>4.9.0.b0003</lucene.version.actual>
17         <lucene.prefix>org.apache.lucene4</lucene.prefix>
18         <jaxen.version>1.1.6</jaxen.version>
19         <jdom.version>2.0.6</jdom.version>
20         <jdom.version.actual>2.0.6.b0001</jdom.version.actual>
21         <jackson.version>2.10.2</jackson.version>
22         <javax.version>3.1.0</javax.version>
23         <jersey.version>2.30.1</jersey.version>
24         <jfreechart.version>1.0.19</jfreechart.version>
25         <slf4j.version>1.7.30</slf4j.version>
26         <slf4j.version.actual>1.7.30</slf4j.version.actual>
27         <grpc.version>1.27.2</grpc.version>
28         <grpc.version.actual>1.27.2</grpc.version.actual>
29         <protobuf.version>3.11.4</protobuf.version>
30         <zeroturnaround.version>1.11</zeroturnaround.version>
31         <eclipse.collections.version>10.2.0</eclipse.collections.version>
32         <caffeine.version>2.8.1</caffeine.version>
33         <influxdb.client.version>1.5.0</influxdb.client.version>
34         <supercsv.version>2.4.0</supercsv.version>
35         <ini4j.version>0.5.4</ini4j.version>
36         <commons-collections.version>4.1</commons-collections.version>
37         <commons-compress.version>1.18</commons-compress.version>
38         <commons-lang.version>2.6</commons-lang.version>
39         <commons-logging.version>1.2</commons-logging.version>
40         <commons-io.version>1.4</commons-io.version>
41         <commons-math.version>3.6.1</commons-math.version>
42         <pdfbox.version>2.0.19</pdfbox.version>
43         <fontbox.version>2.0.19</fontbox.version>
44         <xmpbox.version>2.0.19</xmpbox.version>
45         <log4j.version>1.2.17</log4j.version>
46         <ucanaccess.version>3.0.7</ucanaccess.version>
47         <fastutil.version>7.2.1</fastutil.version>
48         <trove4j.version>3.0.3</trove4j.version>
49         <freemarker.version>2.3.23</freemarker.version>
50         <itext.version>2.1.7</itext.version>
51         <rhino.version>1.7.7.1</rhino.version>
52         <jna41.version>4.1.0</jna41.version>
53         <jna.version>4.3.0</jna.version>
54         <logback-classic.version>1.2.3</logback-classic.version>
55         <koloboke-compile.version>0.5.1</koloboke-compile.version>
56         <koloboke-impl-common-jdk8.version>1.0.0</koloboke-impl-common-jdk8.version>
57         <kryo.version>4.0.0</kryo.version>
58         <org.apache.aries.spifly.dynamic.bundle.version>1.2.3</org.apache.aries.spifly.dynamic.bundle.version>
59         <decompiler-procyon.version>4.3.0.Final</decompiler-procyon.version>
60         <jsoup.version>1.11.3</jsoup.version>
61         <snakeyaml.version>1.23</snakeyaml.version>
62         <jetty945.version>9.4.24.v20191120</jetty945.version>
63         <netty.version>4.1.45.Final</netty.version>
64         <jcip-annotations.version>1.0</jcip-annotations.version>
65         <pgjdbc-ng.version>0.7.1</pgjdbc-ng.version>
66     </properties>
67
68     <repositories>
69         <!--
70         <repository>
71             <id>project-specific-deps</id>
72             <name>project-specific-deps</name>
73             <url>file:///${basedir}/repo</url>
74         </repository>c.version.actual
75         --> 
76     </repositories>
77
78     <build>
79         <plugins>
80             <plugin>
81                 <groupId>org.eclipse.tycho.extras</groupId>
82                 <artifactId>tycho-p2-extras-plugin</artifactId>
83                 <version>1.0.0</version>
84             </plugin>
85             <plugin>
86                 <groupId>org.reficio</groupId>
87                 <artifactId>p2-maven-plugin</artifactId>
88                 <version>1.3.0</version>
89                 <executions>
90                     <execution>
91                         <id>default-cli</id>
92                         <!-- QUICK-START EXAMPLE -->
93                         <!--
94                         This is the default quick-start configuration.
95
96                         Expected behavior:
97                           - specified dependencies will be fetched
98                           - transitive dependencies will be fetched (no default exclusions)
99                           - jars containing source source code will NOT be fetched
100                           - jars that are NOT OSGi bundles will be "bundled" using bnd tool,
101                             if you specify instructions for these jars they will be APPLIED
102                           - jars that are OSGi bundles will be simply included
103                             if you specify instructions for these jars they will be IGNORED (see <override> option)
104                           - p2 site will be generated
105
106                         How the instructions works:
107                           - instructions are applied only to the root artifact that you specify!
108                           - instructions are not applied to the TRANSITIVE dependencies!
109                           - transitive dependencies are never overridden (see <override> option)
110                           - transitive dependencies are bundled using the default instructions:
111                               <instructions>
112                                   <Import-Package>*;resolution:=optional</Import-Package>
113                                   <Export-Package>*</Export-Package>
114                               </instructions>
115                           - other instructions, such as, Bundle-SymbolicName, Bundle-Name, Bundle-Version, etc.
116                             are calculated according to the following rules:
117                             http://felix.apache.org/site/apache-felix-maven-bundle-plugin-bnd.html
118                           - if you specify any instructions they will be applied only if
119                             the jar is not already an OSGi bundle - otherwise you have to use the override
120                             option - please see the /examples/override/pom.xml example
121
122                         The following definition of an artifact:
123                             <artifact>
124                                 <id>commons-io:commons-io:2.1</id>
125                             </artifact>
126
127                         is an equivalent of the following definition:
128                             <artifact>
129                                 <id>commons-io:commons-io:2.1</id>
130                                 <transitive>true</transitive>
131                                 <source>false</source>
132                                 <override>false</override>
133                                 <instructions>
134                                     <Import-Package>*;resolution:=optional</Import-Package>
135                                     <Export-Package>*</Export-Package>
136                                 </instructions>
137                                 <excludes/>
138                             </artifact>
139
140                         To run the example please invoke: mvn p2:site
141                         -->
142                         <configuration>
143                             <artifacts>
144                                 <artifact>
145                                     <id>org.antlr:antlr-runtime:${antlr.version}</id>
146                                     <source>true</source>
147                                     <instructions>
148                                         <Bundle-SymbolicName>org.antlr.runtime</Bundle-SymbolicName>
149                                         <Bundle-Version>${antlr.version}</Bundle-Version>
150                                         <Export-Package>*;version="${antlr.version}"</Export-Package>
151                                     </instructions>                                    
152                                 </artifact>
153                                 <artifact>
154                                     <id>org.apache.lucene:lucene-core:${lucene.version}</id>
155                                     <source>true</source>
156                                     <instructions>
157                                         <Bundle-SymbolicName>${lucene.prefix}.core</Bundle-SymbolicName>
158                                         <Bundle-Version>${lucene.version.actual}</Bundle-Version>
159                                         <Export-Package>*;version="${lucene.version}"</Export-Package>
160                                     </instructions>
161                                 </artifact>
162                                 <artifact>
163                                     <id>org.apache.lucene:lucene-queries:${lucene.version}</id>
164                                     <source>true</source>
165                                     <instructions>
166                                         <Bundle-SymbolicName>${lucene.prefix}.queries</Bundle-SymbolicName>
167                                         <Bundle-Version>${lucene.version.actual}</Bundle-Version>
168                                         <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}"</Require-Bundle>
169                                         <Export-Package>*;version="${lucene.version}"</Export-Package>
170                                         <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>
171                                     </instructions>
172                                 </artifact>
173                                 <artifact>
174                                     <id>org.apache.lucene:lucene-sandbox:${lucene.version}</id>
175                                     <source>true</source>
176                                     <instructions>
177                                         <Bundle-SymbolicName>${lucene.prefix}.sandbox</Bundle-SymbolicName>
178                                         <Bundle-Version>${lucene.version.actual}</Bundle-Version>
179                                         <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}"</Require-Bundle>
180                                         <Export-Package>*;version="${lucene.version}"</Export-Package>
181                                         <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>
182                                     </instructions>
183                                 </artifact>
184                                 <artifact>
185                                     <id>org.apache.lucene:lucene-analyzers-common:${lucene.version}</id>
186                                     <source>true</source>
187                                     <instructions>
188                                         <Bundle-SymbolicName>${lucene.prefix}.analyzers-common</Bundle-SymbolicName>
189                                         <Bundle-Version>${lucene.version.actual}</Bundle-Version>
190                                         <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}"</Require-Bundle>
191                                         <Export-Package>*;version="${lucene.version}"</Export-Package>
192                                         <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>
193                                     </instructions>
194                                 </artifact>
195                                 <artifact>
196                                     <id>org.apache.lucene:lucene-queryparser:${lucene.version}</id>
197                                     <source>true</source>
198                                     <instructions>
199                                         <Bundle-SymbolicName>${lucene.prefix}.queryparser</Bundle-SymbolicName>
200                                         <Bundle-Version>${lucene.version.actual}</Bundle-Version>
201                                         <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}",${lucene.prefix}.queries;bundle-version="${lucene.version}",${lucene.prefix}.sandbox;bundle-version="${lucene.version}"</Require-Bundle>
202                                         <Export-Package>*;version="${lucene.version}"</Export-Package>
203                                         <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>
204                                     </instructions>
205                                 </artifact>
206                                 <artifact>
207                                     <id>jaxen:jaxen:${jaxen.version}</id>
208                                     <source>true</source>
209                                 </artifact>
210                                 <artifact>
211                                     <id>org.jdom:jdom2:${jdom.version}</id>
212                                     <source>true</source>
213                                     <instructions>
214                                         <Bundle-SymbolicName>org.jdom2</Bundle-SymbolicName>
215                                         <Bundle-Version>${jdom.version.actual}</Bundle-Version>
216                                         <Export-Package>*;version="${jdom.version}"</Export-Package>
217                                     </instructions>
218                                 </artifact>
219                                 <artifact>
220                                     <id>org.jfree:jfreechart:${jfreechart.version}</id>
221                                     <source>true</source>
222                                     <instructions>
223                                         <Bundle-SymbolicName>org.jfree.jchart</Bundle-SymbolicName>
224                                     </instructions>
225                                 </artifact>
226                                 <!--
227                                 <artifact>
228                                     <id>org.ow2.asm:asm:5.0.4</id>
229                                     <source>true</source>
230                                     <override>true</override>
231                                     <instructions>
232                                         <Bundle-SymbolicName>org.objectweb.asm5</Bundle-SymbolicName>
233                                     </instructions>
234                                 </artifact>
235                                 -->
236                                 <artifact>
237                                     <id>net.sf.supercsv:super-csv:${supercsv.version}</id>
238                                     <source>true</source>
239                                     <override>true</override>
240                                     <instructions>
241                                         <Bundle-SymbolicName>org.supercsv</Bundle-SymbolicName>
242                                     </instructions>
243                                 </artifact>
244                                 <artifact>
245                                     <id>org.ini4j:ini4j:${ini4j.version}</id>
246                                     <source>true</source>
247                                 </artifact>
248                                 <artifact>
249                                     <!-- Needed by Apache POI 3.15 -->
250                                     <id>commons-codec:commons-codec:${commons-codec.version}</id>
251                                     <source>true</source>
252                                 </artifact>
253                                 <artifact>
254                                     <!-- Needed by Apache POI 3.15 -->
255                                     <id>org.apache.commons:commons-collections4:${commons-collections.version}</id>
256                                     <source>true</source>
257                                 </artifact>
258                                 <artifact>
259                                     <id>org.apache.commons:commons-compress:${commons-compress.version}</id>
260                                     <source>true</source>
261                                     <override>true</override>
262                                     <instructions>
263                                         <Bundle-SymbolicName>org.apache.commons.compress</Bundle-SymbolicName>
264                                     </instructions>
265                                 </artifact>
266                                 <artifact>
267                                     <id>commons-lang:commons-lang:${commons-lang.version}</id>
268                                     <source>true</source>
269                                 </artifact>
270                                 <artifact>
271                                     <!-- Needed by Apache POI 3.15 -->
272                                     <id>commons-logging:commons-logging:${commons-logging.version}</id>
273                                     <source>true</source>
274                                 </artifact>
275                                 <artifact>
276                                     <id>commons-io:commons-io:${commons-io.version}</id>
277                                     <source>true</source>
278                                 </artifact>
279                                 <artifact>
280                                     <id>org.apache.commons:commons-math3:${commons-math.version}</id>
281                                     <source>true</source>
282                                 </artifact>
283
284                                 <artifact>
285                                     <id>org.apache.pdfbox:pdfbox:${pdfbox.version}</id>
286                                     <source>true</source>
287                                 </artifact>
288                                 <artifact>
289                                     <id>org.apache.pdfbox:fontbox:${fontbox.version}</id>
290                                     <source>true</source>
291                                 </artifact>
292                                 <artifact>
293                                     <id>org.apache.pdfbox:xmpbox:${xmpbox.version}</id>
294                                     <source>true</source>
295                                 </artifact>
296                                 <!-- Needed by Apache POI 3.15, however these are included in third-party repository manually -->
297                                 <!--
298                                 <artifact>
299                                     <id>org.apache.xmlbeans:xmlbeans:2.6.0</id>
300                                     <source>true</source>
301                                 </artifact>
302                                 <artifact>
303                                     <id>com.github.virtuald:curvesapi:1.04</id>
304                                     <source>true</source>
305                                 </artifact>
306                                 -->
307                                 <artifact>
308                                     <id>log4j:log4j:${log4j.version}</id>
309                                     <source>true</source>
310                                     <override>true</override>
311                                     <instructions>
312                                         <Bundle-SymbolicName>org.apache.log4j</Bundle-SymbolicName>
313                                     </instructions>
314                                 </artifact>
315                                 <artifact>
316                                     <id>net.sf.ucanaccess:ucanaccess:${ucanaccess.version}</id>
317                                     <source>true</source>
318                                     <instructions>
319                                         <Bundle-SymbolicName>net.ucanaccess</Bundle-SymbolicName>
320                                     </instructions>
321                                 </artifact>
322                                 <artifact>
323                                     <id>it.unimi.dsi:fastutil:${fastutil.version}</id>
324                                     <source>true</source>
325                                 </artifact>
326                                 <artifact>
327                                     <id>org.eclipse.collections:eclipse-collections-api:${eclipse.collections.version}</id>
328                                     <override>true</override>
329                                     <source>true</source>
330                                     <instructions>
331                                         <Export-Package>org.eclipse.collections.*</Export-Package>
332                                     </instructions>
333                                 </artifact>
334                                 <artifact>
335                                     <id>org.eclipse.collections:eclipse-collections:${eclipse.collections.version}</id>
336                                     <source>true</source>
337                                     <instructions>
338                                         <Require-Bundle>org.eclipse.collections.eclipse-collections-api;bundle-version="${eclipse.collections.version}"</Require-Bundle>
339                                         <Import-Package>!org.eclipse.*,!sun.misc.*,*;resolution:=optional</Import-Package>
340                                     </instructions>
341                                 </artifact>
342                                 <artifact>
343                                     <id>net.sf.trove4j:trove4j:${trove4j.version}</id>
344                                     <source>true</source>
345                                     <instructions>
346                                         <Bundle-Name>GNU Trove 3</Bundle-Name>
347                                         <Bundle-SymbolicName>gnu.trove3</Bundle-SymbolicName>
348                                     </instructions>
349                                 </artifact>
350                                 <artifact>
351                                     <id>org.freemarker:freemarker:${freemarker.version}</id>
352                                     <source>true</source>
353                                     <override>true</override>
354                                     <instructions>
355                                         <Bundle-SymbolicName>freemarker</Bundle-SymbolicName>
356                                     </instructions>
357                                 </artifact>
358                                 <artifact>
359                                     <id>com.lowagie:itext:${itext.version}</id>
360                                     <source>true</source>
361                                     <instructions>
362                                         <Bundle-SymbolicName>com.lowagie.text</Bundle-SymbolicName>
363                                         <Bundle-Version>${itext.version.actual}</Bundle-Version>
364                                     </instructions>
365                                 </artifact>
366                                 <artifact>
367                                     <id>org.mozilla:rhino:${rhino.version}</id>
368                                     <source>true</source>
369                                 </artifact>
370                                 <!-- org.eclipse.epp.mpc.core.win32 plug-in requires 4.1.0 -->
371                                 <artifact>
372                                     <id>net.java.dev.jna:jna:${jna41.version}</id>
373                                     <source>true</source>
374                                 </artifact>
375                                  <!-- org.eclipse.epp.mpc.core.win32 plug-in requires 4.1.0 -->
376                                 <artifact>
377                                     <id>net.java.dev.jna:jna-platform:${jna41.version}</id>
378                                     <source>true</source>
379                                 </artifact>
380                                 <artifact>
381                                     <id>net.java.dev.jna:jna:${jna.version}</id>
382                                     <source>true</source>
383                                 </artifact>
384                                 <artifact>
385                                     <id>net.java.dev.jna:jna-platform:${jna.version}</id>
386                                     <source>true</source>
387                                 </artifact>
388                                 <artifact>
389                                     <id>javax.servlet:javax.servlet-api:${javax.version}</id>
390                                     <source>true</source>
391                                 </artifact>
392                                 <artifact>
393                                     <id>com.fasterxml.jackson.core:jackson-core:${jackson.version}</id>
394                                     <source>true</source>
395                                 </artifact>
396                                 <artifact>
397                                     <id>com.fasterxml.jackson.core:jackson-annotations:${jackson.version}</id>
398                                     <source>true</source>
399                                 </artifact>
400                                 <artifact>
401                                     <id>com.fasterxml.jackson.core:jackson-databind:${jackson.version}</id>
402                                     <source>true</source>
403                                     <excludes>
404                                         <exclude>com.fasterxml.jackson.*</exclude>
405                                     </excludes>
406                                 </artifact>
407                                 <artifact>
408                                     <id>com.fasterxml.jackson.dataformat:jackson-dataformat-csv:${jackson.version}</id>
409                                     <source>true</source>
410                                     <excludes>
411                                         <exclude>com.fasterxml.jackson.*</exclude>
412                                     </excludes>
413                                 </artifact>
414                                 <artifact>
415                                     <id>com.fasterxml.jackson.dataformat:jackson-dataformat-xml:${jackson.version}</id>
416                                     <source>true</source>
417                                     <excludes>
418                                         <exclude>com.fasterxml.jackson.*</exclude>
419                                     </excludes>
420                                 </artifact>
421                                 <artifact>
422                                     <id>com.fasterxml.jackson.datatype:jackson-datatype-jsr310:${jackson.version}</id>
423                                     <source>true</source>
424                                     <excludes>
425                                         <exclude>com.fasterxml.jackson.*</exclude>
426                                     </excludes>
427                                 </artifact>
428                                 <artifact>
429                                     <id>com.fasterxml.jackson.jaxrs:jackson-jaxrs-base:${jackson.version}</id>
430                                     <source>true</source>
431                                     <excludes>
432                                         <exclude>com.fasterxml.jackson.*</exclude>
433                                     </excludes>
434                                 </artifact>
435                                 <artifact>
436                                     <id>com.fasterxml.jackson.jaxrs:jackson-jaxrs-json-provider:${jackson.version}</id>
437                                     <source>true</source>
438                                     <excludes>
439                                         <exclude>com.fasterxml.jackson.*</exclude>
440                                     </excludes>
441                                 </artifact>
442                                 <artifact>
443                                     <id>com.fasterxml.jackson.module:jackson-module-jaxb-annotations:${jackson.version}</id>
444                                     <source>true</source>
445                                     <excludes>
446                                         <exclude>com.fasterxml.jackson.*</exclude>
447                                     </excludes>
448                                 </artifact>
449                                 <artifact>
450                                     <id>org.slf4j:slf4j-api:${slf4j.version}</id>
451                                     <source>true</source>
452                                     <override>true</override>
453                                     <instructions>
454                                         <Bundle-Name>SLF4J API Module</Bundle-Name>
455                                         <Bundle-Version>${slf4j.version.actual}</Bundle-Version>
456                                         <Bundle-SymbolicName>org.slf4j.api</Bundle-SymbolicName>
457                                         <Export-Package>*;version=${slf4j.version}</Export-Package>
458                                     </instructions>
459                                 </artifact>
460                                 <artifact>
461                                     <id>ch.qos.logback:logback-classic:${logback-classic.version}</id>
462                                     <source>true</source>
463                                     <override>true</override>
464                                 </artifact>
465                                 <artifact>
466                                     <id>com.koloboke:koloboke-compile:${koloboke-compile.version}</id>
467                                     <source>true</source>
468                                 </artifact>
469                                 <artifact>
470                                     <id>com.koloboke:koloboke-impl-common-jdk8:${koloboke-impl-common-jdk8.version}</id>
471                                     <source>true</source>
472                                 </artifact>
473                                 <artifact>
474                                     <id>com.esotericsoftware:kryo:${kryo.version}</id>
475                                     <source>true</source>
476                                 </artifact>
477                                  <artifact>
478                                      <id>org.apache.aries.spifly:org.apache.aries.spifly.dynamic.bundle:${org.apache.aries.spifly.dynamic.bundle.version}</id>
479                                      <source>true</source>
480                                  </artifact>
481                                 <artifact>
482                                     <id>org.glassfish.jersey.core:jersey-server:${jersey.version}</id>
483                                     <source>true</source>
484                                 </artifact>
485                                 <artifact>
486                                     <id>org.glassfish.jersey.core:jersey-client:${jersey.version}</id>
487                                     <source>true</source>
488                                 </artifact>
489                                 <artifact>
490                                     <id>org.glassfish.jersey.media:jersey-media-multipart:${jersey.version}</id>
491                                     <source>true</source>
492                                 </artifact>
493                                 <artifact>
494                                     <id>org.glassfish.jersey.media:jersey-media-json-jackson:${jersey.version}</id>
495                                     <source>true</source>
496                                     <excludes>
497                                         <exclude>com.fasterxml.jackson.*</exclude>
498                                     </excludes>
499                                 </artifact>
500                                 <artifact>
501                                     <id>org.glassfish.jersey.containers:jersey-container-servlet-core:${jersey.version}</id>
502                                     <source>true</source>
503                                 </artifact>
504                                 <artifact>
505                                     <id>org.jboss.windup.decompiler:decompiler-procyon:${decompiler-procyon.version}</id>
506                                     <source>true</source>
507                                 </artifact>
508                                 <artifact>
509                                     <id>org.jsoup:jsoup:${jsoup.version}</id>
510                                     <source>true</source>
511                                 </artifact>
512                                 <artifact>
513                                     <id>org.yaml:snakeyaml:${snakeyaml.version}</id>
514                                     <source>true</source>
515                                 </artifact>
516                                 <artifact>
517                                     <id>org.eclipse.jetty:jetty-servlets:${jetty945.version}</id>
518                                     <source>true</source>
519                                 </artifact>
520                                 <artifact>
521                                     <id>org.zeroturnaround:zt-exec:${zeroturnaround.version}</id>
522                                     <source>true</source>
523                                 </artifact>
524                                 <!-- Since 1.21.0 grpc, a manually set up plugin is provided in third-party repository.
525                                      Note: grpc-core, grpc-context, and grpc-stub (maybe others as well) must be bundled into same plug-in, since they contain split packages.
526                                      See:
527                                        * https://github.com/grpc/grpc-java/issues/2727
528                                        * https://github.com/grpc/grpc-java/issues/3522
529                                 <artifact>
530                                     <id>io.grpc:io.grpc:${grpc.version}</id>
531                                     <source>true</source>
532                                 </artifact>
533                                 <artifact>
534                                     <id>io.grpc:grpc-netty:${grpc.version}</id>
535                                     <source>true</source>
536                                     <override>true</override>
537                                     <instructions>
538                                         <Require-Bundle>
539                                              io.netty.buffer;bundle-version="4.1.27",
540                                              io.netty.codec;bundle-version="4.1.27",
541                                              io.netty.codec-http;bundle-version="4.1.27",
542                                              io.netty.codec-http2;bundle-version="4.1.27",
543                                              io.netty.codec-socks;bundle-version="4.1.27",
544                                              io.netty.common;bundle-version="4.1.27",
545                                              io.netty.handler;bundle-version="4.1.27",
546                                              io.netty.handler-proxy;bundle-version="4.1.27",
547                                              io.netty.resolver;bundle-version="4.1.27",
548                                              io.netty.transport;bundle-version="4.1.27",
549                                              io.grpc
550                                         </Require-Bundle>
551                                         <Import-Package>!io.netty.*,*;resolution:=optional</Import-Package>
552                                         <Require-Capability>
553                                             osgi.extender;
554                                                 filter:="(osgi.extender=osgi.serviceloader.registrar)"
555                                         </Require-Capability>
556                                         <Provide-Capability>
557                                             osgi.serviceloader;
558                                                 osgi.serviceloader=io.grpc.ServerProvider,
559                                             osgi.serviceloader;
560                                                 osgi.serviceloader=io.grpc.ManagedChannelProvider
561                                         </Provide-Capability>
562                                         <Bundle-Version>${grpc.version.actual}</Bundle-Version>
563                                     </instructions>
564                                 </artifact>
565                                 <artifact>
566                                     <id>com.google.protobuf:protobuf-java:${protobuf.version}</id>
567                                     <source>true</source>
568                                     <override>true</override>
569                                     <instructions>
570                                         <Import-Package>!sun.misc.*,*;resolution:=optional</Import-Package>
571                                     </instructions>
572                                 </artifact>
573                                 -->
574                                 <!-- grpc 1.21.0 dependencies -->
575                                 <artifact>
576                                     <id>io.opencensus:opencensus-api:0.21.0</id>
577                                     <source>true</source>
578                                 </artifact>
579                                 <artifact>
580                                     <id>com.google.code.gson:gson:2.7</id>
581                                     <source>true</source>
582                                 </artifact>
583                                 <artifact>
584                                     <id>com.google.android:annotations:4.1.1.4</id>
585                                     <source>true</source>
586                                 </artifact>
587                                 <artifact>
588                                     <id>io.opencensus:opencensus-contrib-grpc-metrics:0.21.0</id>
589                                     <source>true</source>
590                                 </artifact>
591                                 <artifact>
592                                     <id>com.google.protobuf:protobuf-java:${protobuf.version}</id>
593                                     <source>true</source>
594                                 </artifact>
595                                 <artifact>
596                                     <id>com.google.api.grpc:proto-google-common-protos:1.12.0</id>
597                                     <source>true</source>
598                                 </artifact>
599                                 <artifact>
600                                     <id>com.google.errorprone:error_prone_annotations:2.3.2</id>
601                                     <source>true</source>
602                                 </artifact>
603
604                                 <!-- Netty is needed by com.impossibl.pgjdbc-ng:pgjdbc-ng:0.7.1 -->
605                                 <artifact>
606                                     <id>io.netty:netty-buffer:${netty.version}</id>
607                                     <source>true</source>
608                                     <transitive>true</transitive>
609                                 </artifact>
610                                 <artifact>
611                                     <id>io.netty:netty-codec:${netty.version}</id>
612                                     <source>true</source>
613                                     <transitive>true</transitive>
614                                 </artifact>
615                                 <artifact>
616                                     <id>io.netty:netty-codec-http:${netty.version}</id>
617                                     <source>true</source>
618                                     <transitive>true</transitive>
619                                 </artifact>
620                                 <artifact>
621                                     <id>io.netty:netty-codec-http2:${netty.version}</id>
622                                     <source>true</source>
623                                     <transitive>true</transitive>
624                                 </artifact>
625                                 <artifact>
626                                     <id>io.netty:netty-codec-socks:${netty.version}</id>
627                                     <source>true</source>
628                                     <transitive>true</transitive>
629                                 </artifact>
630                                 <artifact>
631                                     <id>io.netty:netty-common:${netty.version}</id>
632                                     <source>true</source>
633                                     <transitive>true</transitive>
634                                 </artifact>
635                                 <artifact>
636                                     <id>io.netty:netty-handler:${netty.version}</id>
637                                     <source>true</source>
638                                     <transitive>true</transitive>
639                                 </artifact>
640                                 <artifact>
641                                     <id>io.netty:netty-handler-proxy:${netty.version}</id>
642                                     <source>true</source>
643                                     <transitive>true</transitive>
644                                 </artifact>
645                                 <artifact>
646                                     <id>io.netty:netty-resolver:${netty.version}</id>
647                                     <source>true</source>
648                                     <transitive>true</transitive>
649                                 </artifact>
650                                 <artifact>
651                                     <id>io.netty:netty-transport:${netty.version}</id>
652                                     <source>true</source>
653                                     <transitive>true</transitive>
654                                 </artifact>
655                                 <artifact>
656                                     <id>com.impossibl.pgjdbc-ng:pgjdbc-ng:${pgjdbc-ng.version}</id>
657                                     <source>true</source>
658                                     <transitive>false</transitive>
659                                 </artifact>
660                                 <artifact>
661                                     <id>com.github.ben-manes.caffeine:caffeine:${caffeine.version}</id>
662                                     <source>true</source>
663                                     <override>true</override>
664                                     <instructions>
665                                         <Bundle-SymbolicName>com.github.benmanes.caffeine</Bundle-SymbolicName>
666                                     </instructions>
667                                 </artifact>
668                                 <artifact>
669                                     <id>net.jcip:jcip-annotations:${jcip-annotations.version}</id>
670                                     <source>true</source>
671                                 </artifact>
672                                 <artifact>
673                                     <id>com.influxdb:influxdb-client-java:${influxdb.client.version}</id>
674                                     <source>true</source>
675                                 </artifact>
676                             </artifacts>
677                         </configuration>
678                     </execution>
679                 </executions>
680             </plugin>
681
682             <plugin>
683                 <groupId>org.mortbay.jetty</groupId>
684                 <artifactId>jetty-maven-plugin</artifactId>
685                 <version>8.1.5.v20120716</version>
686                 <configuration>
687                     <scanIntervalSeconds>10</scanIntervalSeconds>
688                     <webAppSourceDirectory>${basedir}/target/repository/</webAppSourceDirectory>
689                     <webApp>
690                         <contextPath>/site</contextPath>
691                     </webApp>
692                 </configuration>
693             </plugin>
694         </plugins>
695     </build>
696
697 </project>