Enhance logging for Simantics platform with SLF4J and Logback 85/85/3
authorjsimomaa <jani.simomaa@gmail.com>
Fri, 23 Sep 2016 08:47:02 +0000 (11:47 +0300)
committerTuukka Lehtonen <tuukka.lehtonen@semantum.fi>
Fri, 23 Sep 2016 09:34:50 +0000 (12:34 +0300)
Include the new logging bundles in org.simantics.rcp.feature.

refs #6705

Change-Id: I0711950cbb858a1bbcf0b3a14f648b98707dc1ca

features/org.simantics.rcp.feature/feature.xml
releng/org.simantics.sdk.build.p2.site/pom.xml
releng/org.simantics.sdk.build.targetdefinition/org.simantics.sdk.build.targetdefinition-semantum.target
releng/org.simantics.sdk.build.targetdefinition/org.simantics.sdk.build.targetdefinition.target

index a19e2c230b63002d87a7068d253d0cb76d6d42cd..40a9bdb68368264e321ea65b118a5070768e330f 100644 (file)
@@ -1,4 +1,4 @@
-<?xml version="1.0" encoding="UTF-8"?>\r
+<?xml version="1.0" encoding="UTF-8"?>
 <!--
     Copyright (c) 2007, 2010 Association for Decentralized Information Management
     in Industry THTH ry.
@@ -9,14 +9,14 @@
    
     Contributors:
         VTT Technical Research Centre of Finland - initial API and implementation
- -->\r
-<feature\r
-      id="org.simantics.rcp"\r
-      label="Simantics Rich Client Platform"\r
-      version="1.25.1.qualifier"\r
-      provider-name="VTT Technical Research Centre of Finland">\r
-\r
-   <description>\r
+ -->
+<feature
+      id="org.simantics.rcp"
+      label="Simantics Rich Client Platform"
+      version="1.25.1.qualifier"
+      provider-name="VTT Technical Research Centre of Finland">
+
+   <description>
       Briefly put, includes Eclipse RCP feature along with other basic
 framework parts often required by applications with a workbench
 UI.
@@ -29,15 +29,15 @@ To be more precise, the additions to Eclipse RCP are:
 &lt;li&gt;Apache Commons HTTPClient + dependencies&lt;/li&gt;
 &lt;li&gt;Apache Xerces XML parser + dependencies&lt;/li&gt;
 &lt;li&gt;JUnit 4&lt;/li&gt;
-&lt;/ul&gt;\r
-   </description>\r
-\r
-   <copyright>\r
+&lt;/ul&gt;
+   </description>
+
+   <copyright>
       Copyright (c) 2007, 2010 Association for Decentralized Information Management in Industry THTH ry.&lt;br/&gt;
-All rights reserved. This program and the accompanying materials are made available under the terms of the Eclipse Public License v1.0 which accompanies this distribution, and is available at &lt;a href=&quot;http://www.eclipse.org/legal/epl-v10.html&quot;&gt;http://www.eclipse.org/legal/epl-v10.html&lt;/a&gt;\r
-   </copyright>\r
-\r
-   <license url="http://www.eclipse.org/legal/epl-v10.html">\r
+All rights reserved. This program and the accompanying materials are made available under the terms of the Eclipse Public License v1.0 which accompanies this distribution, and is available at &lt;a href=&quot;http://www.eclipse.org/legal/epl-v10.html&quot;&gt;http://www.eclipse.org/legal/epl-v10.html&lt;/a&gt;
+   </copyright>
+
+   <license url="http://www.eclipse.org/legal/epl-v10.html">
       Eclipse Public License - v 1.0
 
 THE ACCOMPANYING PROGRAM IS PROVIDED UNDER THE TERMS OF THIS ECLIPSE PUBLIC LICENSE (&quot;AGREEMENT&quot;). ANY USE, REPRODUCTION OR DISTRIBUTION OF THE PROGRAM CONSTITUTES RECIPIENT&apos;S ACCEPTANCE OF THIS AGREEMENT.
@@ -107,573 +107,587 @@ All Recipient&apos;s rights under this Agreement shall terminate if it fails to
 
 Everyone is permitted to copy and distribute copies of this Agreement, but in order to avoid inconsistency the Agreement is copyrighted and may only be modified in the following manner. The Agreement Steward reserves the right to publish new versions (including revisions) of this Agreement from time to time. No one other than the Agreement Steward has the right to modify this Agreement. The Eclipse Foundation is the initial Agreement Steward. The Eclipse Foundation may assign the responsibility to serve as the Agreement Steward to a suitable separate entity. Each new version of the Agreement will be given a distinguishing version number. The Program (including Contributions) may always be distributed subject to the version of the Agreement under which it was received. In addition, after a new version of the Agreement is published, Contributor may elect to distribute the Program (including its Contributions) under the new version. Except as expressly stated in Sections 2(a) and 2(b) above, Recipient receives no rights or licenses to the intellectual property of any Contributor under this Agreement, whether expressly, by implication, estoppel or otherwise. All rights in the Program not expressly granted under this Agreement are reserved.
 
-This Agreement is governed by the laws of the State of New York and the intellectual property laws of the United States of America. No party to this Agreement will bring a legal action under this Agreement more than one year after the cause of action arose. Each party waives its rights to a jury trial in any resulting litigation.\r
-   </license>\r
-\r
-   <includes\r
-         id="org.eclipse.rcp"\r
-         version="0.0.0"/>\r
-\r
-   <includes\r
-         id="org.eclipse.ecf.core.feature"\r
-         version="0.0.0"/>\r
-\r
-   <includes\r
-         id="org.eclipse.ecf.core.ssl.feature"\r
-         version="0.0.0"/>\r
-\r
-   <includes\r
-         id="org.eclipse.ecf.filetransfer.feature"\r
-         version="0.0.0"/>\r
-\r
-   <includes\r
-         id="org.eclipse.ecf.filetransfer.ssl.feature"\r
-         version="0.0.0"/>\r
-\r
-   <includes\r
-         id="org.eclipse.ecf.filetransfer.httpclient4.feature"\r
-         version="0.0.0"/>\r
-\r
-   <includes\r
-         id="org.eclipse.ecf.filetransfer.httpclient4.ssl.feature"\r
-         version="0.0.0"/>\r
-\r
-   <includes\r
-         id="org.eclipse.emf.common"\r
-         version="0.0.0"/>\r
-\r
-   <includes\r
-         id="org.eclipse.emf.ecore"\r
-         version="0.0.0"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.filesystem"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.filesystem.aix.ppc"\r
-         os="aix"\r
-         arch="ppc"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.filesystem.aix.ppc64"\r
-         os="aix"\r
-         arch="ppc64"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.filesystem.hpux.ia64"\r
-         os="hpux"\r
-         arch="ia64"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.filesystem.java7"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.filesystem.linux.x86"\r
-         os="linux"\r
-         arch="x86"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.filesystem.linux.x86_64"\r
-         os="linux"\r
-         arch="x86_64"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.filesystem.linux.ppc"\r
-         os="linux"\r
-         arch="ppc"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.filesystem.linux.ppc64"\r
-         os="linux"\r
-         arch="ppc64"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.filesystem.linux.ppc64le"\r
-         os="linux"\r
-         arch="ppc64le"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.filesystem.macosx"\r
-         os="macosx"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.filesystem.solaris.sparc"\r
-         os="solaris"\r
-         arch="sparc"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.filesystem.win32.x86"\r
-         os="win32"\r
-         arch="x86"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.filesystem.win32.x86_64"\r
-         os="win32"\r
-         arch="x86_64"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.net"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.net.linux.x86"\r
-         os="linux"\r
-         arch="x86"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.net.linux.x86_64"\r
-         os="linux"\r
-         arch="x86_64"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.net.win32.x86"\r
-         os="win32"\r
-         arch="x86"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.net.win32.x86_64"\r
-         os="win32"\r
-         arch="x86_64"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.resources"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.resources.win32.x86"\r
-         os="win32"\r
-         arch="x86"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.resources.win32.x86_64"\r
-         os="win32"\r
-         arch="x86_64"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.core.variables"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.ant.core"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="javax.xml"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.osgi.compatibility.state"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.osgi.util"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.security"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.security.macosx"\r
-         os="macosx"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.security.win32.x86"\r
-         os="win32"\r
-         arch="x86"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.security.win32.x86_64"\r
-         os="win32"\r
-         arch="x86_64"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         fragment="true"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.junit"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.security.ui"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.hamcrest.core"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.p2.core"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.p2.engine"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.p2.metadata"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.p2.metadata.repository"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.concurrent"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.p2.director"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.sat4j.core"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.sat4j.pb"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.p2.repository"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.p2.artifact.repository"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.p2.jarprocessor"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.p2.touchpoint.eclipse"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.p2.touchpoint.natives"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.p2.publisher"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.p2.repository.tools"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.p2.ui"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.p2.operations"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.p2.garbagecollector"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.simpleconfigurator"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.simpleconfigurator.manipulator"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.util"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.ds"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.frameworkadmin"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.frameworkadmin.equinox"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.equinox.p2.reconciler.dropins"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="com.google.guava"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.apache.log4j"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.ui.views.log"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.ui.browser"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.ui.views.log"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.ui.browser"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-   <plugin\r
-         id="org.eclipse.ui.themes"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"/>\r
-\r
-   <plugin\r
-         id="org.slf4j.api"\r
-         download-size="0"\r
-         install-size="0"\r
-         version="0.0.0"\r
-         unpack="false"/>\r
-\r
-</feature>\r
+This Agreement is governed by the laws of the State of New York and the intellectual property laws of the United States of America. No party to this Agreement will bring a legal action under this Agreement more than one year after the cause of action arose. Each party waives its rights to a jury trial in any resulting litigation.
+   </license>
+
+   <includes
+         id="org.eclipse.rcp"
+         version="0.0.0"/>
+
+   <includes
+         id="org.eclipse.ecf.core.feature"
+         version="0.0.0"/>
+
+   <includes
+         id="org.eclipse.ecf.core.ssl.feature"
+         version="0.0.0"/>
+
+   <includes
+         id="org.eclipse.ecf.filetransfer.feature"
+         version="0.0.0"/>
+
+   <includes
+         id="org.eclipse.ecf.filetransfer.ssl.feature"
+         version="0.0.0"/>
+
+   <includes
+         id="org.eclipse.ecf.filetransfer.httpclient4.feature"
+         version="0.0.0"/>
+
+   <includes
+         id="org.eclipse.ecf.filetransfer.httpclient4.ssl.feature"
+         version="0.0.0"/>
+
+   <includes
+         id="org.eclipse.emf.common"
+         version="0.0.0"/>
+
+   <includes
+         id="org.eclipse.emf.ecore"
+         version="0.0.0"/>
+
+   <plugin
+         id="org.eclipse.core.filesystem"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.filesystem.aix.ppc"
+         os="aix"
+         arch="ppc"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.filesystem.aix.ppc64"
+         os="aix"
+         arch="ppc64"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.filesystem.hpux.ia64"
+         os="hpux"
+         arch="ia64"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.filesystem.java7"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.filesystem.linux.x86"
+         os="linux"
+         arch="x86"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.filesystem.linux.x86_64"
+         os="linux"
+         arch="x86_64"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.filesystem.linux.ppc"
+         os="linux"
+         arch="ppc"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.filesystem.linux.ppc64"
+         os="linux"
+         arch="ppc64"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.filesystem.linux.ppc64le"
+         os="linux"
+         arch="ppc64le"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.filesystem.macosx"
+         os="macosx"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.filesystem.solaris.sparc"
+         os="solaris"
+         arch="sparc"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.filesystem.win32.x86"
+         os="win32"
+         arch="x86"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.filesystem.win32.x86_64"
+         os="win32"
+         arch="x86_64"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.net"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.net.linux.x86"
+         os="linux"
+         arch="x86"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.net.linux.x86_64"
+         os="linux"
+         arch="x86_64"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.net.win32.x86"
+         os="win32"
+         arch="x86"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.net.win32.x86_64"
+         os="win32"
+         arch="x86_64"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.resources"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.resources.win32.x86"
+         os="win32"
+         arch="x86"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.resources.win32.x86_64"
+         os="win32"
+         arch="x86_64"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.core.variables"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.ant.core"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="javax.xml"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.osgi.compatibility.state"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.osgi.util"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.security"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.security.macosx"
+         os="macosx"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.security.win32.x86"
+         os="win32"
+         arch="x86"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.security.win32.x86_64"
+         os="win32"
+         arch="x86_64"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         fragment="true"
+         unpack="false"/>
+
+   <plugin
+         id="org.junit"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"/>
+
+   <plugin
+         id="org.eclipse.equinox.security.ui"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.hamcrest.core"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.p2.core"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.p2.engine"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.p2.metadata"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.p2.metadata.repository"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.concurrent"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.p2.director"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.sat4j.core"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.sat4j.pb"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.p2.repository"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.p2.artifact.repository"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.p2.jarprocessor"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.p2.touchpoint.eclipse"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.p2.touchpoint.natives"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.p2.publisher"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.p2.repository.tools"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.p2.ui"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.p2.operations"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.p2.garbagecollector"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.simpleconfigurator"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.simpleconfigurator.manipulator"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.util"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.ds"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.frameworkadmin"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.frameworkadmin.equinox"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.equinox.p2.reconciler.dropins"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="com.google.guava"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.apache.log4j"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.ui.views.log"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.ui.browser"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.ui.views.log"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.ui.browser"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="org.eclipse.ui.themes"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"/>
+
+   <plugin
+         id="org.slf4j.api"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="qh.cos.logback.classic"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+   <plugin
+         id="ch.qos.logback.core"
+         download-size="0"
+         install-size="0"
+         version="0.0.0"
+         unpack="false"/>
+
+</feature>
index 361c0cdcdbb430ebd34334a2a5269618720970d6..89340d87216f93f536237244c294c0dfb0ef8f83 100644 (file)
-<?xml version="1.0" encoding="UTF-8"?>\r
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001 XMLSchema-instance"\r
-       xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">\r
-       <modelVersion>4.0.0</modelVersion>\r
-\r
-    <groupId>org.simantics</groupId>\r
-    <artifactId>org.simantics.sdk.build.p2.site</artifactId>\r
-    <packaging>pom</packaging>\r
-    <version>1.25.0</version>\r
-\r
-    <properties>\r
-        <itext.version.actual>2.1.7.b1</itext.version.actual>\r
-        <lucene.version>4.9.0</lucene.version>\r
-        <lucene.version.actual>4.9.0.b0003</lucene.version.actual>\r
-        <lucene.prefix>org.apache.lucene4</lucene.prefix>\r
-    </properties>\r
-\r
-\r
-    <repositories>\r
-        <!--\r
-        <repository>\r
-            <id>project-specific-deps</id>\r
-            <name>project-specific-deps</name>\r
-            <url>file:///${basedir}/repo</url>\r
-        </repository>\r
-        -->\r
-    </repositories>\r
-\r
-    <build>\r
-        <plugins>\r
-            <plugin>\r
-                <groupId>org.eclipse.tycho.extras</groupId>\r
-                <artifactId>tycho-p2-extras-plugin</artifactId>\r
-                <version>0.25.0</version>\r
-            </plugin>\r
-            <plugin>\r
-                <groupId>org.reficio</groupId>\r
-                <artifactId>p2-maven-plugin</artifactId>\r
-                <version>1.2.0-SNAPSHOT</version>\r
-                <executions>\r
-                    <execution>\r
-                        <id>default-cli</id>\r
-                        <!-- QUICK-START EXAMPLE -->\r
-                        <!--\r
-                        This is the default quick-start configuration.\r
-\r
-                        Expected behavior:\r
-                          - specified dependencies will be fetched\r
-                          - transitive dependencies will be fetched (no default exclusions)\r
-                          - jars containing source source code will NOT be fetched\r
-                          - jars that are NOT OSGi bundles will be "bundled" using bnd tool,\r
-                            if you specify instructions for these jars they will be APPLIED\r
-                          - jars that are OSGi bundles will be simply included\r
-                            if you specify instructions for these jars they will be IGNORED (see <override> option)\r
-                          - p2 site will be generated\r
-\r
-                        How the instructions works:\r
-                          - instructions are applied only to the root artifact that you specify!\r
-                          - instructions are not applied to the TRANSITIVE dependencies!\r
-                          - transitive dependencies are never overridden (see <override> option)\r
-                          - transitive dependencies are bundled using the default instructions:\r
-                              <instructions>\r
-                                  <Import-Package>*;resolution:=optional</Import-Package>\r
-                                  <Export-Package>*</Export-Package>\r
-                              </instructions>\r
-                          - other instructions, such as, Bundle-SymbolicName, Bundle-Name, Bundle-Version, etc.\r
-                            are calculated according to the following rules:\r
-                            http://felix.apache.org/site/apache-felix-maven-bundle-plugin-bnd.html\r
-                          - if you specify any instructions they will be applied only if\r
-                            the jar is not already an OSGi bundle - otherwise you have to use the override\r
-                            option - please see the /examples/override/pom.xml example\r
-\r
-                        The following definition of an artifact:\r
-                            <artifact>\r
-                                <id>commons-io:commons-io:2.1</id>\r
-                            </artifact>\r
-\r
-                        is an equivalent of the following definition:\r
-                            <artifact>\r
-                                <id>commons-io:commons-io:2.1</id>\r
-                                <transitive>true</transitive>\r
-                                <source>false</source>\r
-                                <override>false</override>\r
-                                <instructions>\r
-                                    <Import-Package>*;resolution:=optional</Import-Package>\r
-                                    <Export-Package>*</Export-Package>\r
-                                </instructions>\r
-                                <excludes/>\r
-                            </artifact>\r
-\r
-                        To run the example please invoke: mvn p2:site\r
-                        -->\r
-                        <configuration>\r
-                            <artifacts>\r
-                                <artifact>\r
-                                    <id>org.antlr:antlr-runtime:3.5.2</id>\r
-                                    <source>true</source>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>org.apache.poi:poi:3.14</id>\r
-                                    <source>true</source>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>org.apache.poi:poi-ooxml:3.14</id>\r
-                                    <source>true</source>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>org.apache.lucene:lucene-core:${lucene.version}</id>\r
-                                    <source>true</source>\r
-                                    <instructions>\r
-                                        <Bundle-SymbolicName>${lucene.prefix}.core</Bundle-SymbolicName>\r
-                                        <Bundle-Version>${lucene.version.actual}</Bundle-Version>\r
-                                        <Export-Package>*;version="${lucene.version}"</Export-Package>\r
-                                    </instructions>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>org.apache.lucene:lucene-queries:${lucene.version}</id>\r
-                                    <source>true</source>\r
-                                    <instructions>\r
-                                        <Bundle-SymbolicName>${lucene.prefix}.queries</Bundle-SymbolicName>\r
-                                        <Bundle-Version>${lucene.version.actual}</Bundle-Version>\r
-                                        <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}"</Require-Bundle>\r
-                                        <Export-Package>*;version="${lucene.version}"</Export-Package>\r
-                                        <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>\r
-                                    </instructions>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>org.apache.lucene:lucene-sandbox:${lucene.version}</id>\r
-                                    <source>true</source>\r
-                                    <instructions>\r
-                                        <Bundle-SymbolicName>${lucene.prefix}.sandbox</Bundle-SymbolicName>\r
-                                        <Bundle-Version>${lucene.version.actual}</Bundle-Version>\r
-                                        <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}"</Require-Bundle>\r
-                                        <Export-Package>*;version="${lucene.version}"</Export-Package>\r
-                                        <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>\r
-                                    </instructions>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>org.apache.lucene:lucene-analyzers-common:${lucene.version}</id>\r
-                                    <source>true</source>\r
-                                    <instructions>\r
-                                        <Bundle-SymbolicName>${lucene.prefix}.analyzers-common</Bundle-SymbolicName>\r
-                                        <Bundle-Version>${lucene.version.actual}</Bundle-Version>\r
-                                        <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}"</Require-Bundle>\r
-                                        <Export-Package>*;version="${lucene.version}"</Export-Package>\r
-                                        <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>\r
-                                    </instructions>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>org.apache.lucene:lucene-queryparser:${lucene.version}</id>\r
-                                    <source>true</source>\r
-                                    <instructions>\r
-                                        <Bundle-SymbolicName>${lucene.prefix}.queryparser</Bundle-SymbolicName>\r
-                                        <Bundle-Version>${lucene.version.actual}</Bundle-Version>\r
-                                        <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}",${lucene.prefix}.queries;bundle-version="${lucene.version}",${lucene.prefix}.sandbox;bundle-version="${lucene.version}"</Require-Bundle>\r
-                                        <Export-Package>*;version="${lucene.version}"</Export-Package>\r
-                                        <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>\r
-                                    </instructions>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>org.jdom:jdom2:2.0.6</id>\r
-                                    <source>true</source>\r
-                                    <instructions>\r
-                                        <Bundle-SymbolicName>org.jdom2</Bundle-SymbolicName>\r
-                                    </instructions>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>org.jfree:jfreechart:1.0.19</id>\r
-                                    <source>true</source>\r
-                                    <instructions>\r
-                                        <Bundle-SymbolicName>org.jfree.jchart</Bundle-SymbolicName>\r
-                                    </instructions>\r
-                                </artifact>\r
-                                <!--\r
-                                <artifact>\r
-                                    <id>org.ow2.asm:asm:5.0.4</id>\r
-                                    <source>true</source>\r
-                                    <override>true</override>\r
-                                    <instructions>\r
-                                        <Bundle-SymbolicName>org.objectweb.asm5</Bundle-SymbolicName>\r
-                                    </instructions>\r
-                                </artifact>\r
-                                -->\r
-                                <artifact>\r
-                                    <id>net.sf.supercsv:super-csv:2.4.0</id>\r
-                                    <source>true</source>\r
-                                    <override>true</override>\r
-                                    <instructions>\r
-                                        <Bundle-SymbolicName>org.supercsv</Bundle-SymbolicName>\r
-                                    </instructions>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>org.ini4j:ini4j:0.5.4</id>\r
-                                    <source>true</source>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>commons-collections:commons-collections:3.2.2</id>\r
-                                    <source>true</source>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>org.apache.commons:commons-compress:1.12</id>\r
-                                    <source>true</source>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>commons-lang:commons-lang:2.6</id>\r
-                                    <source>true</source>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>commons-io:commons-io:1.4</id>\r
-                                    <source>true</source>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>org.apache.pdfbox:pdfbox:2.0.2</id>\r
-                                    <source>true</source>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>org.apache.pdfbox:fontbox:2.0.2</id>\r
-                                    <source>true</source>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>org.apache.pdfbox:xmpbox:2.0.2</id>\r
-                                    <source>true</source>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>log4j:log4j:1.2.17</id>\r
-                                    <source>true</source>\r
-                                    <override>true</override>\r
-                                    <instructions>\r
-                                        <Bundle-SymbolicName>org.apache.log4j</Bundle-SymbolicName>\r
-                                    </instructions>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>net.sf.ucanaccess:ucanaccess:3.0.6</id>\r
-                                    <source>true</source>\r
-                                    <instructions>\r
-                                        <Bundle-SymbolicName>net.ucanaccess</Bundle-SymbolicName>\r
-                                    </instructions>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>it.unimi.dsi:fastutil:7.0.12</id>\r
-                                    <source>true</source>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>org.eclipse.collections:eclipse-collections-api:7.1.0</id>\r
-                                    <override>true</override>\r
-                                    <source>true</source>\r
-                                    <instructions>\r
-                                        <Export-Package>org.eclipse.collections.*</Export-Package>\r
-                                    </instructions>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>org.eclipse.collections:eclipse-collections:7.1.0</id>\r
-                                    <source>true</source>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>net.sf.trove4j:trove4j:2.1.0</id>\r
-                                    <source>true</source>\r
-                                    <instructions>\r
-                                        <Bundle-Name>GNU Trove 2</Bundle-Name>\r
-                                        <Bundle-SymbolicName>gnu.trove2</Bundle-SymbolicName>\r
-                                    </instructions>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>net.sf.trove4j:trove4j:3.0.3</id>\r
-                                    <source>true</source>\r
-                                    <instructions>\r
-                                        <Bundle-Name>GNU Trove 3</Bundle-Name>\r
-                                        <Bundle-SymbolicName>gnu.trove3</Bundle-SymbolicName>\r
-                                    </instructions>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>org.freemarker:freemarker:2.3.23</id>\r
-                                    <source>true</source>\r
-                                    <override>true</override>\r
-                                    <instructions>\r
-                                        <Bundle-SymbolicName>freemarker</Bundle-SymbolicName>\r
-                                    </instructions>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>com.lowagie:itext:2.1.7</id>\r
-                                    <source>true</source>\r
-                                    <instructions>\r
-                                        <Bundle-SymbolicName>com.lowagie.text</Bundle-SymbolicName>\r
-                                        <Bundle-Version>${itext.version.actual}</Bundle-Version>\r
-                                    </instructions>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>javax.vecmath:vecmath:1.5.2</id>\r
-                                    <transitive>false</transitive>\r
-                                    <override>true</override>\r
-                                    <instructions>\r
-                                        <Export-Package>javax.vecmath</Export-Package>\r
-                                    </instructions>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>org.mozilla:rhino:1.7.7.1</id>\r
-                                    <source>true</source>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>net.java.dev.jna:jna:4.2.2</id>\r
-                                    <source>true</source>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>net.java.dev.jna:jna-platform:4.2.2</id>\r
-                                    <source>true</source>\r
-                                </artifact>\r
-                                <artifact>\r
-                                    <id>com.fasterxml.jackson.core:jackson-core:2.8.2</id>\r
-                                    <source>true</source>\r
-                                </artifact>\r
-                            </artifacts>\r
-                        </configuration>\r
-                    </execution>\r
-                </executions>\r
-            </plugin>\r
-\r
-            <plugin>\r
-                <groupId>org.mortbay.jetty</groupId>\r
-                <artifactId>jetty-maven-plugin</artifactId>\r
-                <version>8.1.5.v20120716</version>\r
-                <configuration>\r
-                    <scanIntervalSeconds>10</scanIntervalSeconds>\r
-                    <webAppSourceDirectory>${basedir}/target/repository/</webAppSourceDirectory>\r
-                    <webApp>\r
-                        <contextPath>/site</contextPath>\r
-                    </webApp>\r
-                </configuration>\r
-            </plugin>\r
-        </plugins>\r
-    </build>\r
-\r
-    <pluginRepositories>\r
-        <pluginRepository>\r
-            <id>reficio</id>\r
-            <url>http://repo.reficio.org/maven/</url>\r
-        </pluginRepository>\r
-    </pluginRepositories>\r
-\r
-</project>\r
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001 XMLSchema-instance"
+       xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
+       <modelVersion>4.0.0</modelVersion>
+
+    <groupId>org.simantics</groupId>
+    <artifactId>org.simantics.sdk.build.p2.site</artifactId>
+    <packaging>pom</packaging>
+    <version>1.25.0</version>
+
+    <properties>
+        <itext.version.actual>2.1.7.b1</itext.version.actual>
+        <lucene.version>4.9.0</lucene.version>
+        <lucene.version.actual>4.9.0.b0003</lucene.version.actual>
+        <lucene.prefix>org.apache.lucene4</lucene.prefix>
+    </properties>
+
+
+    <repositories>
+        <!--
+        <repository>
+            <id>project-specific-deps</id>
+            <name>project-specific-deps</name>
+            <url>file:///${basedir}/repo</url>
+        </repository>
+        -->
+    </repositories>
+
+    <build>
+        <plugins>
+            <plugin>
+                <groupId>org.eclipse.tycho.extras</groupId>
+                <artifactId>tycho-p2-extras-plugin</artifactId>
+                <version>0.25.0</version>
+            </plugin>
+            <plugin>
+                <groupId>org.reficio</groupId>
+                <artifactId>p2-maven-plugin</artifactId>
+                <version>1.2.0-SNAPSHOT</version>
+                <executions>
+                    <execution>
+                        <id>default-cli</id>
+                        <!-- QUICK-START EXAMPLE -->
+                        <!--
+                        This is the default quick-start configuration.
+
+                        Expected behavior:
+                          - specified dependencies will be fetched
+                          - transitive dependencies will be fetched (no default exclusions)
+                          - jars containing source source code will NOT be fetched
+                          - jars that are NOT OSGi bundles will be "bundled" using bnd tool,
+                            if you specify instructions for these jars they will be APPLIED
+                          - jars that are OSGi bundles will be simply included
+                            if you specify instructions for these jars they will be IGNORED (see <override> option)
+                          - p2 site will be generated
+
+                        How the instructions works:
+                          - instructions are applied only to the root artifact that you specify!
+                          - instructions are not applied to the TRANSITIVE dependencies!
+                          - transitive dependencies are never overridden (see <override> option)
+                          - transitive dependencies are bundled using the default instructions:
+                              <instructions>
+                                  <Import-Package>*;resolution:=optional</Import-Package>
+                                  <Export-Package>*</Export-Package>
+                              </instructions>
+                          - other instructions, such as, Bundle-SymbolicName, Bundle-Name, Bundle-Version, etc.
+                            are calculated according to the following rules:
+                            http://felix.apache.org/site/apache-felix-maven-bundle-plugin-bnd.html
+                          - if you specify any instructions they will be applied only if
+                            the jar is not already an OSGi bundle - otherwise you have to use the override
+                            option - please see the /examples/override/pom.xml example
+
+                        The following definition of an artifact:
+                            <artifact>
+                                <id>commons-io:commons-io:2.1</id>
+                            </artifact>
+
+                        is an equivalent of the following definition:
+                            <artifact>
+                                <id>commons-io:commons-io:2.1</id>
+                                <transitive>true</transitive>
+                                <source>false</source>
+                                <override>false</override>
+                                <instructions>
+                                    <Import-Package>*;resolution:=optional</Import-Package>
+                                    <Export-Package>*</Export-Package>
+                                </instructions>
+                                <excludes/>
+                            </artifact>
+
+                        To run the example please invoke: mvn p2:site
+                        -->
+                        <configuration>
+                            <artifacts>
+                                <artifact>
+                                    <id>org.antlr:antlr-runtime:3.5.2</id>
+                                    <source>true</source>
+                                </artifact>
+                                <artifact>
+                                    <id>org.apache.poi:poi:3.14</id>
+                                    <source>true</source>
+                                </artifact>
+                                <artifact>
+                                    <id>org.apache.poi:poi-ooxml:3.14</id>
+                                    <source>true</source>
+                                </artifact>
+                                <artifact>
+                                    <id>org.apache.lucene:lucene-core:${lucene.version}</id>
+                                    <source>true</source>
+                                    <instructions>
+                                        <Bundle-SymbolicName>${lucene.prefix}.core</Bundle-SymbolicName>
+                                        <Bundle-Version>${lucene.version.actual}</Bundle-Version>
+                                        <Export-Package>*;version="${lucene.version}"</Export-Package>
+                                    </instructions>
+                                </artifact>
+                                <artifact>
+                                    <id>org.apache.lucene:lucene-queries:${lucene.version}</id>
+                                    <source>true</source>
+                                    <instructions>
+                                        <Bundle-SymbolicName>${lucene.prefix}.queries</Bundle-SymbolicName>
+                                        <Bundle-Version>${lucene.version.actual}</Bundle-Version>
+                                        <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}"</Require-Bundle>
+                                        <Export-Package>*;version="${lucene.version}"</Export-Package>
+                                        <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>
+                                    </instructions>
+                                </artifact>
+                                <artifact>
+                                    <id>org.apache.lucene:lucene-sandbox:${lucene.version}</id>
+                                    <source>true</source>
+                                    <instructions>
+                                        <Bundle-SymbolicName>${lucene.prefix}.sandbox</Bundle-SymbolicName>
+                                        <Bundle-Version>${lucene.version.actual}</Bundle-Version>
+                                        <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}"</Require-Bundle>
+                                        <Export-Package>*;version="${lucene.version}"</Export-Package>
+                                        <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>
+                                    </instructions>
+                                </artifact>
+                                <artifact>
+                                    <id>org.apache.lucene:lucene-analyzers-common:${lucene.version}</id>
+                                    <source>true</source>
+                                    <instructions>
+                                        <Bundle-SymbolicName>${lucene.prefix}.analyzers-common</Bundle-SymbolicName>
+                                        <Bundle-Version>${lucene.version.actual}</Bundle-Version>
+                                        <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}"</Require-Bundle>
+                                        <Export-Package>*;version="${lucene.version}"</Export-Package>
+                                        <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>
+                                    </instructions>
+                                </artifact>
+                                <artifact>
+                                    <id>org.apache.lucene:lucene-queryparser:${lucene.version}</id>
+                                    <source>true</source>
+                                    <instructions>
+                                        <Bundle-SymbolicName>${lucene.prefix}.queryparser</Bundle-SymbolicName>
+                                        <Bundle-Version>${lucene.version.actual}</Bundle-Version>
+                                        <Require-Bundle>${lucene.prefix}.core;bundle-version="${lucene.version}",${lucene.prefix}.queries;bundle-version="${lucene.version}",${lucene.prefix}.sandbox;bundle-version="${lucene.version}"</Require-Bundle>
+                                        <Export-Package>*;version="${lucene.version}"</Export-Package>
+                                        <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>
+                                    </instructions>
+                                </artifact>
+                                <artifact>
+                                    <id>org.jdom:jdom2:2.0.6</id>
+                                    <source>true</source>
+                                    <instructions>
+                                        <Bundle-SymbolicName>org.jdom2</Bundle-SymbolicName>
+                                    </instructions>
+                                </artifact>
+                                <artifact>
+                                    <id>org.jfree:jfreechart:1.0.19</id>
+                                    <source>true</source>
+                                    <instructions>
+                                        <Bundle-SymbolicName>org.jfree.jchart</Bundle-SymbolicName>
+                                    </instructions>
+                                </artifact>
+                                <!--
+                                <artifact>
+                                    <id>org.ow2.asm:asm:5.0.4</id>
+                                    <source>true</source>
+                                    <override>true</override>
+                                    <instructions>
+                                        <Bundle-SymbolicName>org.objectweb.asm5</Bundle-SymbolicName>
+                                    </instructions>
+                                </artifact>
+                                -->
+                                <artifact>
+                                    <id>net.sf.supercsv:super-csv:2.4.0</id>
+                                    <source>true</source>
+                                    <override>true</override>
+                                    <instructions>
+                                        <Bundle-SymbolicName>org.supercsv</Bundle-SymbolicName>
+                                    </instructions>
+                                </artifact>
+                                <artifact>
+                                    <id>org.ini4j:ini4j:0.5.4</id>
+                                    <source>true</source>
+                                </artifact>
+                                <artifact>
+                                    <id>commons-collections:commons-collections:3.2.2</id>
+                                    <source>true</source>
+                                </artifact>
+                                <artifact>
+                                    <id>org.apache.commons:commons-compress:1.12</id>
+                                    <source>true</source>
+                                </artifact>
+                                <artifact>
+                                    <id>commons-lang:commons-lang:2.6</id>
+                                    <source>true</source>
+                                </artifact>
+                                <artifact>
+                                    <id>commons-io:commons-io:1.4</id>
+                                    <source>true</source>
+                                </artifact>
+                                <artifact>
+                                    <id>org.apache.pdfbox:pdfbox:2.0.2</id>
+                                    <source>true</source>
+                                </artifact>
+                                <artifact>
+                                    <id>org.apache.pdfbox:fontbox:2.0.2</id>
+                                    <source>true</source>
+                                </artifact>
+                                <artifact>
+                                    <id>org.apache.pdfbox:xmpbox:2.0.2</id>
+                                    <source>true</source>
+                                </artifact>
+                                <artifact>
+                                    <id>log4j:log4j:1.2.17</id>
+                                    <source>true</source>
+                                    <override>true</override>
+                                    <instructions>
+                                        <Bundle-SymbolicName>org.apache.log4j</Bundle-SymbolicName>
+                                    </instructions>
+                                </artifact>
+                                <artifact>
+                                    <id>net.sf.ucanaccess:ucanaccess:3.0.6</id>
+                                    <source>true</source>
+                                    <instructions>
+                                        <Bundle-SymbolicName>net.ucanaccess</Bundle-SymbolicName>
+                                    </instructions>
+                                </artifact>
+                                <artifact>
+                                    <id>it.unimi.dsi:fastutil:7.0.12</id>
+                                    <source>true</source>
+                                </artifact>
+                                <artifact>
+                                    <id>org.eclipse.collections:eclipse-collections-api:7.1.0</id>
+                                    <override>true</override>
+                                    <source>true</source>
+                                    <instructions>
+                                        <Export-Package>org.eclipse.collections.*</Export-Package>
+                                    </instructions>
+                                </artifact>
+                                <artifact>
+                                    <id>org.eclipse.collections:eclipse-collections:7.1.0</id>
+                                    <source>true</source>
+                                </artifact>
+                                <artifact>
+                                    <id>net.sf.trove4j:trove4j:2.1.0</id>
+                                    <source>true</source>
+                                    <instructions>
+                                        <Bundle-Name>GNU Trove 2</Bundle-Name>
+                                        <Bundle-SymbolicName>gnu.trove2</Bundle-SymbolicName>
+                                    </instructions>
+                                </artifact>
+                                <artifact>
+                                    <id>net.sf.trove4j:trove4j:3.0.3</id>
+                                    <source>true</source>
+                                    <instructions>
+                                        <Bundle-Name>GNU Trove 3</Bundle-Name>
+                                        <Bundle-SymbolicName>gnu.trove3</Bundle-SymbolicName>
+                                    </instructions>
+                                </artifact>
+                                <artifact>
+                                    <id>org.freemarker:freemarker:2.3.23</id>
+                                    <source>true</source>
+                                    <override>true</override>
+                                    <instructions>
+                                        <Bundle-SymbolicName>freemarker</Bundle-SymbolicName>
+                                    </instructions>
+                                </artifact>
+                                <artifact>
+                                    <id>com.lowagie:itext:2.1.7</id>
+                                    <source>true</source>
+                                    <instructions>
+                                        <Bundle-SymbolicName>com.lowagie.text</Bundle-SymbolicName>
+                                        <Bundle-Version>${itext.version.actual}</Bundle-Version>
+                                    </instructions>
+                                </artifact>
+                                <artifact>
+                                    <id>javax.vecmath:vecmath:1.5.2</id>
+                                    <transitive>false</transitive>
+                                    <override>true</override>
+                                    <instructions>
+                                        <Export-Package>javax.vecmath</Export-Package>
+                                    </instructions>
+                                </artifact>
+                                <artifact>
+                                    <id>org.mozilla:rhino:1.7.7.1</id>
+                                    <source>true</source>
+                                </artifact>
+                                <artifact>
+                                    <id>net.java.dev.jna:jna:4.2.2</id>
+                                    <source>true</source>
+                                </artifact>
+                                <artifact>
+                                    <id>net.java.dev.jna:jna-platform:4.2.2</id>
+                                    <source>true</source>
+                                </artifact>
+                                <artifact>
+                                    <id>com.fasterxml.jackson.core:jackson-core:2.8.2</id>
+                                    <source>true</source>
+                                </artifact>
+                                <artifact>
+                                    <id>org.slf4j:slf4j-api:1.7.20</id>
+                                    <source>true</source>
+                                    <override>true</override>
+                                    <instructions>
+                                        <Bundle-Name>SLF4J API Module</Bundle-Name>
+                                        <Bundle-SymbolicName>org.slf4j.api</Bundle-SymbolicName>
+                                    </instructions>
+                                </artifact>
+                                <artifact>
+                                    <id>ch.qos.logback:logback-classic:1.1.7</id>
+                                    <source>true</source>
+                                </artifact>
+                            </artifacts>
+                        </configuration>
+                    </execution>
+                </executions>
+            </plugin>
+
+            <plugin>
+                <groupId>org.mortbay.jetty</groupId>
+                <artifactId>jetty-maven-plugin</artifactId>
+                <version>8.1.5.v20120716</version>
+                <configuration>
+                    <scanIntervalSeconds>10</scanIntervalSeconds>
+                    <webAppSourceDirectory>${basedir}/target/repository/</webAppSourceDirectory>
+                    <webApp>
+                        <contextPath>/site</contextPath>
+                    </webApp>
+                </configuration>
+            </plugin>
+        </plugins>
+    </build>
+
+    <pluginRepositories>
+        <pluginRepository>
+            <id>reficio</id>
+            <url>http://repo.reficio.org/maven/</url>
+        </pluginRepository>
+    </pluginRepositories>
+
+</project>
index aba69b350da9dc263b60076ec998634941ccece9..30877826a1d8e78abc9e556caae529064a6999f0 100644 (file)
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>\r
-<?pde version="3.8"?><target name="Eclipse Mars.2" sequenceNumber="141">\r
-<locations>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.eclipse.mylyn.wikitext_feature.feature.group" version="2.7.0.v20151015-1452"/>\r
-<unit id="org.eclipse.emf.sdk.feature.group" version="2.11.2.v20160208-0841"/>\r
-<unit id="org.eclipse.epp.mpc.feature.group" version="1.4.2.v20160210-2005"/>\r
-<repository location="http://dev.simupedia.com/download/mars"/>\r
-</location>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.eclipse.ecf.core.ssl.feature.feature.group" version="1.1.0.v20151130-0157"/>\r
-<unit id="org.eclipse.rcp.source.feature.group" version="4.5.2.v20160212-1500"/>\r
-<unit id="org.eclipse.e4.core.tools.feature.feature.group" version="4.5.1.v20160129-0959"/>\r
-<unit id="org.eclipse.ecf.filetransfer.source.feature.feature.group" version="3.12.0.v20151130-0157"/>\r
-<unit id="org.eclipse.ecf.filetransfer.ssl.feature.feature.group" version="1.1.0.v20151130-0157"/>\r
-<unit id="org.eclipse.help.feature.group" version="2.1.2.v20160212-1500"/>\r
-<unit id="org.eclipse.ecf.filetransfer.httpclient4.source.feature.feature.group" version="3.12.0.v20151130-0157"/>\r
-<unit id="org.eclipse.e4.core.tools.feature.source.feature.group" version="4.5.1.v20160129-0959"/>\r
-<unit id="org.eclipse.swt.tools.feature.feature.group" version="3.104.2.v20160128-0900"/>\r
-<unit id="org.eclipse.ecf.filetransfer.httpclient4.feature.feature.group" version="3.12.0.v20151130-0157"/>\r
-<unit id="org.eclipse.ecf.filetransfer.ssl.source.feature.feature.group" version="1.1.0.v20151130-0157"/>\r
-<unit id="org.eclipse.platform.feature.group" version="4.5.2.v20160212-1500"/>\r
-<unit id="org.eclipse.ecf.core.ssl.source.feature.feature.group" version="1.1.0.v20151130-0157"/>\r
-<unit id="org.eclipse.rcp.feature.group" version="4.5.2.v20160212-1500"/>\r
-<unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="1.0.300.v20150430-1836"/>\r
-<unit id="org.eclipse.ecf.core.feature.feature.group" version="1.2.0.v20151130-0157"/>\r
-<unit id="org.eclipse.ecf.core.source.feature.feature.group" version="1.2.0.v20151130-0157"/>\r
-<unit id="org.eclipse.equinox.sdk.feature.group" version="3.11.2.v20160202-2102"/>\r
-<unit id="org.eclipse.platform.source.feature.group" version="4.5.2.v20160212-1500"/>\r
-<unit id="org.eclipse.releng.tools.feature.group" version="3.6.0.v20150527-0145"/>\r
-<unit id="org.eclipse.ecf.filetransfer.feature.feature.group" version="3.12.0.v20151130-0157"/>\r
-<unit id="org.eclipse.sdk.ide" version="4.5.2.M20160212-1500"/>\r
-<unit id="org.eclipse.ecf.filetransfer.httpclient4.ssl.feature.feature.group" version="1.1.0.v20151130-0157"/>\r
-<unit id="org.eclipse.help.source.feature.group" version="2.1.2.v20160212-1500"/>\r
-<unit id="org.eclipse.ecf.filetransfer.httpclient4.ssl.source.feature.feature.group" version="1.1.0.v20151130-0157"/>\r
-<repository location="http://dev.simupedia.com/download/eclipse/updates/4.5"/>\r
-</location>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.eclipse.nebula.effects.stw.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.visualization.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.calendarcombo.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.gallery.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.cwt.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.oscilloscope.feature.feature.group" version="1.2.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.pshelf.css.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.ganttchart.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.xviewer.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.compositetable.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.grid.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.cdatetime.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.pshelf.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.richtext.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.tablecombo.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.paperclips.feature.feature.group" version="2.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.examples.release.feature.feature.group" version="1.0.4.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.pgroup.feature.feature.group" version="1.0.0.201605182147"/>\r
-<repository location="http://dev.simupedia.com/download/nebula/Q22016/release/"/>\r
-</location>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.eclipse.e4.tools.spies.feature.feature.group" version="0.17.0.v20160919-2121"/>\r
-<repository location="http://dev.simupedia.com/download/e4/snapshots/org.eclipse.e4.tools/latest/"/>\r
-</location>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.eclipse.nebula.incubation.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.examples.incubation.feature.feature.group" version="1.0.0.201605182147"/>\r
-<repository location="http://dev.simupedia.com/download/nebula/Q22016/incubation"/>\r
-</location>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.eclipse.nebula.widgets.nattable.core.feature.feature.group" version="1.4.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.e4.source.feature.feature.group" version="1.0.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.poi.feature.feature.group" version="1.4.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.feature.feature.group" version="1.4.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.core.source.feature.feature.group" version="1.4.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.source.feature.feature.group" version="1.4.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.feature.feature.group" version="1.0.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.e4.feature.feature.group" version="1.0.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.source.feature.feature.group" version="1.0.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.poi.source.feature.feature.group" version="1.4.0.201606011907"/>\r
-<repository location="http://dev.simupedia.com/download/nebula/nattable/releases/1.4.0/repository/"/>\r
-</location>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.apache.commons.lang.source" version="2.6.0"/>\r
-<unit id="org.antlr.runtime.source" version="3.5.2"/>\r
-<unit id="org.apache.commons.compress" version="1.12.0"/>\r
-<unit id="org.apache.pdfbox.source" version="2.0.2"/>\r
-<unit id="org.bouncycastle.bcmail-jdk14.source" version="1.38.0"/>\r
-<unit id="org.ini4j" version="0.5.4"/>\r
-<unit id="org.jdom2.source" version="2.0.6"/>\r
-<unit id="org.apache.commons.logging" version="1.2.0"/>\r
-<unit id="org.apache.pdfbox.xmpbox.source" version="2.0.2"/>\r
-<unit id="net.ucanaccess" version="3.0.6"/>\r
-<unit id="gnu.trove2" version="2.1.0"/>\r
-<unit id="net.ucanaccess.source" version="3.0.6"/>\r
-<unit id="org.eclipse.collections.eclipse-collections.source" version="7.1.0"/>\r
-<unit id="freemarker" version="2.3.23.stable"/>\r
-<unit id="com.github.virtuald.curvesapi.source" version="1.3.0"/>\r
-<unit id="org.apache.commons.collections.source" version="3.2.2"/>\r
-<unit id="org.apache.pdfbox.fontbox" version="2.0.2"/>\r
-<unit id="org.apache.commons.compress.source" version="1.12.0"/>\r
-<unit id="org.apache.lucene4.queryparser.source" version="4.9.0.b0003"/>\r
-<unit id="org.mozilla.rhino.source" version="1.7.7.1"/>\r
-<unit id="freemarker.source" version="2.3.23.stable"/>\r
-<unit id="jakarta-regexp" version="1.4.0"/>\r
-<unit id="net.jcip.annotations.source" version="1.0.0"/>\r
-<unit id="org.apache.log4j.source" version="1.2.17"/>\r
-<unit id="org.apache.commons.logging.source" version="1.2.0"/>\r
-<unit id="org.apache.commons.io.source" version="1.4.0"/>\r
-<unit id="com.healthmarketscience.jackcess" version="2.1.3"/>\r
-<unit id="org.bouncycastle.bctsp-jdk14.source" version="1.38.0"/>\r
-<unit id="org.eclipse.collections.eclipse-collections-api" version="7.1.0"/>\r
-<unit id="gnu.trove3.source" version="3.0.3"/>\r
-<unit id="it.unimi.dsi.fastutil.source" version="7.0.12"/>\r
-<unit id="org.hsqldb.hsqldb.source" version="2.3.1"/>\r
-<unit id="org.apache.poi.source" version="3.14.0"/>\r
-<unit id="org.apache.lucene4.sandbox.source" version="4.9.0.b0003"/>\r
-<unit id="org.apache.xmlbeans" version="2.6.0"/>\r
-<unit id="org.supercsv" version="2.4.0"/>\r
-<unit id="org.mozilla.rhino" version="1.7.7.1"/>\r
-<unit id="org.apache.pdfbox.xmpbox" version="2.0.2"/>\r
-<unit id="org.apache.commons.codec" version="1.10.0"/>\r
-<unit id="com.healthmarketscience.jackcess.source" version="2.1.3"/>\r
-<unit id="org.eclipse.collections.eclipse-collections-api.source" version="7.1.0"/>\r
-<unit id="org.bouncycastle.bcprov-jdk14.source" version="1.38.0"/>\r
-<unit id="stax.api" version="1.0.1"/>\r
-<unit id="org.apache.pdfbox.fontbox.source" version="2.0.2"/>\r
-<unit id="it.unimi.dsi.fastutil" version="7.0.12"/>\r
-<unit id="com.lowagie.text.source" version="2.1.7.b1"/>\r
-<unit id="net.jcip.annotations" version="1.0.0"/>\r
-<unit id="org.apache.lucene4.queryparser" version="4.9.0.b0003"/>\r
-<unit id="org.bouncycastle.bctsp-jdk14" version="1.38.0"/>\r
-<unit id="org.jfree.jchart.source" version="1.0.19"/>\r
-<unit id="com.lowagie.text" version="2.1.7.b1"/>\r
-<unit id="org.apache.poi.ooxml-schemas" version="3.14.0"/>\r
-<unit id="org.bouncycastle.bcprov-jdk14" version="1.38.0"/>\r
-<unit id="com.sun.jna" version="4.2.2"/>\r
-<unit id="org.apache.poi" version="3.14.0"/>\r
-<unit id="org.jdom2" version="2.0.6"/>\r
-<unit id="org.apache.commons.lang" version="2.6.0"/>\r
-<unit id="org.jfree.jchart" version="1.0.19"/>\r
-<unit id="org.apache.lucene4.sandbox" version="4.9.0.b0003"/>\r
-<unit id="org.apache.commons.codec.source" version="1.10.0"/>\r
-<unit id="org.supercsv.source" version="2.4.0"/>\r
-<unit id="com.github.virtuald.curvesapi" version="1.3.0"/>\r
-<unit id="org.eclipse.collections.eclipse-collections" version="7.1.0"/>\r
-<unit id="org.apache.log4j" version="1.2.17"/>\r
-<unit id="org.apache.lucene4.queries.source" version="4.9.0.b0003"/>\r
-<unit id="com.fasterxml.jackson.core.jackson-core.source" version="2.8.2"/>\r
-<unit id="org.apache.lucene4.core.source" version="4.9.0.b0003"/>\r
-<unit id="com.sun.jna.source" version="4.2.2"/>\r
-<unit id="org.apache.poi.ooxml" version="3.14.0"/>\r
-<unit id="com.sun.jna.platform" version="4.2.2"/>\r
-<unit id="org.apache.lucene4.analyzers-common.source" version="4.9.0.b0003"/>\r
-<unit id="org.apache.pdfbox" version="2.0.2"/>\r
-<unit id="org.bouncycastle.bcmail-jdk14" version="1.38.0"/>\r
-<unit id="org.jfree.jcommon" version="1.0.23"/>\r
-<unit id="org.apache.lucene4.analyzers-common" version="4.9.0.b0003"/>\r
-<unit id="org.apache.commons.collections" version="3.2.2"/>\r
-<unit id="org.apache.poi.ooxml.source" version="3.14.0"/>\r
-<unit id="com.fasterxml.jackson.core.jackson-core" version="2.8.2"/>\r
-<unit id="org.apache.lucene4.core" version="4.9.0.b0003"/>\r
-<unit id="gnu.trove2.source" version="2.1.0"/>\r
-<unit id="gnu.trove3" version="3.0.3"/>\r
-<unit id="org.antlr.runtime" version="3.5.2"/>\r
-<unit id="org.jfree.jcommon.source" version="1.0.23"/>\r
-<unit id="org.hsqldb.hsqldb" version="2.3.1"/>\r
-<unit id="org.apache.commons.io" version="1.4.0"/>\r
-<unit id="bouncycastle.bcmail-jdk14" version="138.0.0"/>\r
-<unit id="org.apache.lucene4.queries" version="4.9.0.b0003"/>\r
-<unit id="com.sun.jna.platform.source" version="4.2.2"/>\r
-<unit id="javax.vecmath" version="1.5.2"/>\r
-<unit id="bouncycastle.bcprov-jdk14" version="138.0.0"/>\r
-<unit id="org.ini4j.source" version="0.5.4"/>\r
-<repository location="http://dev.simupedia.com/download/master/external-components"/>\r
-</location>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.objectweb.asm.xml.source" version="5.0.1.v201404251740"/>\r
-<unit id="org.objectweb.asm.util.source" version="5.0.1.v201404251740"/>\r
-<unit id="org.objectweb.asm.source" version="5.0.1.v201404251740"/>\r
-<unit id="com.google.guava" version="15.0.0.v201403281430"/>\r
-<unit id="org.objectweb.asm.util" version="5.0.1.v201404251740"/>\r
-<unit id="org.objectweb.asm.xml" version="5.0.1.v201404251740"/>\r
-<unit id="com.google.guava.source" version="15.0.0.v201403281430"/>\r
-<unit id="org.objectweb.asm" version="5.0.1.v201404251740"/>\r
-<unit id="org.objectweb.asm.commons" version="5.0.1.v201404251740"/>\r
-<unit id="org.objectweb.asm.analysis.source" version="5.0.1.v201505121915"/>\r
-<unit id="org.objectweb.asm.commons.source" version="5.0.1.v201404251740"/>\r
-<unit id="org.objectweb.asm.tree.source" version="5.0.1.v201404251740"/>\r
-<unit id="org.objectweb.asm.analysis" version="5.0.1.v201505121915"/>\r
-<unit id="org.objectweb.asm.tree" version="5.0.1.v201404251740"/>\r
-<repository location="http://dev.simupedia.com/download/tools/orbit/downloads/drops/R20160221192158/repository/"/>\r
-</location>\r
-</locations>\r
-</target>\r
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<?pde version="3.8"?><target name="Eclipse Mars.2" sequenceNumber="141">
+<locations>
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.eclipse.mylyn.wikitext_feature.feature.group" version="2.7.0.v20151015-1452"/>
+<unit id="org.eclipse.emf.sdk.feature.group" version="2.11.2.v20160208-0841"/>
+<unit id="org.eclipse.epp.mpc.feature.group" version="1.4.2.v20160210-2005"/>
+<repository location="http://dev.simupedia.com/download/mars"/>
+</location>
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.eclipse.ecf.core.ssl.feature.feature.group" version="1.1.0.v20151130-0157"/>
+<unit id="org.eclipse.rcp.source.feature.group" version="4.5.2.v20160212-1500"/>
+<unit id="org.eclipse.e4.core.tools.feature.feature.group" version="4.5.1.v20160129-0959"/>
+<unit id="org.eclipse.ecf.filetransfer.source.feature.feature.group" version="3.12.0.v20151130-0157"/>
+<unit id="org.eclipse.ecf.filetransfer.ssl.feature.feature.group" version="1.1.0.v20151130-0157"/>
+<unit id="org.eclipse.help.feature.group" version="2.1.2.v20160212-1500"/>
+<unit id="org.eclipse.ecf.filetransfer.httpclient4.source.feature.feature.group" version="3.12.0.v20151130-0157"/>
+<unit id="org.eclipse.e4.core.tools.feature.source.feature.group" version="4.5.1.v20160129-0959"/>
+<unit id="org.eclipse.swt.tools.feature.feature.group" version="3.104.2.v20160128-0900"/>
+<unit id="org.eclipse.ecf.filetransfer.httpclient4.feature.feature.group" version="3.12.0.v20151130-0157"/>
+<unit id="org.eclipse.ecf.filetransfer.ssl.source.feature.feature.group" version="1.1.0.v20151130-0157"/>
+<unit id="org.eclipse.platform.feature.group" version="4.5.2.v20160212-1500"/>
+<unit id="org.eclipse.ecf.core.ssl.source.feature.feature.group" version="1.1.0.v20151130-0157"/>
+<unit id="org.eclipse.rcp.feature.group" version="4.5.2.v20160212-1500"/>
+<unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="1.0.300.v20150430-1836"/>
+<unit id="org.eclipse.ecf.core.feature.feature.group" version="1.2.0.v20151130-0157"/>
+<unit id="org.eclipse.ecf.core.source.feature.feature.group" version="1.2.0.v20151130-0157"/>
+<unit id="org.eclipse.equinox.sdk.feature.group" version="3.11.2.v20160202-2102"/>
+<unit id="org.eclipse.platform.source.feature.group" version="4.5.2.v20160212-1500"/>
+<unit id="org.eclipse.releng.tools.feature.group" version="3.6.0.v20150527-0145"/>
+<unit id="org.eclipse.ecf.filetransfer.feature.feature.group" version="3.12.0.v20151130-0157"/>
+<unit id="org.eclipse.sdk.ide" version="4.5.2.M20160212-1500"/>
+<unit id="org.eclipse.ecf.filetransfer.httpclient4.ssl.feature.feature.group" version="1.1.0.v20151130-0157"/>
+<unit id="org.eclipse.help.source.feature.group" version="2.1.2.v20160212-1500"/>
+<unit id="org.eclipse.ecf.filetransfer.httpclient4.ssl.source.feature.feature.group" version="1.1.0.v20151130-0157"/>
+<repository location="http://dev.simupedia.com/download/eclipse/updates/4.5"/>
+</location>
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.eclipse.nebula.effects.stw.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.visualization.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.calendarcombo.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.gallery.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.cwt.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.oscilloscope.feature.feature.group" version="1.2.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.pshelf.css.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.ganttchart.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.xviewer.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.compositetable.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.grid.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.cdatetime.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.pshelf.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.richtext.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.tablecombo.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.paperclips.feature.feature.group" version="2.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.examples.release.feature.feature.group" version="1.0.4.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.pgroup.feature.feature.group" version="1.0.0.201605182147"/>
+<repository location="http://dev.simupedia.com/download/nebula/Q22016/release/"/>
+</location>
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.eclipse.e4.tools.spies.feature.feature.group" version="0.17.0.v20160919-2121"/>
+<repository location="http://dev.simupedia.com/download/e4/snapshots/org.eclipse.e4.tools/latest/"/>
+</location>
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.eclipse.nebula.incubation.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.examples.incubation.feature.feature.group" version="1.0.0.201605182147"/>
+<repository location="http://dev.simupedia.com/download/nebula/Q22016/incubation"/>
+</location>
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.eclipse.nebula.widgets.nattable.core.feature.feature.group" version="1.4.0.201606011907"/>
+<unit id="org.eclipse.nebula.widgets.nattable.extension.e4.source.feature.feature.group" version="1.0.0.201606011907"/>
+<unit id="org.eclipse.nebula.widgets.nattable.extension.poi.feature.feature.group" version="1.4.0.201606011907"/>
+<unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.feature.feature.group" version="1.4.0.201606011907"/>
+<unit id="org.eclipse.nebula.widgets.nattable.core.source.feature.feature.group" version="1.4.0.201606011907"/>
+<unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.source.feature.feature.group" version="1.4.0.201606011907"/>
+<unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.feature.feature.group" version="1.0.0.201606011907"/>
+<unit id="org.eclipse.nebula.widgets.nattable.extension.e4.feature.feature.group" version="1.0.0.201606011907"/>
+<unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.source.feature.feature.group" version="1.0.0.201606011907"/>
+<unit id="org.eclipse.nebula.widgets.nattable.extension.poi.source.feature.feature.group" version="1.4.0.201606011907"/>
+<repository location="http://dev.simupedia.com/download/nebula/nattable/releases/1.4.0/repository/"/>
+</location>
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.apache.commons.lang.source" version="2.6.0"/>
+<unit id="org.antlr.runtime.source" version="3.5.2"/>
+<unit id="org.apache.commons.compress" version="1.12.0"/>
+<unit id="org.apache.pdfbox.source" version="2.0.2"/>
+<unit id="org.bouncycastle.bcmail-jdk14.source" version="1.38.0"/>
+<unit id="org.ini4j" version="0.5.4"/>
+<unit id="org.jdom2.source" version="2.0.6"/>
+<unit id="org.apache.commons.logging" version="1.2.0"/>
+<unit id="org.apache.pdfbox.xmpbox.source" version="2.0.2"/>
+<unit id="net.ucanaccess" version="3.0.6"/>
+<unit id="gnu.trove2" version="2.1.0"/>
+<unit id="net.ucanaccess.source" version="3.0.6"/>
+<unit id="org.eclipse.collections.eclipse-collections.source" version="7.1.0"/>
+<unit id="freemarker" version="2.3.23.stable"/>
+<unit id="com.github.virtuald.curvesapi.source" version="1.3.0"/>
+<unit id="org.apache.commons.collections.source" version="3.2.2"/>
+<unit id="org.apache.pdfbox.fontbox" version="2.0.2"/>
+<unit id="org.apache.commons.compress.source" version="1.12.0"/>
+<unit id="org.apache.lucene4.queryparser.source" version="4.9.0.b0003"/>
+<unit id="org.mozilla.rhino.source" version="1.7.7.1"/>
+<unit id="freemarker.source" version="2.3.23.stable"/>
+<unit id="jakarta-regexp" version="1.4.0"/>
+<unit id="net.jcip.annotations.source" version="1.0.0"/>
+<unit id="org.apache.log4j.source" version="1.2.17"/>
+<unit id="org.apache.commons.logging.source" version="1.2.0"/>
+<unit id="org.apache.commons.io.source" version="1.4.0"/>
+<unit id="com.healthmarketscience.jackcess" version="2.1.3"/>
+<unit id="org.bouncycastle.bctsp-jdk14.source" version="1.38.0"/>
+<unit id="org.eclipse.collections.eclipse-collections-api" version="7.1.0"/>
+<unit id="gnu.trove3.source" version="3.0.3"/>
+<unit id="it.unimi.dsi.fastutil.source" version="7.0.12"/>
+<unit id="org.hsqldb.hsqldb.source" version="2.3.1"/>
+<unit id="org.apache.poi.source" version="3.14.0"/>
+<unit id="org.apache.lucene4.sandbox.source" version="4.9.0.b0003"/>
+<unit id="org.apache.xmlbeans" version="2.6.0"/>
+<unit id="org.supercsv" version="2.4.0"/>
+<unit id="org.mozilla.rhino" version="1.7.7.1"/>
+<unit id="org.apache.pdfbox.xmpbox" version="2.0.2"/>
+<unit id="org.apache.commons.codec" version="1.10.0"/>
+<unit id="com.healthmarketscience.jackcess.source" version="2.1.3"/>
+<unit id="org.eclipse.collections.eclipse-collections-api.source" version="7.1.0"/>
+<unit id="org.bouncycastle.bcprov-jdk14.source" version="1.38.0"/>
+<unit id="stax.api" version="1.0.1"/>
+<unit id="org.apache.pdfbox.fontbox.source" version="2.0.2"/>
+<unit id="it.unimi.dsi.fastutil" version="7.0.12"/>
+<unit id="com.lowagie.text.source" version="2.1.7.b1"/>
+<unit id="net.jcip.annotations" version="1.0.0"/>
+<unit id="org.apache.lucene4.queryparser" version="4.9.0.b0003"/>
+<unit id="org.bouncycastle.bctsp-jdk14" version="1.38.0"/>
+<unit id="org.jfree.jchart.source" version="1.0.19"/>
+<unit id="com.lowagie.text" version="2.1.7.b1"/>
+<unit id="org.apache.poi.ooxml-schemas" version="3.14.0"/>
+<unit id="org.bouncycastle.bcprov-jdk14" version="1.38.0"/>
+<unit id="com.sun.jna" version="4.2.2"/>
+<unit id="org.apache.poi" version="3.14.0"/>
+<unit id="org.jdom2" version="2.0.6"/>
+<unit id="org.apache.commons.lang" version="2.6.0"/>
+<unit id="org.jfree.jchart" version="1.0.19"/>
+<unit id="org.apache.lucene4.sandbox" version="4.9.0.b0003"/>
+<unit id="org.apache.commons.codec.source" version="1.10.0"/>
+<unit id="org.supercsv.source" version="2.4.0"/>
+<unit id="com.github.virtuald.curvesapi" version="1.3.0"/>
+<unit id="org.eclipse.collections.eclipse-collections" version="7.1.0"/>
+<unit id="org.apache.log4j" version="1.2.17"/>
+<unit id="org.apache.lucene4.queries.source" version="4.9.0.b0003"/>
+<unit id="com.fasterxml.jackson.core.jackson-core.source" version="2.8.2"/>
+<unit id="org.apache.lucene4.core.source" version="4.9.0.b0003"/>
+<unit id="com.sun.jna.source" version="4.2.2"/>
+<unit id="org.apache.poi.ooxml" version="3.14.0"/>
+<unit id="com.sun.jna.platform" version="4.2.2"/>
+<unit id="org.apache.lucene4.analyzers-common.source" version="4.9.0.b0003"/>
+<unit id="org.apache.pdfbox" version="2.0.2"/>
+<unit id="org.bouncycastle.bcmail-jdk14" version="1.38.0"/>
+<unit id="org.jfree.jcommon" version="1.0.23"/>
+<unit id="org.apache.lucene4.analyzers-common" version="4.9.0.b0003"/>
+<unit id="org.apache.commons.collections" version="3.2.2"/>
+<unit id="org.apache.poi.ooxml.source" version="3.14.0"/>
+<unit id="com.fasterxml.jackson.core.jackson-core" version="2.8.2"/>
+<unit id="org.apache.lucene4.core" version="4.9.0.b0003"/>
+<unit id="gnu.trove2.source" version="2.1.0"/>
+<unit id="gnu.trove3" version="3.0.3"/>
+<unit id="org.antlr.runtime" version="3.5.2"/>
+<unit id="org.jfree.jcommon.source" version="1.0.23"/>
+<unit id="org.hsqldb.hsqldb" version="2.3.1"/>
+<unit id="org.apache.commons.io" version="1.4.0"/>
+<unit id="bouncycastle.bcmail-jdk14" version="138.0.0"/>
+<unit id="org.apache.lucene4.queries" version="4.9.0.b0003"/>
+<unit id="com.sun.jna.platform.source" version="4.2.2"/>
+<unit id="javax.vecmath" version="1.5.2"/>
+<unit id="bouncycastle.bcprov-jdk14" version="138.0.0"/>
+<unit id="org.ini4j.source" version="0.5.4"/>
+<unit id="org.slf4j.api" version="1.7.20"/>
+<unit id="org.slf4j.api.source" version="1.7.20"/>
+<unit id="ch.qos.logback.classic" version="1.1.7"/>
+<unit id="ch.qos.logback.classic.source" version="1.1.7"/>
+<unit id="ch.qos.logback.core" version="1.1.7"/>
+<unit id="ch.qos.logback.core.source" version="1.1.7"/>
+<repository location="http://dev.simupedia.com/download/master/external-components"/>
+</location>
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.objectweb.asm.xml.source" version="5.0.1.v201404251740"/>
+<unit id="org.objectweb.asm.util.source" version="5.0.1.v201404251740"/>
+<unit id="org.objectweb.asm.source" version="5.0.1.v201404251740"/>
+<unit id="com.google.guava" version="15.0.0.v201403281430"/>
+<unit id="org.objectweb.asm.util" version="5.0.1.v201404251740"/>
+<unit id="org.objectweb.asm.xml" version="5.0.1.v201404251740"/>
+<unit id="com.google.guava.source" version="15.0.0.v201403281430"/>
+<unit id="org.objectweb.asm" version="5.0.1.v201404251740"/>
+<unit id="org.objectweb.asm.commons" version="5.0.1.v201404251740"/>
+<unit id="org.objectweb.asm.analysis.source" version="5.0.1.v201505121915"/>
+<unit id="org.objectweb.asm.commons.source" version="5.0.1.v201404251740"/>
+<unit id="org.objectweb.asm.tree.source" version="5.0.1.v201404251740"/>
+<unit id="org.objectweb.asm.analysis" version="5.0.1.v201505121915"/>
+<unit id="org.objectweb.asm.tree" version="5.0.1.v201404251740"/>
+<repository location="http://dev.simupedia.com/download/tools/orbit/downloads/drops/R20160221192158/repository/"/>
+</location>
+</locations>
+</target>
index 4975bea1712c96bd11435b18051f87f7d6a294f4..b40350e28786e85a423c3058490782eb49f3744f 100644 (file)
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>\r
-<?pde version="3.8"?><target name="Eclipse Mars.2" sequenceNumber="128">\r
-<locations>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.objectweb.asm.xml.source" version="5.0.1.v201404251740"/>\r
-<unit id="org.objectweb.asm.util.source" version="5.0.1.v201404251740"/>\r
-<unit id="org.objectweb.asm.source" version="5.0.1.v201404251740"/>\r
-<unit id="com.google.guava" version="15.0.0.v201403281430"/>\r
-<unit id="org.objectweb.asm.util" version="5.0.1.v201404251740"/>\r
-<unit id="org.objectweb.asm.xml" version="5.0.1.v201404251740"/>\r
-<unit id="com.google.guava.source" version="15.0.0.v201403281430"/>\r
-<unit id="org.objectweb.asm" version="5.0.1.v201404251740"/>\r
-<unit id="org.objectweb.asm.commons" version="5.0.1.v201404251740"/>\r
-<unit id="org.objectweb.asm.analysis.source" version="5.0.1.v201505121915"/>\r
-<unit id="org.objectweb.asm.commons.source" version="5.0.1.v201404251740"/>\r
-<unit id="org.objectweb.asm.tree.source" version="5.0.1.v201404251740"/>\r
-<unit id="org.objectweb.asm.analysis" version="5.0.1.v201505121915"/>\r
-<unit id="org.objectweb.asm.tree" version="5.0.1.v201404251740"/>\r
-<repository location="http://www.simantics.org/update/tools/orbit/downloads/drops/R20160221192158/repository/"/>\r
-</location>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.eclipse.mylyn.wikitext_feature.feature.group" version="2.7.0.v20151015-1452"/>\r
-<unit id="org.eclipse.emf.sdk.feature.group" version="2.11.2.v20160208-0841"/>\r
-<unit id="org.eclipse.epp.mpc.feature.group" version="1.4.2.v20160210-2005"/>\r
-<repository location="http://www.simantics.org/update/mars"/>\r
-</location>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.eclipse.ecf.core.ssl.feature.feature.group" version="1.1.0.v20151130-0157"/>\r
-<unit id="org.eclipse.rcp.source.feature.group" version="4.5.2.v20160212-1500"/>\r
-<unit id="org.eclipse.e4.core.tools.feature.feature.group" version="4.5.1.v20160129-0959"/>\r
-<unit id="org.eclipse.ecf.filetransfer.source.feature.feature.group" version="3.12.0.v20151130-0157"/>\r
-<unit id="org.eclipse.ecf.filetransfer.ssl.feature.feature.group" version="1.1.0.v20151130-0157"/>\r
-<unit id="org.eclipse.help.feature.group" version="2.1.2.v20160212-1500"/>\r
-<unit id="org.eclipse.ecf.filetransfer.httpclient4.source.feature.feature.group" version="3.12.0.v20151130-0157"/>\r
-<unit id="org.eclipse.e4.core.tools.feature.source.feature.group" version="4.5.1.v20160129-0959"/>\r
-<unit id="org.eclipse.swt.tools.feature.feature.group" version="3.104.2.v20160128-0900"/>\r
-<unit id="org.eclipse.ecf.filetransfer.httpclient4.feature.feature.group" version="3.12.0.v20151130-0157"/>\r
-<unit id="org.eclipse.ecf.filetransfer.ssl.source.feature.feature.group" version="1.1.0.v20151130-0157"/>\r
-<unit id="org.eclipse.platform.feature.group" version="4.5.2.v20160212-1500"/>\r
-<unit id="org.eclipse.ecf.core.ssl.source.feature.feature.group" version="1.1.0.v20151130-0157"/>\r
-<unit id="org.eclipse.rcp.feature.group" version="4.5.2.v20160212-1500"/>\r
-<unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="1.0.300.v20150430-1836"/>\r
-<unit id="org.eclipse.ecf.core.feature.feature.group" version="1.2.0.v20151130-0157"/>\r
-<unit id="org.eclipse.ecf.core.source.feature.feature.group" version="1.2.0.v20151130-0157"/>\r
-<unit id="org.eclipse.equinox.sdk.feature.group" version="3.11.2.v20160202-2102"/>\r
-<unit id="org.eclipse.platform.source.feature.group" version="4.5.2.v20160212-1500"/>\r
-<unit id="org.eclipse.releng.tools.feature.group" version="3.6.0.v20150527-0145"/>\r
-<unit id="org.eclipse.ecf.filetransfer.feature.feature.group" version="3.12.0.v20151130-0157"/>\r
-<unit id="org.eclipse.sdk.ide" version="4.5.2.M20160212-1500"/>\r
-<unit id="org.eclipse.ecf.filetransfer.httpclient4.ssl.feature.feature.group" version="1.1.0.v20151130-0157"/>\r
-<unit id="org.eclipse.help.source.feature.group" version="2.1.2.v20160212-1500"/>\r
-<unit id="org.eclipse.ecf.filetransfer.httpclient4.ssl.source.feature.feature.group" version="1.1.0.v20151130-0157"/>\r
-<repository location="http://www.simantics.org/update/eclipse/updates/4.5"/>\r
-</location>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.eclipse.nebula.effects.stw.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.visualization.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.calendarcombo.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.gallery.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.cwt.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.oscilloscope.feature.feature.group" version="1.2.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.pshelf.css.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.ganttchart.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.xviewer.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.compositetable.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.grid.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.cdatetime.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.pshelf.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.richtext.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.tablecombo.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.paperclips.feature.feature.group" version="2.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.examples.release.feature.feature.group" version="1.0.4.201605182147"/>\r
-<unit id="org.eclipse.nebula.widgets.pgroup.feature.feature.group" version="1.0.0.201605182147"/>\r
-<repository location="http://www.simantics.org/update/nebula/Q22016/release/"/>\r
-</location>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.eclipse.e4.tools.spies.feature.feature.group" version="0.17.0.v20160919-2121"/>\r
-<repository location="http://www.simantics.org/update/e4/snapshots/org.eclipse.e4.tools/latest/"/>\r
-</location>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.eclipse.nebula.incubation.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.examples.incubation.feature.feature.group" version="1.0.0.201605182147"/>\r
-<repository location="http://www.simantics.org/update/nebula/Q22016/incubation"/>\r
-</location>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.eclipse.nebula.widgets.nattable.core.feature.feature.group" version="1.4.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.e4.source.feature.feature.group" version="1.0.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.poi.feature.feature.group" version="1.4.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.feature.feature.group" version="1.4.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.core.source.feature.feature.group" version="1.4.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.source.feature.feature.group" version="1.4.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.feature.feature.group" version="1.0.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.e4.feature.feature.group" version="1.0.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.source.feature.feature.group" version="1.0.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.poi.source.feature.feature.group" version="1.4.0.201606011907"/>\r
-<repository location="http://www.simantics.org/update/nebula/nattable/releases/1.4.0/repository/"/>\r
-</location>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.apache.commons.lang.source" version="2.6.0"/>\r
-<unit id="org.antlr.runtime.source" version="3.5.2"/>\r
-<unit id="org.apache.commons.compress" version="1.12.0"/>\r
-<unit id="org.apache.pdfbox.source" version="2.0.2"/>\r
-<unit id="org.bouncycastle.bcmail-jdk14.source" version="1.38.0"/>\r
-<unit id="org.ini4j" version="0.5.4"/>\r
-<unit id="org.jdom2.source" version="2.0.6"/>\r
-<unit id="org.apache.commons.logging" version="1.2.0"/>\r
-<unit id="org.apache.pdfbox.xmpbox.source" version="2.0.2"/>\r
-<unit id="net.ucanaccess" version="3.0.6"/>\r
-<unit id="gnu.trove2" version="2.1.0"/>\r
-<unit id="net.ucanaccess.source" version="3.0.6"/>\r
-<unit id="org.eclipse.collections.eclipse-collections.source" version="7.1.0"/>\r
-<unit id="freemarker" version="2.3.23.stable"/>\r
-<unit id="com.github.virtuald.curvesapi.source" version="1.3.0"/>\r
-<unit id="org.apache.commons.collections.source" version="3.2.2"/>\r
-<unit id="org.apache.pdfbox.fontbox" version="2.0.2"/>\r
-<unit id="org.apache.commons.compress.source" version="1.12.0"/>\r
-<unit id="org.apache.lucene4.queryparser.source" version="4.9.0.b0003"/>\r
-<unit id="org.mozilla.rhino.source" version="1.7.7.1"/>\r
-<unit id="freemarker.source" version="2.3.23.stable"/>\r
-<unit id="jakarta-regexp" version="1.4.0"/>\r
-<unit id="net.jcip.annotations.source" version="1.0.0"/>\r
-<unit id="org.apache.log4j.source" version="1.2.17"/>\r
-<unit id="org.apache.commons.logging.source" version="1.2.0"/>\r
-<unit id="org.apache.commons.io.source" version="1.4.0"/>\r
-<unit id="com.healthmarketscience.jackcess" version="2.1.3"/>\r
-<unit id="org.bouncycastle.bctsp-jdk14.source" version="1.38.0"/>\r
-<unit id="org.eclipse.collections.eclipse-collections-api" version="7.1.0"/>\r
-<unit id="gnu.trove3.source" version="3.0.3"/>\r
-<unit id="it.unimi.dsi.fastutil.source" version="7.0.12"/>\r
-<unit id="org.hsqldb.hsqldb.source" version="2.3.1"/>\r
-<unit id="org.apache.poi.source" version="3.14.0"/>\r
-<unit id="org.apache.lucene4.sandbox.source" version="4.9.0.b0003"/>\r
-<unit id="org.apache.xmlbeans" version="2.6.0"/>\r
-<unit id="org.supercsv" version="2.4.0"/>\r
-<unit id="org.mozilla.rhino" version="1.7.7.1"/>\r
-<unit id="org.apache.pdfbox.xmpbox" version="2.0.2"/>\r
-<unit id="org.apache.commons.codec" version="1.10.0"/>\r
-<unit id="com.healthmarketscience.jackcess.source" version="2.1.3"/>\r
-<unit id="org.eclipse.collections.eclipse-collections-api.source" version="7.1.0"/>\r
-<unit id="org.bouncycastle.bcprov-jdk14.source" version="1.38.0"/>\r
-<unit id="stax.api" version="1.0.1"/>\r
-<unit id="org.apache.pdfbox.fontbox.source" version="2.0.2"/>\r
-<unit id="it.unimi.dsi.fastutil" version="7.0.12"/>\r
-<unit id="com.lowagie.text.source" version="2.1.7.b1"/>\r
-<unit id="net.jcip.annotations" version="1.0.0"/>\r
-<unit id="org.apache.lucene4.queryparser" version="4.9.0.b0003"/>\r
-<unit id="org.bouncycastle.bctsp-jdk14" version="1.38.0"/>\r
-<unit id="org.jfree.jchart.source" version="1.0.19"/>\r
-<unit id="com.lowagie.text" version="2.1.7.b1"/>\r
-<unit id="org.apache.poi.ooxml-schemas" version="3.14.0"/>\r
-<unit id="org.bouncycastle.bcprov-jdk14" version="1.38.0"/>\r
-<unit id="com.sun.jna" version="4.2.2"/>\r
-<unit id="org.apache.poi" version="3.14.0"/>\r
-<unit id="org.jdom2" version="2.0.6"/>\r
-<unit id="org.apache.commons.lang" version="2.6.0"/>\r
-<unit id="org.jfree.jchart" version="1.0.19"/>\r
-<unit id="org.apache.lucene4.sandbox" version="4.9.0.b0003"/>\r
-<unit id="org.apache.commons.codec.source" version="1.10.0"/>\r
-<unit id="org.supercsv.source" version="2.4.0"/>\r
-<unit id="com.github.virtuald.curvesapi" version="1.3.0"/>\r
-<unit id="org.eclipse.collections.eclipse-collections" version="7.1.0"/>\r
-<unit id="org.apache.log4j" version="1.2.17"/>\r
-<unit id="org.apache.lucene4.queries.source" version="4.9.0.b0003"/>\r
-<unit id="com.fasterxml.jackson.core.jackson-core.source" version="2.8.2"/>\r
-<unit id="org.apache.lucene4.core.source" version="4.9.0.b0003"/>\r
-<unit id="com.sun.jna.source" version="4.2.2"/>\r
-<unit id="org.apache.poi.ooxml" version="3.14.0"/>\r
-<unit id="com.sun.jna.platform" version="4.2.2"/>\r
-<unit id="org.apache.lucene4.analyzers-common.source" version="4.9.0.b0003"/>\r
-<unit id="org.apache.pdfbox" version="2.0.2"/>\r
-<unit id="org.bouncycastle.bcmail-jdk14" version="1.38.0"/>\r
-<unit id="org.jfree.jcommon" version="1.0.23"/>\r
-<unit id="org.apache.lucene4.analyzers-common" version="4.9.0.b0003"/>\r
-<unit id="org.apache.commons.collections" version="3.2.2"/>\r
-<unit id="org.apache.poi.ooxml.source" version="3.14.0"/>\r
-<unit id="com.fasterxml.jackson.core.jackson-core" version="2.8.2"/>\r
-<unit id="org.apache.lucene4.core" version="4.9.0.b0003"/>\r
-<unit id="gnu.trove2.source" version="2.1.0"/>\r
-<unit id="gnu.trove3" version="3.0.3"/>\r
-<unit id="org.antlr.runtime" version="3.5.2"/>\r
-<unit id="org.jfree.jcommon.source" version="1.0.23"/>\r
-<unit id="org.hsqldb.hsqldb" version="2.3.1"/>\r
-<unit id="org.apache.commons.io" version="1.4.0"/>\r
-<unit id="bouncycastle.bcmail-jdk14" version="138.0.0"/>\r
-<unit id="org.apache.lucene4.queries" version="4.9.0.b0003"/>\r
-<unit id="com.sun.jna.platform.source" version="4.2.2"/>\r
-<unit id="javax.vecmath" version="1.5.2"/>\r
-<unit id="bouncycastle.bcprov-jdk14" version="138.0.0"/>\r
-<unit id="org.ini4j.source" version="0.5.4"/>\r
-<repository location="http://www.simantics.org/download/master/external-components"/>\r
-</location>\r
-</locations>\r
-</target>\r
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<?pde version="3.8"?><target name="Eclipse Mars.2" sequenceNumber="128">
+<locations>
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.objectweb.asm.xml.source" version="5.0.1.v201404251740"/>
+<unit id="org.objectweb.asm.util.source" version="5.0.1.v201404251740"/>
+<unit id="org.objectweb.asm.source" version="5.0.1.v201404251740"/>
+<unit id="com.google.guava" version="15.0.0.v201403281430"/>
+<unit id="org.objectweb.asm.util" version="5.0.1.v201404251740"/>
+<unit id="org.objectweb.asm.xml" version="5.0.1.v201404251740"/>
+<unit id="com.google.guava.source" version="15.0.0.v201403281430"/>
+<unit id="org.objectweb.asm" version="5.0.1.v201404251740"/>
+<unit id="org.objectweb.asm.commons" version="5.0.1.v201404251740"/>
+<unit id="org.objectweb.asm.analysis.source" version="5.0.1.v201505121915"/>
+<unit id="org.objectweb.asm.commons.source" version="5.0.1.v201404251740"/>
+<unit id="org.objectweb.asm.tree.source" version="5.0.1.v201404251740"/>
+<unit id="org.objectweb.asm.analysis" version="5.0.1.v201505121915"/>
+<unit id="org.objectweb.asm.tree" version="5.0.1.v201404251740"/>
+<repository location="http://www.simantics.org/update/tools/orbit/downloads/drops/R20160221192158/repository/"/>
+</location>
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.eclipse.mylyn.wikitext_feature.feature.group" version="2.7.0.v20151015-1452"/>
+<unit id="org.eclipse.emf.sdk.feature.group" version="2.11.2.v20160208-0841"/>
+<unit id="org.eclipse.epp.mpc.feature.group" version="1.4.2.v20160210-2005"/>
+<repository location="http://www.simantics.org/update/mars"/>
+</location>
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.eclipse.ecf.core.ssl.feature.feature.group" version="1.1.0.v20151130-0157"/>
+<unit id="org.eclipse.rcp.source.feature.group" version="4.5.2.v20160212-1500"/>
+<unit id="org.eclipse.e4.core.tools.feature.feature.group" version="4.5.1.v20160129-0959"/>
+<unit id="org.eclipse.ecf.filetransfer.source.feature.feature.group" version="3.12.0.v20151130-0157"/>
+<unit id="org.eclipse.ecf.filetransfer.ssl.feature.feature.group" version="1.1.0.v20151130-0157"/>
+<unit id="org.eclipse.help.feature.group" version="2.1.2.v20160212-1500"/>
+<unit id="org.eclipse.ecf.filetransfer.httpclient4.source.feature.feature.group" version="3.12.0.v20151130-0157"/>
+<unit id="org.eclipse.e4.core.tools.feature.source.feature.group" version="4.5.1.v20160129-0959"/>
+<unit id="org.eclipse.swt.tools.feature.feature.group" version="3.104.2.v20160128-0900"/>
+<unit id="org.eclipse.ecf.filetransfer.httpclient4.feature.feature.group" version="3.12.0.v20151130-0157"/>
+<unit id="org.eclipse.ecf.filetransfer.ssl.source.feature.feature.group" version="1.1.0.v20151130-0157"/>
+<unit id="org.eclipse.platform.feature.group" version="4.5.2.v20160212-1500"/>
+<unit id="org.eclipse.ecf.core.ssl.source.feature.feature.group" version="1.1.0.v20151130-0157"/>
+<unit id="org.eclipse.rcp.feature.group" version="4.5.2.v20160212-1500"/>
+<unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="1.0.300.v20150430-1836"/>
+<unit id="org.eclipse.ecf.core.feature.feature.group" version="1.2.0.v20151130-0157"/>
+<unit id="org.eclipse.ecf.core.source.feature.feature.group" version="1.2.0.v20151130-0157"/>
+<unit id="org.eclipse.equinox.sdk.feature.group" version="3.11.2.v20160202-2102"/>
+<unit id="org.eclipse.platform.source.feature.group" version="4.5.2.v20160212-1500"/>
+<unit id="org.eclipse.releng.tools.feature.group" version="3.6.0.v20150527-0145"/>
+<unit id="org.eclipse.ecf.filetransfer.feature.feature.group" version="3.12.0.v20151130-0157"/>
+<unit id="org.eclipse.sdk.ide" version="4.5.2.M20160212-1500"/>
+<unit id="org.eclipse.ecf.filetransfer.httpclient4.ssl.feature.feature.group" version="1.1.0.v20151130-0157"/>
+<unit id="org.eclipse.help.source.feature.group" version="2.1.2.v20160212-1500"/>
+<unit id="org.eclipse.ecf.filetransfer.httpclient4.ssl.source.feature.feature.group" version="1.1.0.v20151130-0157"/>
+<repository location="http://www.simantics.org/update/eclipse/updates/4.5"/>
+</location>
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.eclipse.nebula.effects.stw.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.visualization.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.calendarcombo.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.gallery.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.cwt.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.oscilloscope.feature.feature.group" version="1.2.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.pshelf.css.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.ganttchart.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.xviewer.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.compositetable.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.grid.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.cdatetime.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.pshelf.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.richtext.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.tablecombo.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.paperclips.feature.feature.group" version="2.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.examples.release.feature.feature.group" version="1.0.4.201605182147"/>
+<unit id="org.eclipse.nebula.widgets.pgroup.feature.feature.group" version="1.0.0.201605182147"/>
+<repository location="http://www.simantics.org/update/nebula/Q22016/release/"/>
+</location>
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.eclipse.e4.tools.spies.feature.feature.group" version="0.17.0.v20160919-2121"/>
+<repository location="http://www.simantics.org/update/e4/snapshots/org.eclipse.e4.tools/latest/"/>
+</location>
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.eclipse.nebula.incubation.feature.feature.group" version="1.0.0.201605182147"/>
+<unit id="org.eclipse.nebula.examples.incubation.feature.feature.group" version="1.0.0.201605182147"/>
+<repository location="http://www.simantics.org/update/nebula/Q22016/incubation"/>
+</location>
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.eclipse.nebula.widgets.nattable.core.feature.feature.group" version="1.4.0.201606011907"/>
+<unit id="org.eclipse.nebula.widgets.nattable.extension.e4.source.feature.feature.group" version="1.0.0.201606011907"/>
+<unit id="org.eclipse.nebula.widgets.nattable.extension.poi.feature.feature.group" version="1.4.0.201606011907"/>
+<unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.feature.feature.group" version="1.4.0.201606011907"/>
+<unit id="org.eclipse.nebula.widgets.nattable.core.source.feature.feature.group" version="1.4.0.201606011907"/>
+<unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.source.feature.feature.group" version="1.4.0.201606011907"/>
+<unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.feature.feature.group" version="1.0.0.201606011907"/>
+<unit id="org.eclipse.nebula.widgets.nattable.extension.e4.feature.feature.group" version="1.0.0.201606011907"/>
+<unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.source.feature.feature.group" version="1.0.0.201606011907"/>
+<unit id="org.eclipse.nebula.widgets.nattable.extension.poi.source.feature.feature.group" version="1.4.0.201606011907"/>
+<repository location="http://www.simantics.org/update/nebula/nattable/releases/1.4.0/repository/"/>
+</location>
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.apache.commons.lang.source" version="2.6.0"/>
+<unit id="org.antlr.runtime.source" version="3.5.2"/>
+<unit id="org.apache.commons.compress" version="1.12.0"/>
+<unit id="org.apache.pdfbox.source" version="2.0.2"/>
+<unit id="org.bouncycastle.bcmail-jdk14.source" version="1.38.0"/>
+<unit id="org.ini4j" version="0.5.4"/>
+<unit id="org.jdom2.source" version="2.0.6"/>
+<unit id="org.apache.commons.logging" version="1.2.0"/>
+<unit id="org.apache.pdfbox.xmpbox.source" version="2.0.2"/>
+<unit id="net.ucanaccess" version="3.0.6"/>
+<unit id="gnu.trove2" version="2.1.0"/>
+<unit id="net.ucanaccess.source" version="3.0.6"/>
+<unit id="org.eclipse.collections.eclipse-collections.source" version="7.1.0"/>
+<unit id="freemarker" version="2.3.23.stable"/>
+<unit id="com.github.virtuald.curvesapi.source" version="1.3.0"/>
+<unit id="org.apache.commons.collections.source" version="3.2.2"/>
+<unit id="org.apache.pdfbox.fontbox" version="2.0.2"/>
+<unit id="org.apache.commons.compress.source" version="1.12.0"/>
+<unit id="org.apache.lucene4.queryparser.source" version="4.9.0.b0003"/>
+<unit id="org.mozilla.rhino.source" version="1.7.7.1"/>
+<unit id="freemarker.source" version="2.3.23.stable"/>
+<unit id="jakarta-regexp" version="1.4.0"/>
+<unit id="net.jcip.annotations.source" version="1.0.0"/>
+<unit id="org.apache.log4j.source" version="1.2.17"/>
+<unit id="org.apache.commons.logging.source" version="1.2.0"/>
+<unit id="org.apache.commons.io.source" version="1.4.0"/>
+<unit id="com.healthmarketscience.jackcess" version="2.1.3"/>
+<unit id="org.bouncycastle.bctsp-jdk14.source" version="1.38.0"/>
+<unit id="org.eclipse.collections.eclipse-collections-api" version="7.1.0"/>
+<unit id="gnu.trove3.source" version="3.0.3"/>
+<unit id="it.unimi.dsi.fastutil.source" version="7.0.12"/>
+<unit id="org.hsqldb.hsqldb.source" version="2.3.1"/>
+<unit id="org.apache.poi.source" version="3.14.0"/>
+<unit id="org.apache.lucene4.sandbox.source" version="4.9.0.b0003"/>
+<unit id="org.apache.xmlbeans" version="2.6.0"/>
+<unit id="org.supercsv" version="2.4.0"/>
+<unit id="org.mozilla.rhino" version="1.7.7.1"/>
+<unit id="org.apache.pdfbox.xmpbox" version="2.0.2"/>
+<unit id="org.apache.commons.codec" version="1.10.0"/>
+<unit id="com.healthmarketscience.jackcess.source" version="2.1.3"/>
+<unit id="org.eclipse.collections.eclipse-collections-api.source" version="7.1.0"/>
+<unit id="org.bouncycastle.bcprov-jdk14.source" version="1.38.0"/>
+<unit id="stax.api" version="1.0.1"/>
+<unit id="org.apache.pdfbox.fontbox.source" version="2.0.2"/>
+<unit id="it.unimi.dsi.fastutil" version="7.0.12"/>
+<unit id="com.lowagie.text.source" version="2.1.7.b1"/>
+<unit id="net.jcip.annotations" version="1.0.0"/>
+<unit id="org.apache.lucene4.queryparser" version="4.9.0.b0003"/>
+<unit id="org.bouncycastle.bctsp-jdk14" version="1.38.0"/>
+<unit id="org.jfree.jchart.source" version="1.0.19"/>
+<unit id="com.lowagie.text" version="2.1.7.b1"/>
+<unit id="org.apache.poi.ooxml-schemas" version="3.14.0"/>
+<unit id="org.bouncycastle.bcprov-jdk14" version="1.38.0"/>
+<unit id="com.sun.jna" version="4.2.2"/>
+<unit id="org.apache.poi" version="3.14.0"/>
+<unit id="org.jdom2" version="2.0.6"/>
+<unit id="org.apache.commons.lang" version="2.6.0"/>
+<unit id="org.jfree.jchart" version="1.0.19"/>
+<unit id="org.apache.lucene4.sandbox" version="4.9.0.b0003"/>
+<unit id="org.apache.commons.codec.source" version="1.10.0"/>
+<unit id="org.supercsv.source" version="2.4.0"/>
+<unit id="com.github.virtuald.curvesapi" version="1.3.0"/>
+<unit id="org.eclipse.collections.eclipse-collections" version="7.1.0"/>
+<unit id="org.apache.log4j" version="1.2.17"/>
+<unit id="org.apache.lucene4.queries.source" version="4.9.0.b0003"/>
+<unit id="com.fasterxml.jackson.core.jackson-core.source" version="2.8.2"/>
+<unit id="org.apache.lucene4.core.source" version="4.9.0.b0003"/>
+<unit id="com.sun.jna.source" version="4.2.2"/>
+<unit id="org.apache.poi.ooxml" version="3.14.0"/>
+<unit id="com.sun.jna.platform" version="4.2.2"/>
+<unit id="org.apache.lucene4.analyzers-common.source" version="4.9.0.b0003"/>
+<unit id="org.apache.pdfbox" version="2.0.2"/>
+<unit id="org.bouncycastle.bcmail-jdk14" version="1.38.0"/>
+<unit id="org.jfree.jcommon" version="1.0.23"/>
+<unit id="org.apache.lucene4.analyzers-common" version="4.9.0.b0003"/>
+<unit id="org.apache.commons.collections" version="3.2.2"/>
+<unit id="org.apache.poi.ooxml.source" version="3.14.0"/>
+<unit id="com.fasterxml.jackson.core.jackson-core" version="2.8.2"/>
+<unit id="org.apache.lucene4.core" version="4.9.0.b0003"/>
+<unit id="gnu.trove2.source" version="2.1.0"/>
+<unit id="gnu.trove3" version="3.0.3"/>
+<unit id="org.antlr.runtime" version="3.5.2"/>
+<unit id="org.jfree.jcommon.source" version="1.0.23"/>
+<unit id="org.hsqldb.hsqldb" version="2.3.1"/>
+<unit id="org.apache.commons.io" version="1.4.0"/>
+<unit id="bouncycastle.bcmail-jdk14" version="138.0.0"/>
+<unit id="org.apache.lucene4.queries" version="4.9.0.b0003"/>
+<unit id="com.sun.jna.platform.source" version="4.2.2"/>
+<unit id="javax.vecmath" version="1.5.2"/>
+<unit id="bouncycastle.bcprov-jdk14" version="138.0.0"/>
+<unit id="org.ini4j.source" version="0.5.4"/>
+<unit id="org.slf4j.api" version="1.7.20"/>
+<unit id="org.slf4j.api.source" version="1.7.20"/>
+<unit id="ch.qos.logback.classic" version="1.1.7"/>
+<unit id="ch.qos.logback.classic.source" version="1.1.7"/>
+<unit id="ch.qos.logback.core" version="1.1.7"/>
+<unit id="ch.qos.logback.core.source" version="1.1.7"/>
+<repository location="http://www.simantics.org/download/master/external-components"/>
+</location>
+</locations>
+</target>