Try to fix grpc work with OSGI via ARIES serviceloader 93/2093/1
authorjsimomaa <jani.simomaa@gmail.com>
Tue, 4 Sep 2018 07:20:52 +0000 (10:20 +0300)
committerjsimomaa <jani.simomaa@gmail.com>
Tue, 4 Sep 2018 07:20:52 +0000 (10:20 +0300)
gitlab #98

Change-Id: Id534a1da66c9593d4b514166ec916de069c717de

releng/org.simantics.sdk.build.p2.site/pom.xml

index 7f1d8d59d397b3faff4c93603705c6da65298c97..7f27b3e96ea16b39abb24936a9f116dab93b9217 100644 (file)
                                             io.grpc.util;version="${grpc.version}"
                                         </Export-Package>
                                         <Import-Package>!com.google.errorprone.annotations,*</Import-Package>
+                                        <Require-Capability>osgi.extender; filter:="(osgi.extender=osgi.serviceloader.processor)", osgi.serviceloader; filter:="(osgi.serviceloader=io.grpc.ServerProvider,io.grpc.ManagedChannelProvider)"; cardinality:=multiple</Require-Capability>
+                                        <Bundle-Version>${grpc.version.actual}</Bundle-Version>
                                     </instructions>
                                 </artifact>
                                 <artifact>
                                 <artifact>
                                     <id>io.grpc:grpc-netty:${grpc.version}</id>
                                     <source>true</source>
+                                    <override>true</override>
+                                    <instructions>
+                                        <Require-Capability>osgi.extender; filter:="(osgi.extender=osgi.serviceloader.registrar)"</Require-Capability>
+                                        <Provide-Capability>osgi.serviceloader; filter:="(osgi.serviceloader=io.grpc.ServerProvider,io.grpc.ManagedChannelProvider)"</Provide-Capability>
+                                        <Bundle-Version>${grpc.version.actual}</Bundle-Version>
+                                    </instructions>
                                 </artifact>
                                 <artifact>
                                     <id>com.google.protobuf:protobuf-java:${protobuf.version}</id>