jakarta.activation-api imports package `com.sun.activation` 55/4155/2
authorjsimomaa <jani.simomaa@gmail.com>
Thu, 16 Apr 2020 22:02:15 +0000 (01:02 +0300)
committerJani Simomaa <jani.simomaa@semantum.fi>
Thu, 16 Apr 2020 22:02:28 +0000 (22:02 +0000)
* This import shall be made optional as jakarta has taken over EE

gitlab #486

Change-Id: I4114e83cfab287196a4422feb124b5a8f6e85f91

releng/org.simantics.sdk.build.p2.site/pom.xml

index 3e03472d882951c34dff976bbf68e0fe27abfc6c..8528800c2b68cace11128967b4bc5c2e31ca4edf 100644 (file)
@@ -22,6 +22,8 @@
         <jackson.version.actual>2.10.2.b0001</jackson.version.actual>
         <javax.version>3.1.0</javax.version>
         <jakarta.version>2.1.6</jakarta.version>
+        <jakarta.activation-api.version>1.2.1</jakarta.activation-api.version>
+        <jakarta.activation-api.version.actual>1.2.1.b0001</jakarta.activation-api.version.actual>
         <!-- This can be removed once jakarta version is bumped -->
         <jakarta.version.actual>2.1.6.b0005</jakarta.version.actual>
         <jersey.version>2.30.1</jersey.version>
                                      <id>org.apache.aries.spifly:org.apache.aries.spifly.dynamic.bundle:${org.apache.aries.spifly.dynamic.bundle.version}</id>
                                      <source>true</source>
                                  </artifact>
+                                <artifact>
+                                    <id>jakarta.activation:jakarta.activation-api:${jakarta.activation-api.version}</id>
+                                    <source>true</source>
+                                    <override>true</override>
+                                    <instructions>
+                                        <Bundle-Version>${jakarta.activation-api.version.actual}</Bundle-Version>
+                                        <Import-Package>*;resolution:=optional</Import-Package>
+                                    </instructions>
+                                </artifact>
                                 <artifact>
                                     <id>jakarta.ws.rs:jakarta.ws.rs-api:${jakarta.version}</id>
                                     <source>true</source>