Update rest of external components & explicitly export javax.ws.rs* 39/3939/1
authorjsimomaa <jani.simomaa@gmail.com>
Fri, 28 Feb 2020 07:00:45 +0000 (09:00 +0200)
committerjsimomaa <jani.simomaa@gmail.com>
Fri, 28 Feb 2020 07:00:45 +0000 (09:00 +0200)
gitlab #486

Change-Id: I858750bb69a0ebade617c72f29ee76330394954e

releng/org.simantics.sdk.build.p2.site/pom.xml

index 0bd96df8f10ad0c90ec088e1c90f6da1b9e3dfa9..05777cd04f156d7715a27f7b76ae0f89beacdc63 100644 (file)
         <javax.version>3.1.0</javax.version>
         <jakarta.version>2.1.6</jakarta.version>
         <!-- This can be removed once jakarta version is bumped -->
-        <jakarta.version.actual>2.1.6.b0003</jakarta.version.actual>
+        <jakarta.version.actual>2.1.6.b0004</jakarta.version.actual>
         <jersey.version>2.30.1</jersey.version>
         <!-- This can be removed once jersey version is bumped -->
-        <jersey.version.actual>2.30.1.b0003</jersey.version.actual>
+        <jersey.version.actual>2.30.1.b0004</jersey.version.actual>
         <jfreechart.version>1.5.0</jfreechart.version>
         <slf4j.version>1.7.30</slf4j.version>
         <slf4j.version.actual>1.7.30</slf4j.version.actual>
                                     <id>org.mozilla:rhino:${rhino.version}</id>
                                     <source>true</source>
                                 </artifact>
-                                <!-- org.eclipse.epp.mpc.core.win32 plug-in requires 4.1.0 -->
-                                <artifact>
-                                    <id>net.java.dev.jna:jna:${jna41.version}</id>
-                                    <source>true</source>
-                                </artifact>
-                                 <!-- org.eclipse.epp.mpc.core.win32 plug-in requires 4.1.0 -->
-                                <artifact>
-                                    <id>net.java.dev.jna:jna-platform:${jna41.version}</id>
-                                    <source>true</source>
-                                </artifact>
-                                <artifact>
-                                    <id>net.java.dev.jna:jna:${jna.version}</id>
-                                    <source>true</source>
-                                </artifact>
-                                <artifact>
-                                    <id>net.java.dev.jna:jna-platform:${jna.version}</id>
-                                    <source>true</source>
-                                </artifact>
                                 <artifact>
                                     <id>javax.servlet:javax.servlet-api:${javax.version}</id>
                                     <source>true</source>
                                         </Require-Bundle>
                                         <Import-Package>!javax.*,*;resolution:=optional</Import-Package>
                                         <Export-Package>
-                                            javax.ws.rs,
-                                            javax.ws.rs.core,
-                                            javax.ws.rs.ext
+                                            javax.ws.rs;version="${jakarta.version}",
+                                            javax.ws.rs.core;version="${jakarta.version}",
+                                            javax.ws.rs.ext;version="${jakarta.version}",
+                                            javax.ws.rs.client;version="${jakarta.version}",
+                                            javax.ws.rs.container;version="${jakarta.version}",
+                                            javax.ws.rs.sse;version="${jakarta.version}"
                                         </Export-Package>
                                     </instructions>
                                 </artifact>