Bump org.apache.lucene4 bundle versions to 4.9.0.b0001. 33/33/1
authorTuukka Lehtonen <tuukka.lehtonen@semantum.fi>
Wed, 17 Aug 2016 10:48:36 +0000 (13:48 +0300)
committerTuukka Lehtonen <tuukka.lehtonen@semantum.fi>
Wed, 17 Aug 2016 10:48:36 +0000 (13:48 +0300)
Change-Id: If6440eb09d61abd09ac6c42c073c9c58dfa03926

releng/org.simantics.sdk.build.p2.site/pom.xml
releng/org.simantics.sdk.build.targetdefinition/org.simantics.sdk.build.targetdefinition.target

index 9b8594de03064aece379607b90ffdf767b6866ce..7859b67cad864ac632f3ae026dec1f9dbe0d7557 100644 (file)
@@ -9,7 +9,9 @@
     <version>1.25.0</version>\r
 \r
     <properties>\r
+        <itext.version.actual>2.1.7.b1</itext.version.actual>\r
         <lucene.version>4.9.0</lucene.version>\r
+        <lucene.version.actual>4.9.0.b0001</lucene.version.actual>\r
         <lucene.prefix>org.apache.lucene4</lucene.prefix>\r
     </properties>\r
 \r
                                     <source>true</source>\r
                                     <instructions>\r
                                         <Bundle-SymbolicName>${lucene.prefix}.core</Bundle-SymbolicName>\r
+                                        <Bundle-Version>${lucene.version.actual}</Bundle-Version>\r
                                     </instructions>\r
                                 </artifact>\r
                                 <artifact>\r
                                     <source>true</source>\r
                                     <instructions>\r
                                         <Bundle-SymbolicName>${lucene.prefix}.queries</Bundle-SymbolicName>\r
+                                        <Bundle-Version>${lucene.version.actual}</Bundle-Version>\r
                                         <Import-Package>org.apache.lucene.*;version="${lucene.version}";resolution:=optional,*;resolution:=optional</Import-Package>\r
                                     </instructions>\r
                                 </artifact>\r
                                     <source>true</source>\r
                                     <instructions>\r
                                         <Bundle-SymbolicName>${lucene.prefix}.sandbox</Bundle-SymbolicName>\r
+                                        <Bundle-Version>${lucene.version.actual}</Bundle-Version>\r
                                         <Import-Package>org.apache.lucene.*;version="${lucene.version}";resolution:=optional,*;resolution:=optional</Import-Package>\r
                                     </instructions>\r
                                 </artifact>\r
                                     <source>true</source>\r
                                     <instructions>\r
                                         <Bundle-SymbolicName>${lucene.prefix}.queryparser</Bundle-SymbolicName>\r
+                                        <Bundle-Version>${lucene.version.actual}</Bundle-Version>\r
                                         <Import-Package>org.apache.lucene.*;version="${lucene.version}";resolution:=optional,*;resolution:=optional</Import-Package>\r
                                     </instructions>\r
                                 </artifact>\r
                                     <source>true</source>\r
                                     <instructions>\r
                                         <Bundle-SymbolicName>${lucene.prefix}.analyzers-common</Bundle-SymbolicName>\r
+                                        <Bundle-Version>${lucene.version.actual}</Bundle-Version>\r
                                         <Import-Package>org.apache.lucene.*;version="${lucene.version}";resolution:=optional,*;resolution:=optional</Import-Package>\r
                                     </instructions>\r
                                 </artifact>\r
                                     <source>true</source>\r
                                     <instructions>\r
                                         <Bundle-SymbolicName>com.lowagie.text</Bundle-SymbolicName>\r
-                                        <Bundle-Version>2.1.7.b1</Bundle-Version>\r
+                                        <Bundle-Version>${itext.version.actual}</Bundle-Version>\r
                                     </instructions>\r
                                 </artifact>\r
                                 <artifact>\r
index 5c23887f7ff6f448594167f278bcd03397d2c611..d2a2d6b8a1de977067c2b8c098cbf05c8aacf464 100644 (file)
@@ -75,9 +75,9 @@
 <repository location="http://www.simantics.org/update/nebula/Q22016/release/"/>\r
 </location>\r
 <location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.apache.lucene4.queries" version="4.9.0"/>\r
+<unit id="org.apache.lucene4.queries" version="4.9.0.b0001"/>\r
 <unit id="org.apache.commons.lang.source" version="2.6.0"/>\r
-<unit id="org.apache.lucene4.sandbox.source" version="4.9.0"/>\r
+<unit id="org.apache.lucene4.sandbox.source" version="4.9.0.b0001"/>\r
 <unit id="org.antlr.runtime.source" version="3.5.2"/>\r
 <unit id="org.apache.commons.compress" version="1.12.0"/>\r
 <unit id="org.apache.pdfbox.source" version="2.0.2"/>\r
 <unit id="org.eclipse.collections.eclipse-collections.source" version="7.1.0"/>\r
 <unit id="freemarker" version="2.3.23.stable"/>\r
 <unit id="com.github.virtuald.curvesapi.source" version="1.3.0"/>\r
-<unit id="org.apache.lucene4.analyzers-common" version="4.9.0"/>\r
+<unit id="org.apache.lucene4.analyzers-common" version="4.9.0.b0001"/>\r
 <unit id="org.apache.commons.collections.source" version="3.2.2"/>\r
 <unit id="org.apache.pdfbox.fontbox" version="2.0.2"/>\r
 <unit id="org.apache.commons.compress.source" version="1.12.0"/>\r
 <unit id="org.mozilla.rhino.source" version="1.7.7.1"/>\r
-<unit id="org.apache.lucene4.queries.source" version="4.9.0"/>\r
+<unit id="org.apache.lucene4.queries.source" version="4.9.0.b0001"/>\r
 <unit id="freemarker.source" version="2.3.23.stable"/>\r
 <unit id="jakarta-regexp" version="1.4.0"/>\r
 <unit id="net.jcip.annotations.source" version="1.0.0"/>\r
 <unit id="org.apache.log4j.source" version="1.2.17"/>\r
-<unit id="org.apache.lucene4.sandbox" version="4.9.0"/>\r
+<unit id="org.apache.lucene4.sandbox" version="4.9.0.b0001"/>\r
 <unit id="org.apache.commons.logging.source" version="1.2.0"/>\r
 <unit id="org.apache.commons.io.source" version="1.4.0"/>\r
-<unit id="org.apache.lucene4.core" version="4.9.0"/>\r
+<unit id="org.apache.lucene4.core" version="4.9.0.b0001"/>\r
 <unit id="com.healthmarketscience.jackcess" version="2.1.3"/>\r
 <unit id="org.bouncycastle.bctsp-jdk14.source" version="1.38.0"/>\r
 <unit id="org.eclipse.collections.eclipse-collections-api" version="7.1.0"/>\r
 <unit id="org.bouncycastle.bcprov-jdk14.source" version="1.38.0"/>\r
 <unit id="stax.api" version="1.0.1"/>\r
 <unit id="org.apache.pdfbox.fontbox.source" version="2.0.2"/>\r
-<unit id="org.apache.lucene4.analyzers-common.source" version="4.9.0"/>\r
+<unit id="org.apache.lucene4.analyzers-common.source" version="4.9.0.b0001"/>\r
 <unit id="it.unimi.dsi.fastutil" version="7.0.12"/>\r
 <unit id="net.jcip.annotations" version="1.0.0"/>\r
 <unit id="org.bouncycastle.bctsp-jdk14" version="1.38.0"/>\r
 <unit id="org.jfree.jchart.source" version="1.0.19"/>\r
-<unit id="org.apache.lucene4.queryparser" version="4.9.0"/>\r
+<unit id="org.apache.lucene4.queryparser" version="4.9.0.b0001"/>\r
 <unit id="org.apache.poi.ooxml-schemas" version="3.14.0"/>\r
 <unit id="org.bouncycastle.bcprov-jdk14" version="1.38.0"/>\r
 <unit id="org.apache.poi" version="3.14.0"/>\r
 <unit id="javax.vecmath" version="1.5.2"/>\r
 <unit id="bouncycastle.bcprov-jdk14" version="138.0.0"/>\r
 <unit id="org.ini4j.source" version="0.5.4"/>\r
-<unit id="org.apache.lucene4.core.source" version="4.9.0"/>\r
-<unit id="org.apache.lucene4.queryparser.source" version="4.9.0"/>\r
+<unit id="org.apache.lucene4.core.source" version="4.9.0.b0001"/>\r
+<unit id="org.apache.lucene4.queryparser.source" version="4.9.0.b0001"/>\r
 <repository location="http://www.simantics.org/update/external-components/master"/>\r
 </location>\r
 <location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r