Updating external component versions & add influxdb-client 36/3936/3
authorjsimomaa <jani.simomaa@gmail.com>
Thu, 27 Feb 2020 11:41:56 +0000 (13:41 +0200)
committerTuukka Lehtonen <tuukka.lehtonen@semantum.fi>
Thu, 27 Feb 2020 12:38:41 +0000 (12:38 +0000)
gitlab #486

Change-Id: I4348db51b082aedaf26bd8c9458f1b81cef0f512

releng/org.simantics.sdk.build.p2.site/pom.xml

index d4e66227b1fff88e874e611068c731917cda769f..fcf6f6d7b6fa4d277931d58045ade88494348205 100644 (file)
     <properties>
         <itext.version.actual>2.1.7.b1</itext.version.actual>
         <antlr.version>3.5.2</antlr.version>
+        <commons-codec.version>1.10</commons-codec.version>
         <lucene.version>4.9.0</lucene.version>
         <lucene.version.actual>4.9.0.b0003</lucene.version.actual>
         <lucene.prefix>org.apache.lucene4</lucene.prefix>
         <jaxen.version>1.1.6</jaxen.version>
         <jdom.version>2.0.6</jdom.version>
         <jdom.version.actual>2.0.6.b0001</jdom.version.actual>
-        <jackson.version>2.8.8</jackson.version>
+        <jackson.version>2.10.2</jackson.version>
         <javax.version>3.1.0</javax.version>
-        <jersey.version>2.25.1</jersey.version>
-        <slf4j.version>1.7.25</slf4j.version>
-        <slf4j.version.actual>1.7.25.b001</slf4j.version.actual>
-        <grpc.version>1.21.0</grpc.version>
-        <grpc.version.actual>1.21.0</grpc.version.actual>
-        <protobuf.version>3.7.1</protobuf.version>
-        <zeroturnaround.version>1.10</zeroturnaround.version>
-        <eclipse.collections.version>9.2.0</eclipse.collections.version>
-        <caffeine.version>2.6.2</caffeine.version>
+        <jersey.version>2.30.1</jersey.version>
+        <jfreechart.version>1.0.19</jfreechart.version>
+        <slf4j.version>1.7.30</slf4j.version>
+        <slf4j.version.actual>1.7.30</slf4j.version.actual>
+        <grpc.version>1.27.2</grpc.version>
+        <grpc.version.actual>1.27.2</grpc.version.actual>
+        <protobuf.version>3.11.4</protobuf.version>
+        <zeroturnaround.version>1.11</zeroturnaround.version>
+        <eclipse.collections.version>10.2.0</eclipse.collections.version>
+        <caffeine.version>2.8.1</caffeine.version>
+        <influxdb.client.version>1.5.0</influxdb.client.version>
+        <supercsv.version>2.4.0</supercsv.version>
+        <ini4j.version>0.5.4</ini4j.version>
+        <commons-collections.version>4.1</commons-collections.version>
+        <commons-compress.version>1.18</commons-compress.version>
+        <commons-lang.version>2.6</commons-lang.version>
+        <commons-logging.version>1.2</commons-logging.version>
+        <commons-io.version>1.4</commons-io.version>
+        <commons-math.version>3.6.1</commons-math.version>
+        <pdfbox.version>2.0.19</pdfbox.version>
+        <fontbox.version>2.0.19</fontbox.version>
+        <xmpbox.version>2.0.19</xmpbox.version>
+        <log4j.version>1.2.17</log4j.version>
+        <ucanaccess.version>3.0.7</ucanaccess.version>
+        <fastutil.version>7.2.1</fastutil.version>
+        <trove4j.version>3.0.3</trove4j.version>
+        <freemarker.version>2.3.23</freemarker.version>
+        <itext.version>2.1.7</itext.version>
+        <rhino.version>1.7.7.1</rhino.version>
+        <jna41.version>4.1.0</jna41.version>
+        <jna.version>4.3.0</jna.version>
+        <logback-classic.version>1.2.3</logback-classic.version>
+        <koloboke-compile.version>0.5.1</koloboke-compile.version>
+        <koloboke-impl-common-jdk8.version>1.0.0</koloboke-impl-common-jdk8.version>
+        <kryo.version>4.0.0</kryo.version>
+        <org.apache.aries.spifly.dynamic.bundle.version>1.2.3</org.apache.aries.spifly.dynamic.bundle.version>
+        <decompiler-procyon.version>4.3.0.Final</decompiler-procyon.version>
+        <jsoup.version>1.11.3</jsoup.version>
+        <snakeyaml.version>1.23</snakeyaml.version>
+        <jetty945.version>9.4.24.v20191120</jetty945.version>
+        <netty.version>4.1.45.Final</netty.version>
+        <jcip-annotations.version>1.0</jcip-annotations.version>
+        <pgjdbc-ng.version>0.7.1</pgjdbc-ng.version>
     </properties>
 
     <repositories>
@@ -50,7 +85,7 @@
             <plugin>
                 <groupId>org.reficio</groupId>
                 <artifactId>p2-maven-plugin</artifactId>
-                <version>1.2.0</version>
+                <version>1.3.0</version>
                 <executions>
                     <execution>
                         <id>default-cli</id>
                                     </instructions>
                                 </artifact>
                                 <artifact>
-                                    <id>org.jfree:jfreechart:1.0.19</id>
+                                    <id>org.jfree:jfreechart:${jfreechart.version}</id>
                                     <source>true</source>
                                     <instructions>
                                         <Bundle-SymbolicName>org.jfree.jchart</Bundle-SymbolicName>
                                 </artifact>
                                 -->
                                 <artifact>
-                                    <id>net.sf.supercsv:super-csv:2.4.0</id>
+                                    <id>net.sf.supercsv:super-csv:${supercsv.version}</id>
                                     <source>true</source>
                                     <override>true</override>
                                     <instructions>
                                     </instructions>
                                 </artifact>
                                 <artifact>
-                                    <id>org.ini4j:ini4j:0.5.4</id>
+                                    <id>org.ini4j:ini4j:${ini4j.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
                                     <!-- Needed by Apache POI 3.15 -->
-                                    <id>commons-codec:commons-codec:1.10</id>
-                                    <source>true</source>
-                                </artifact>
-                                <artifact>
-                                    <id>commons-collections:commons-collections:3.2.2</id>
+                                    <id>commons-codec:commons-codec:${commons-codec.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
                                     <!-- Needed by Apache POI 3.15 -->
-                                    <id>org.apache.commons:commons-collections4:4.1</id>
+                                    <id>org.apache.commons:commons-collections4:${commons-collections.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
-                                    <id>org.apache.commons:commons-compress:1.18</id>
+                                    <id>org.apache.commons:commons-compress:${commons-compress.version}</id>
                                     <source>true</source>
                                     <override>true</override>
                                     <instructions>
                                     </instructions>
                                 </artifact>
                                 <artifact>
-                                    <id>commons-lang:commons-lang:2.6</id>
+                                    <id>commons-lang:commons-lang:${commons-lang.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
                                     <!-- Needed by Apache POI 3.15 -->
-                                    <id>commons-logging:commons-logging:1.2</id>
+                                    <id>commons-logging:commons-logging:${commons-logging.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
-                                    <id>commons-io:commons-io:1.4</id>
+                                    <id>commons-io:commons-io:${commons-io.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
-                                    <id>org.apache.commons:commons-math3:3.6.1</id>
+                                    <id>org.apache.commons:commons-math3:${commons-math.version}</id>
                                     <source>true</source>
                                 </artifact>
 
                                 <artifact>
-                                    <id>org.apache.pdfbox:pdfbox:2.0.3</id>
+                                    <id>org.apache.pdfbox:pdfbox:${pdfbox.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
-                                    <id>org.apache.pdfbox:fontbox:2.0.3</id>
+                                    <id>org.apache.pdfbox:fontbox:${fontbox.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
-                                    <id>org.apache.pdfbox:xmpbox:2.0.3</id>
+                                    <id>org.apache.pdfbox:xmpbox:${xmpbox.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <!-- Needed by Apache POI 3.15, however these are included in third-party repository manually -->
                                 </artifact>
                                 -->
                                 <artifact>
-                                    <id>log4j:log4j:1.2.17</id>
+                                    <id>log4j:log4j:${log4j.version}</id>
                                     <source>true</source>
                                     <override>true</override>
                                     <instructions>
                                     </instructions>
                                 </artifact>
                                 <artifact>
-                                    <id>net.sf.ucanaccess:ucanaccess:3.0.7</id>
+                                    <id>net.sf.ucanaccess:ucanaccess:${ucanaccess.version}</id>
                                     <source>true</source>
                                     <instructions>
                                         <Bundle-SymbolicName>net.ucanaccess</Bundle-SymbolicName>
                                     </instructions>
                                 </artifact>
                                 <artifact>
-                                    <id>it.unimi.dsi:fastutil:7.2.1</id>
+                                    <id>it.unimi.dsi:fastutil:${fastutil.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
                                     </instructions>
                                 </artifact>
                                 <artifact>
-                                    <id>net.sf.trove4j:trove4j:3.0.3</id>
+                                    <id>net.sf.trove4j:trove4j:${trove4j.version}</id>
                                     <source>true</source>
                                     <instructions>
                                         <Bundle-Name>GNU Trove 3</Bundle-Name>
                                     </instructions>
                                 </artifact>
                                 <artifact>
-                                    <id>org.freemarker:freemarker:2.3.23</id>
+                                    <id>org.freemarker:freemarker:${freemarker.version}</id>
                                     <source>true</source>
                                     <override>true</override>
                                     <instructions>
                                     </instructions>
                                 </artifact>
                                 <artifact>
-                                    <id>com.lowagie:itext:2.1.7</id>
+                                    <id>com.lowagie:itext:${itext.version}</id>
                                     <source>true</source>
                                     <instructions>
                                         <Bundle-SymbolicName>com.lowagie.text</Bundle-SymbolicName>
                                     </instructions>
                                 </artifact>
                                 <artifact>
-                                    <id>org.mozilla:rhino:1.7.7.1</id>
+                                    <id>org.mozilla:rhino:${rhino.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <!-- org.eclipse.epp.mpc.core.win32 plug-in requires 4.1.0 -->
                                 <artifact>
-                                    <id>net.java.dev.jna:jna:4.1.0</id>
+                                    <id>net.java.dev.jna:jna:${jna41.version}</id>
                                     <source>true</source>
                                 </artifact>
                                  <!-- org.eclipse.epp.mpc.core.win32 plug-in requires 4.1.0 -->
                                 <artifact>
-                                    <id>net.java.dev.jna:jna-platform:4.1.0</id>
+                                    <id>net.java.dev.jna:jna-platform:${jna41.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
-                                    <id>net.java.dev.jna:jna:4.3.0</id>
+                                    <id>net.java.dev.jna:jna:${jna.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
-                                    <id>net.java.dev.jna:jna-platform:4.3.0</id>
+                                    <id>net.java.dev.jna:jna-platform:${jna.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
                                     </instructions>
                                 </artifact>
                                 <artifact>
-                                    <id>ch.qos.logback:logback-classic:1.2.3</id>
+                                    <id>ch.qos.logback:logback-classic:${logback-classic.version}</id>
                                     <source>true</source>
                                     <override>true</override>
                                 </artifact>
                                 <artifact>
-                                    <id>com.koloboke:koloboke-compile:0.5.1</id>
+                                    <id>com.koloboke:koloboke-compile:${koloboke-compile.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
-                                    <id>com.koloboke:koloboke-impl-common-jdk8:1.0.0</id>
+                                    <id>com.koloboke:koloboke-impl-common-jdk8:${koloboke-impl-common-jdk8.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
-                                    <id>com.esotericsoftware:kryo:4.0.0</id>
+                                    <id>com.esotericsoftware:kryo:${kryo.version}</id>
                                     <source>true</source>
                                 </artifact>
                                  <artifact>
-                                     <id>org.apache.aries.spifly:org.apache.aries.spifly.dynamic.bundle:1.2.3</id>
+                                     <id>org.apache.aries.spifly:org.apache.aries.spifly.dynamic.bundle:${org.apache.aries.spifly.dynamic.bundle.version}</id>
                                      <source>true</source>
                                  </artifact>
                                 <artifact>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
-                                    <id>org.jboss.windup.decompiler:decompiler-procyon:4.0.0.Beta1</id>
+                                    <id>org.jboss.windup.decompiler:decompiler-procyon:${decompiler-procyon.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
-                                    <id>org.jsoup:jsoup:1.11.3</id>
+                                    <id>org.jsoup:jsoup:${jsoup.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
-                                    <id>org.yaml:snakeyaml:1.23</id>
+                                    <id>org.yaml:snakeyaml:${snakeyaml.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
-                                    <id>org.eclipse.jetty:jetty-servlets:9.4.5.v20170502</id>
-                                    <source>true</source>
-                                </artifact>
-                                <artifact>
-                                    <id>org.eclipse.jetty:jetty-server:9.4.5.v20170502</id>
+                                    <id>org.eclipse.jetty:jetty-servlets:${jetty945.version}</id>
                                     <source>true</source>
                                 </artifact>
                                 <artifact>
                                 </artifact>
                                 <!-- Since 1.21.0 grpc, a manually set up plugin is provided in third-party repository.
                                      Note: grpc-core, grpc-context, and grpc-stub (maybe others as well) must be bundled into same plug-in, since they contain split packages.
+                                     See:
+                                       * https://github.com/grpc/grpc-java/issues/2727
+                                       * https://github.com/grpc/grpc-java/issues/3522
                                 <artifact>
                                     <id>io.grpc:io.grpc:${grpc.version}</id>
                                     <source>true</source>
 
                                 <!-- Netty is needed by com.impossibl.pgjdbc-ng:pgjdbc-ng:0.7.1 -->
                                 <artifact>
-                                    <id>io.netty:netty-buffer:4.1.35.Final</id>
+                                    <id>io.netty:netty-buffer:${netty.version}</id>
                                     <source>true</source>
                                     <transitive>true</transitive>
                                 </artifact>
                                 <artifact>
-                                    <id>io.netty:netty-codec:4.1.35.Final</id>
+                                    <id>io.netty:netty-codec:${netty.version}</id>
                                     <source>true</source>
                                     <transitive>true</transitive>
                                 </artifact>
                                 <artifact>
-                                    <id>io.netty:netty-codec-http:4.1.35.Final</id>
+                                    <id>io.netty:netty-codec-http:${netty.version}</id>
                                     <source>true</source>
                                     <transitive>true</transitive>
                                 </artifact>
                                 <artifact>
-                                    <id>io.netty:netty-codec-http2:4.1.35.Final</id>
+                                    <id>io.netty:netty-codec-http2:${netty.version}</id>
                                     <source>true</source>
                                     <transitive>true</transitive>
                                 </artifact>
                                 <artifact>
-                                    <id>io.netty:netty-codec-socks:4.1.35.Final</id>
+                                    <id>io.netty:netty-codec-socks:${netty.version}</id>
                                     <source>true</source>
                                     <transitive>true</transitive>
                                 </artifact>
                                 <artifact>
-                                    <id>io.netty:netty-common:4.1.35.Final</id>
+                                    <id>io.netty:netty-common:${netty.version}</id>
                                     <source>true</source>
                                     <transitive>true</transitive>
                                 </artifact>
                                 <artifact>
-                                    <id>io.netty:netty-handler:4.1.35.Final</id>
+                                    <id>io.netty:netty-handler:${netty.version}</id>
                                     <source>true</source>
                                     <transitive>true</transitive>
                                 </artifact>
                                 <artifact>
-                                    <id>io.netty:netty-handler-proxy:4.1.35.Final</id>
+                                    <id>io.netty:netty-handler-proxy:${netty.version}</id>
                                     <source>true</source>
                                     <transitive>true</transitive>
                                 </artifact>
                                 <artifact>
-                                    <id>io.netty:netty-resolver:4.1.35.Final</id>
+                                    <id>io.netty:netty-resolver:${netty.version}</id>
                                     <source>true</source>
                                     <transitive>true</transitive>
                                 </artifact>
                                 <artifact>
-                                    <id>io.netty:netty-transport:4.1.35.Final</id>
+                                    <id>io.netty:netty-transport:${netty.version}</id>
                                     <source>true</source>
                                     <transitive>true</transitive>
                                 </artifact>
                                 <artifact>
-                                    <id>com.impossibl.pgjdbc-ng:pgjdbc-ng:0.7.1</id>
+                                    <id>com.impossibl.pgjdbc-ng:pgjdbc-ng:${pgjdbc-ng.version}</id>
                                     <source>true</source>
                                     <transitive>false</transitive>
                                 </artifact>
                                     </instructions>
                                 </artifact>
                                 <artifact>
-                                    <id>net.jcip:jcip-annotations:1.0</id>
+                                    <id>net.jcip:jcip-annotations:${jcip-annotations.version}</id>
+                                    <source>true</source>
+                                </artifact>
+                                <artifact>
+                                    <id>com.influxdb:influxdb-client-java:${influxdb.client.version}</id>
                                     <source>true</source>
                                 </artifact>
                             </artifacts>