Add missing external dependency plug-ins to SDK build platform.
authorTuukka Lehtonen <tuukka.lehtonen@semantum.fi>
Tue, 13 Sep 2016 10:14:40 +0000 (13:14 +0300)
committerTuukka Lehtonen <tuukka.lehtonen@semantum.fi>
Tue, 13 Sep 2016 10:14:40 +0000 (13:14 +0300)
refs #6475

releng/org.simantics.sdk.build.targetdefinition/org.simantics.sdk.build.targetdefinition.target

index 34bfa95c2f088ef40d5d6dcd23662ebc9e7c0006..7d5f0d45c036ed959a97428da071eaba51c28739 100644 (file)
@@ -1,5 +1,5 @@
 <?xml version="1.0" encoding="UTF-8" standalone="no"?>\r
-<?pde version="3.8"?><target name="Eclipse Mars.2" sequenceNumber="127">\r
+<?pde version="3.8"?><target name="Eclipse Mars.2" sequenceNumber="128">\r
 <locations>\r
 <location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
 <unit id="org.objectweb.asm.xml.source" version="5.0.1.v201404251740"/>\r
 <repository location="http://www.simantics.org/update/nebula/Q22016/release/"/>\r
 </location>\r
 <location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.apache.lucene4.queries" version="4.9.0.b0003"/>\r
+<unit id="org.eclipse.e4.tools.spies.feature.feature.group" version="0.17.0.v20160811-1516"/>\r
+<repository location="http://www.simantics.org/update/e4/snapshots/org.eclipse.e4.tools/latest/"/>\r
+</location>\r
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
+<unit id="org.eclipse.nebula.incubation.feature.feature.group" version="1.0.0.201605182147"/>\r
+<unit id="org.eclipse.nebula.examples.incubation.feature.feature.group" version="1.0.0.201605182147"/>\r
+<repository location="http://www.simantics.org/update/nebula/Q22016/incubation"/>\r
+</location>\r
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
+<unit id="org.eclipse.nebula.widgets.nattable.core.feature.feature.group" version="1.4.0.201606011907"/>\r
+<unit id="org.eclipse.nebula.widgets.nattable.extension.e4.source.feature.feature.group" version="1.0.0.201606011907"/>\r
+<unit id="org.eclipse.nebula.widgets.nattable.extension.poi.feature.feature.group" version="1.4.0.201606011907"/>\r
+<unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.feature.feature.group" version="1.4.0.201606011907"/>\r
+<unit id="org.eclipse.nebula.widgets.nattable.core.source.feature.feature.group" version="1.4.0.201606011907"/>\r
+<unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.source.feature.feature.group" version="1.4.0.201606011907"/>\r
+<unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.feature.feature.group" version="1.0.0.201606011907"/>\r
+<unit id="org.eclipse.nebula.widgets.nattable.extension.e4.feature.feature.group" version="1.0.0.201606011907"/>\r
+<unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.source.feature.feature.group" version="1.0.0.201606011907"/>\r
+<unit id="org.eclipse.nebula.widgets.nattable.extension.poi.source.feature.feature.group" version="1.4.0.201606011907"/>\r
+<repository location="http://www.simantics.org/update/nebula/nattable/releases/1.4.0/repository/"/>\r
+</location>\r
+<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
 <unit id="org.apache.commons.lang.source" version="2.6.0"/>\r
-<unit id="org.apache.lucene4.sandbox.source" version="4.9.0.b0003"/>\r
 <unit id="org.antlr.runtime.source" version="3.5.2"/>\r
 <unit id="org.apache.commons.compress" version="1.12.0"/>\r
 <unit id="org.apache.pdfbox.source" version="2.0.2"/>\r
 <unit id="org.ini4j" version="0.5.4"/>\r
 <unit id="org.jdom2.source" version="2.0.6"/>\r
 <unit id="org.apache.commons.logging" version="1.2.0"/>\r
+<unit id="org.apache.pdfbox.xmpbox.source" version="2.0.2"/>\r
 <unit id="net.ucanaccess" version="3.0.6"/>\r
 <unit id="gnu.trove2" version="2.1.0"/>\r
 <unit id="net.ucanaccess.source" version="3.0.6"/>\r
 <unit id="org.eclipse.collections.eclipse-collections.source" version="7.1.0"/>\r
 <unit id="freemarker" version="2.3.23.stable"/>\r
 <unit id="com.github.virtuald.curvesapi.source" version="1.3.0"/>\r
-<unit id="org.apache.lucene4.analyzers-common" version="4.9.0.b0003"/>\r
 <unit id="org.apache.commons.collections.source" version="3.2.2"/>\r
 <unit id="org.apache.pdfbox.fontbox" version="2.0.2"/>\r
 <unit id="org.apache.commons.compress.source" version="1.12.0"/>\r
+<unit id="org.apache.lucene4.queryparser.source" version="4.9.0.b0003"/>\r
 <unit id="org.mozilla.rhino.source" version="1.7.7.1"/>\r
-<unit id="org.apache.lucene4.queries.source" version="4.9.0.b0003"/>\r
 <unit id="freemarker.source" version="2.3.23.stable"/>\r
 <unit id="jakarta-regexp" version="1.4.0"/>\r
 <unit id="net.jcip.annotations.source" version="1.0.0"/>\r
 <unit id="org.apache.log4j.source" version="1.2.17"/>\r
-<unit id="org.apache.lucene4.sandbox" version="4.9.0.b0003"/>\r
 <unit id="org.apache.commons.logging.source" version="1.2.0"/>\r
 <unit id="org.apache.commons.io.source" version="1.4.0"/>\r
-<unit id="org.apache.lucene4.core" version="4.9.0.b0003"/>\r
 <unit id="com.healthmarketscience.jackcess" version="2.1.3"/>\r
 <unit id="org.bouncycastle.bctsp-jdk14.source" version="1.38.0"/>\r
 <unit id="org.eclipse.collections.eclipse-collections-api" version="7.1.0"/>\r
 <unit id="it.unimi.dsi.fastutil.source" version="7.0.12"/>\r
 <unit id="org.hsqldb.hsqldb.source" version="2.3.1"/>\r
 <unit id="org.apache.poi.source" version="3.14.0"/>\r
+<unit id="org.apache.lucene4.sandbox.source" version="4.9.0.b0003"/>\r
 <unit id="org.apache.xmlbeans" version="2.6.0"/>\r
 <unit id="org.supercsv" version="2.4.0"/>\r
 <unit id="org.mozilla.rhino" version="1.7.7.1"/>\r
+<unit id="org.apache.pdfbox.xmpbox" version="2.0.2"/>\r
 <unit id="org.apache.commons.codec" version="1.10.0"/>\r
 <unit id="com.healthmarketscience.jackcess.source" version="2.1.3"/>\r
 <unit id="org.eclipse.collections.eclipse-collections-api.source" version="7.1.0"/>\r
 <unit id="org.bouncycastle.bcprov-jdk14.source" version="1.38.0"/>\r
 <unit id="stax.api" version="1.0.1"/>\r
 <unit id="org.apache.pdfbox.fontbox.source" version="2.0.2"/>\r
-<unit id="org.apache.lucene4.analyzers-common.source" version="4.9.0.b0003"/>\r
 <unit id="it.unimi.dsi.fastutil" version="7.0.12"/>\r
+<unit id="com.lowagie.text.source" version="2.1.7.b1"/>\r
 <unit id="net.jcip.annotations" version="1.0.0"/>\r
+<unit id="org.apache.lucene4.queryparser" version="4.9.0.b0003"/>\r
 <unit id="org.bouncycastle.bctsp-jdk14" version="1.38.0"/>\r
 <unit id="org.jfree.jchart.source" version="1.0.19"/>\r
-<unit id="org.apache.lucene4.queryparser" version="4.9.0.b0003"/>\r
+<unit id="com.lowagie.text" version="2.1.7.b1"/>\r
 <unit id="org.apache.poi.ooxml-schemas" version="3.14.0"/>\r
 <unit id="org.bouncycastle.bcprov-jdk14" version="1.38.0"/>\r
+<unit id="com.sun.jna" version="4.2.2"/>\r
 <unit id="org.apache.poi" version="3.14.0"/>\r
 <unit id="org.jdom2" version="2.0.6"/>\r
 <unit id="org.apache.commons.lang" version="2.6.0"/>\r
 <unit id="org.jfree.jchart" version="1.0.19"/>\r
+<unit id="org.apache.lucene4.sandbox" version="4.9.0.b0003"/>\r
 <unit id="org.apache.commons.codec.source" version="1.10.0"/>\r
-<unit id="com.lowagie.text.source" version="2.1.7.b1"/>\r
 <unit id="org.supercsv.source" version="2.4.0"/>\r
 <unit id="com.github.virtuald.curvesapi" version="1.3.0"/>\r
 <unit id="org.eclipse.collections.eclipse-collections" version="7.1.0"/>\r
 <unit id="org.apache.log4j" version="1.2.17"/>\r
-<unit id="com.lowagie.text" version="2.1.7.b1"/>\r
+<unit id="org.apache.lucene4.queries.source" version="4.9.0.b0003"/>\r
+<unit id="com.fasterxml.jackson.core.jackson-core.source" version="2.8.2"/>\r
+<unit id="org.apache.lucene4.core.source" version="4.9.0.b0003"/>\r
+<unit id="com.sun.jna.source" version="4.2.2"/>\r
 <unit id="org.apache.poi.ooxml" version="3.14.0"/>\r
+<unit id="com.sun.jna.platform" version="4.2.2"/>\r
+<unit id="org.apache.lucene4.analyzers-common.source" version="4.9.0.b0003"/>\r
 <unit id="org.apache.pdfbox" version="2.0.2"/>\r
 <unit id="org.bouncycastle.bcmail-jdk14" version="1.38.0"/>\r
 <unit id="org.jfree.jcommon" version="1.0.23"/>\r
+<unit id="org.apache.lucene4.analyzers-common" version="4.9.0.b0003"/>\r
 <unit id="org.apache.commons.collections" version="3.2.2"/>\r
 <unit id="org.apache.poi.ooxml.source" version="3.14.0"/>\r
+<unit id="com.fasterxml.jackson.core.jackson-core" version="2.8.2"/>\r
+<unit id="org.apache.lucene4.core" version="4.9.0.b0003"/>\r
 <unit id="gnu.trove2.source" version="2.1.0"/>\r
 <unit id="gnu.trove3" version="3.0.3"/>\r
 <unit id="org.antlr.runtime" version="3.5.2"/>\r
 <unit id="org.hsqldb.hsqldb" version="2.3.1"/>\r
 <unit id="org.apache.commons.io" version="1.4.0"/>\r
 <unit id="bouncycastle.bcmail-jdk14" version="138.0.0"/>\r
+<unit id="org.apache.lucene4.queries" version="4.9.0.b0003"/>\r
+<unit id="com.sun.jna.platform.source" version="4.2.2"/>\r
 <unit id="javax.vecmath" version="1.5.2"/>\r
 <unit id="bouncycastle.bcprov-jdk14" version="138.0.0"/>\r
 <unit id="org.ini4j.source" version="0.5.4"/>\r
-<unit id="org.apache.lucene4.core.source" version="4.9.0.b0003"/>\r
-<unit id="org.apache.lucene4.queryparser.source" version="4.9.0.b0003"/>\r
 <repository location="http://www.simantics.org/download/master/external-components"/>\r
 </location>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.eclipse.e4.tools.spies.feature.feature.group" version="0.17.0.v20160811-1516"/>\r
-<repository location="http://www.simantics.org/update/e4/snapshots/org.eclipse.e4.tools/latest/"/>\r
-</location>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.eclipse.nebula.incubation.feature.feature.group" version="1.0.0.201605182147"/>\r
-<unit id="org.eclipse.nebula.examples.incubation.feature.feature.group" version="1.0.0.201605182147"/>\r
-<repository location="http://www.simantics.org/update/nebula/Q22016/incubation"/>\r
-</location>\r
-<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">\r
-<unit id="org.eclipse.nebula.widgets.nattable.core.feature.feature.group" version="1.4.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.e4.source.feature.feature.group" version="1.0.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.poi.feature.feature.group" version="1.4.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.feature.feature.group" version="1.4.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.core.source.feature.feature.group" version="1.4.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.source.feature.feature.group" version="1.4.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.feature.feature.group" version="1.0.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.e4.feature.feature.group" version="1.0.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.source.feature.feature.group" version="1.0.0.201606011907"/>\r
-<unit id="org.eclipse.nebula.widgets.nattable.extension.poi.source.feature.feature.group" version="1.4.0.201606011907"/>\r
-<repository location="http://www.simantics.org/update/nebula/nattable/releases/1.4.0/repository/"/>\r
-</location>\r
 </locations>\r
 </target>\r