Changes for Eclipse 2019-12 RCP platform compatibility. 92/3792/2
authorTuukka Lehtonen <tuukka.lehtonen@semantum.fi>
Fri, 17 Jan 2020 11:03:05 +0000 (13:03 +0200)
committerTuukka Lehtonen <tuukka.lehtonen@semantum.fi>
Fri, 17 Jan 2020 11:04:00 +0000 (11:04 +0000)
* org.eclipse.equinox.util seems to have been removed, removed
  unnecessary dependencies to it
* Expand org.objectweb.asm* required version range to [5,8) from [5,6)
* Removed dependency on org.objectweb.asm.xml which no longer exists as
  a separate bundle.

gitlab #405

Change-Id: Idcb6fee939da8cda9d44f230fb6e6118bc9e5e6e

bundles/org.simantics.databoard/META-INF/MANIFEST.MF
bundles/org.simantics.fastlz/META-INF/MANIFEST.MF
bundles/org.simantics.lz4/META-INF/MANIFEST.MF
bundles/org.simantics.scl.compiler/META-INF/MANIFEST.MF
features/org.simantics.scl.feature/feature.xml

index e44b55bd470a826f7d050c1dfe85d9ac6f940320..efa4817264d7145e55099c8551078031d493b0df 100644 (file)
@@ -5,7 +5,7 @@ Bundle-SymbolicName: org.simantics.databoard;singleton:=true
 Bundle-Version: 0.6.6.qualifier
 Bundle-RequiredExecutionEnvironment: JavaSE-1.8
 Require-Bundle: org.junit;resolution:=optional,
- org.objectweb.asm;bundle-version="[5.0.0,6.0.0)";resolution:=optional;visibility:=reexport,
+ org.objectweb.asm;bundle-version="[5.0.0,8.0.0)";resolution:=optional;visibility:=reexport,
  gnu.trove3;bundle-version="3.0.0",
  org.eclipse.help;bundle-version="3.5.100";resolution:=optional,
  org.eclipse.swt;bundle-version="3.7.1";resolution:=optional,
index 9dce615860990723bcd5c10ab7969a4c834202d3..f05b9d965b0587dee25bd0b77c7fd1aeed7698f0 100644 (file)
@@ -8,7 +8,6 @@ Bundle-Activator: org.simantics.fastlz.bundle.Activator
 Require-Bundle: org.eclipse.core.runtime,
  org.junit;bundle-version="4.12.0";resolution:=optional,
  org.simantics.compressions;bundle-version="1.0.0",
- org.eclipse.equinox.util;bundle-version="1.0.300",
  org.eclipse.equinox.ds;bundle-version="1.3.1",
  org.eclipse.osgi.services;bundle-version="3.3.0"
 Export-Package: org.simantics.fastlz
index 205be1f2310ded559b8efc392567e4eb795bcb4f..173d0c6cab844fcc431c283ba0981b01ff440e01 100644 (file)
@@ -9,7 +9,6 @@ Export-Package: net.jpountz.lz4,
  org.simantics.lz4
 Require-Bundle: org.eclipse.osgi,
  org.simantics.compressions;bundle-version="1.0.0",
- org.eclipse.equinox.util;bundle-version="1.0.300",
  org.eclipse.equinox.ds;bundle-version="1.3.1",
  org.eclipse.osgi.services;bundle-version="3.3.0"
 Service-Component: OSGI-INF/component.xml
index 627eac496e4ef48178613029d617cb85e89b6310..70bb068b32d900359e8b798d15cab39a7d4f7037 100644 (file)
@@ -7,9 +7,9 @@ Bundle-RequiredExecutionEnvironment: JavaSE-1.8
 Require-Bundle: gnu.trove3;bundle-version="3.0.0",
  org.simantics.scl.runtime;bundle-version="0.1.4";visibility:=reexport,
  org.junit;bundle-version="4.12.0";resolution:=optional,
- org.objectweb.asm;bundle-version="[5.0.0,6.0.0)",
- org.objectweb.asm.commons;bundle-version="[5.0.0,6.0.0)",
- org.objectweb.asm.util;bundle-version="[5.0.0,6.0.0)",
+ org.objectweb.asm;bundle-version="[5.0.0,8.0.0)",
+ org.objectweb.asm.commons;bundle-version="[5.0.0,8.0.0)",
+ org.objectweb.asm.util;bundle-version="[5.0.0,8.0.0)",
  org.slf4j.api;bundle-version="1.7.2"
 Export-Package: org.cojen.classfile,
  org.simantics.scl.compiler.commands,
index e87b68842abce9986986724e59e0457ff0e64081..5082bdc632d1333de7ac4d3e1babd1adb2365760 100644 (file)
@@ -213,13 +213,6 @@ This Agreement is governed by the laws of the State of New York and the intellec
          version="0.0.0"
          unpack="false"/>
 
-   <plugin
-         id="org.objectweb.asm.xml"
-         download-size="0"
-         install-size="0"
-         version="0.0.0"
-         unpack="false"/>
-
    <plugin
          id="com.fasterxml.jackson.core.jackson-core"
          download-size="0"