Added qualifier to org.simantics.sdk version 96/1096/1
authorTuukka Lehtonen <tuukka.lehtonen@semantum.fi>
Wed, 11 Oct 2017 12:07:35 +0000 (15:07 +0300)
committerTuukka Lehtonen <tuukka.lehtonen@semantum.fi>
Wed, 11 Oct 2017 12:07:35 +0000 (15:07 +0300)
This change was required to make the Simatnics SDK contents update after
the SDK contents are changed in some way. Otherwise local bundle pools
will not get updated easily.

refs #7542

Change-Id: I00d3df96eab2aedc690beb58551b4a71d537ad2c

features/org.simantics.sdk.feature/feature.xml
releng/org.simantics.sdk.build.targetdefinition/simantics.target
releng/org.simantics.sdk.build.targetdefinition/simantics.tpd

index 26928844f47bc53de8db5d695e3bea666c23f8e1..61bb1e5b53d83ddfcafb7852110f6d1bfc00e6fd 100644 (file)
@@ -13,7 +13,7 @@
 <feature
       id="org.simantics.sdk"
       label="Simantics SDK"
-      version="1.31.0"
+      version="1.31.0.qualifier"
       provider-name="VTT Technical Research Centre of Finland">
 
    <description url="http://www.example.com/description">
index 0575532ed66bde33fb66284e6605c187c00face4..dfb65a9e2f15cd3d7d425369a986288398a893e0 100644 (file)
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<?pde?>
-<!-- generated with https://github.com/mbarbero/fr.obeo.releng.targetplatform -->
-<target name="Simantics 1.31.0" sequenceNumber="1505284281">
-  <locations>
-    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
-      <unit id="com.google.guava" version="21.0.0.v20170206-1425"/>
-      <unit id="com.google.guava.source" version="21.0.0.v20170206-1425"/>
-      <unit id="org.objectweb.asm" version="5.2.0.v20170126-0011"/>
-      <unit id="org.objectweb.asm.analysis" version="5.2.0.v20170126-0011"/>
-      <unit id="org.objectweb.asm.analysis.source" version="5.2.0.v20170126-0011"/>
-      <unit id="org.objectweb.asm.commons" version="5.2.0.v20170126-0011"/>
-      <unit id="org.objectweb.asm.commons.source" version="5.2.0.v20170126-0011"/>
-      <unit id="org.objectweb.asm.source" version="5.2.0.v20170126-0011"/>
-      <unit id="org.objectweb.asm.tree" version="5.2.0.v20170126-0011"/>
-      <unit id="org.objectweb.asm.tree.source" version="5.2.0.v20170126-0011"/>
-      <unit id="org.objectweb.asm.util" version="5.2.0.v20170126-0011"/>
-      <unit id="org.objectweb.asm.util.source" version="5.2.0.v20170126-0011"/>
-      <unit id="org.objectweb.asm.xml" version="5.2.0.v20170126-0011"/>
-      <unit id="org.objectweb.asm.xml.source" version="5.2.0.v20170126-0011"/>
-      <repository location="http://www.simantics.org/update/tools/orbit/downloads/drops/R20170516192513"/>
-    </location>
-    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
-      <unit id="javax.xml" version="1.3.4.v201005080400"/>
-      <unit id="org.apache.commons.httpclient" version="3.1.0.v201012070820"/>
-      <unit id="org.apache.commons.httpclient.source" version="3.1.0.v201012070820"/>
-      <unit id="org.apache.xerces" version="2.9.0.v201101211617"/>
-      <unit id="org.apache.xml.resolver" version="1.2.0.v201005080400"/>
-      <unit id="org.apache.xml.serializer" version="2.7.1.v201005080400"/>
-      <unit id="org.eclipse.draw2d.feature.group" version="3.10.100.201606061308"/>
-      <unit id="org.eclipse.emf.sdk.feature.group" version="2.13.0.v20170609-0928"/>
-      <unit id="org.eclipse.epp.mpc.feature.group" version="1.6.0.v20170616-0843"/>
-      <unit id="org.eclipse.epp.mpc.source.feature.group" version="1.6.0.v20170616-0843"/>
-      <unit id="org.eclipse.mylyn.commons.feature.group" version="3.23.0.v20170503-0014"/>
-      <unit id="org.eclipse.mylyn.commons.identity.feature.group" version="1.15.0.v20170411-1844"/>
-      <unit id="org.eclipse.mylyn.commons.net" version="3.23.0.v20170411-1844"/>
-      <unit id="org.eclipse.mylyn.commons.net.source" version="3.23.0.v20170411-1844"/>
-      <unit id="org.eclipse.mylyn.commons.notifications.feature.group" version="1.15.0.v20170411-1844"/>
-      <unit id="org.eclipse.mylyn.commons.repositories.core" version="1.15.0.v20170411-1844"/>
-      <unit id="org.eclipse.mylyn.commons.repositories.core.source" version="1.15.0.v20170411-1844"/>
-      <unit id="org.eclipse.mylyn.commons.repositories.ui" version="1.15.0.v20170411-1844"/>
-      <unit id="org.eclipse.mylyn.commons.repositories.ui.source" version="1.15.0.v20170411-1844"/>
-      <unit id="org.eclipse.mylyn.context_feature.feature.group" version="3.23.0.v20170414-0629"/>
-      <unit id="org.eclipse.mylyn.monitor.feature.group" version="3.23.0.v20170411-1844"/>
-      <unit id="org.eclipse.mylyn.tasks.core" version="3.23.0.v20170602-2017"/>
-      <unit id="org.eclipse.mylyn.tasks.core.source" version="3.23.0.v20170602-2017"/>
-      <unit id="org.eclipse.mylyn.tasks.ui" version="3.23.0.v20170608-2055"/>
-      <unit id="org.eclipse.mylyn.tasks.ui.source" version="3.23.0.v20170608-2055"/>
-      <unit id="org.eclipse.mylyn.wikitext_feature.feature.group" version="3.0.6.201703111926"/>
-      <unit id="org.eclipse.mylyn.wikitext.ant.source" version="3.0.6.20170311142502"/>
-      <unit id="org.eclipse.mylyn.wikitext.mediawiki.source" version="3.0.6.20170311142502"/>
-      <unit id="org.eclipse.mylyn.wikitext.osgi.source" version="3.0.6.201703111926"/>
-      <unit id="org.eclipse.mylyn.wikitext.source" version="3.0.6.20170311142502"/>
-      <unit id="org.eclipse.userstorage.feature.group" version="1.1.0.v20170526-1605"/>
-      <unit id="org.eclipse.userstorage.oauth" version="1.0.0.v20170526-1605"/>
-      <unit id="org.eclipse.userstorage.oauth.source" version="1.0.0.v20170526-1605"/>
-      <unit id="org.eclipse.userstorage.source" version="1.1.0.v20170328-0205"/>
-      <unit id="org.eclipse.userstorage.ui.source" version="1.0.2.v20170526-1605"/>
-      <repository location="http://www.simantics.org/update/oxygen/"/>
-    </location>
-    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
-      <unit id="org.apache.httpcomponents.httpclient" version="4.5.2.v20170210-0925"/>
-      <unit id="org.apache.httpcomponents.httpclient.source" version="4.5.2.v20170210-0925"/>
-      <unit id="org.apache.httpcomponents.httpcore" version="4.4.6.v20170210-0925"/>
-      <unit id="org.apache.httpcomponents.httpcore.source" version="4.4.6.v20170210-0925"/>
-      <unit id="org.eclipse.core.runtime.feature.feature.group" version="1.2.0.v20170518-1049"/>
-      <unit id="org.eclipse.e4.core.tools.feature.feature.group" version="4.7.0.v20170515-1617"/>
-      <unit id="org.eclipse.e4.core.tools.feature.source.feature.group" version="4.7.0.v20170515-1617"/>
-      <unit id="org.eclipse.ecf.core.feature.feature.group" version="1.4.0.v20170516-2248"/>
-      <unit id="org.eclipse.ecf.core.feature.source.feature.group" version="1.4.0.v20170516-2248"/>
-      <unit id="org.eclipse.ecf.core.ssl.feature.feature.group" version="1.1.0.v20170110-1317"/>
-      <unit id="org.eclipse.ecf.core.ssl.feature.source.feature.group" version="1.1.0.v20170110-1317"/>
-      <unit id="org.eclipse.ecf.filetransfer.feature.feature.group" version="3.13.7.v20170516-2248"/>
-      <unit id="org.eclipse.ecf.filetransfer.feature.source.feature.group" version="3.13.7.v20170516-2248"/>
-      <unit id="org.eclipse.ecf.filetransfer.httpclient4.feature.feature.group" version="3.13.7.v20170516-2248"/>
-      <unit id="org.eclipse.ecf.filetransfer.httpclient4.feature.source.feature.group" version="3.13.7.v20170516-2248"/>
-      <unit id="org.eclipse.ecf.filetransfer.httpclient4.ssl.feature.feature.group" version="1.1.0.v20170110-1317"/>
-      <unit id="org.eclipse.ecf.filetransfer.httpclient4.ssl.feature.source.feature.group" version="1.1.0.v20170110-1317"/>
-      <unit id="org.eclipse.ecf.filetransfer.ssl.feature.feature.group" version="1.1.0.v20170110-1317"/>
-      <unit id="org.eclipse.ecf.filetransfer.ssl.feature.source.feature.group" version="1.1.0.v20170110-1317"/>
-      <unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="1.1.0.v20170418-0708"/>
-      <unit id="org.eclipse.equinox.sdk.feature.group" version="3.13.0.v20170531-1133"/>
-      <unit id="org.eclipse.help.feature.group" version="2.2.100.v20170612-0950"/>
-      <unit id="org.eclipse.help.source.feature.group" version="2.2.100.v20170612-0950"/>
-      <unit id="org.eclipse.platform.feature.group" version="4.7.0.v20170612-1255"/>
-      <unit id="org.eclipse.platform.source.feature.group" version="4.7.0.v20170612-1255"/>
-      <unit id="org.eclipse.rcp.feature.group" version="4.7.0.v20170612-1255"/>
-      <unit id="org.eclipse.rcp.source.feature.group" version="4.7.0.v20170612-1255"/>
-      <unit id="org.eclipse.releng.tools.feature.group" version="3.9.100.v20170516-0717"/>
-      <unit id="org.eclipse.sdk.ide" version="4.7.0.I20170612-0950"/>
-      <unit id="org.eclipse.swt.tools.feature.feature.group" version="3.106.0.v20170503-0851"/>
-      <repository location="http://www.simantics.org/update/eclipse/updates/4.7/"/>
-    </location>
-    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
-      <unit id="org.eclipse.nebula.cwt.feature.feature.group" version="1.0.0.201706221838"/>
-      <unit id="org.eclipse.nebula.effects.stw.feature.feature.group" version="1.0.0.201706221838"/>
-      <unit id="org.eclipse.nebula.examples.feature.feature.group" version="1.0.4.201706221838"/>
-      <unit id="org.eclipse.nebula.examples.release.feature.feature.group" version="1.1.0.201706221838"/>
-      <unit id="org.eclipse.nebula.feature.feature.group" version="1.3.0.201706221838"/>
-      <unit id="org.eclipse.nebula.visualization.feature.feature.group" version="2.0.0.201706221838"/>
-      <unit id="org.eclipse.nebula.widgets.cdatetime.feature.feature.group" version="1.0.0.201706221838"/>
-      <unit id="org.eclipse.nebula.widgets.compositetable.feature.feature.group" version="1.0.0.201706221838"/>
-      <unit id="org.eclipse.nebula.widgets.gallery.feature.feature.group" version="1.0.0.201706221838"/>
-      <unit id="org.eclipse.nebula.widgets.ganttchart.feature.feature.group" version="1.0.0.201706221838"/>
-      <unit id="org.eclipse.nebula.widgets.grid.feature.feature.group" version="1.0.0.201706221838"/>
-      <unit id="org.eclipse.nebula.widgets.oscilloscope.feature.feature.group" version="1.3.0.201706221838"/>
-      <unit id="org.eclipse.nebula.widgets.paperclips.feature.feature.group" version="2.0.0.201706221838"/>
-      <unit id="org.eclipse.nebula.widgets.pgroup.feature.feature.group" version="1.0.0.201706221838"/>
-      <unit id="org.eclipse.nebula.widgets.pshelf.css.feature.feature.group" version="1.0.0.201706221838"/>
-      <unit id="org.eclipse.nebula.widgets.pshelf.feature.feature.group" version="1.0.0.201706221838"/>
-      <unit id="org.eclipse.nebula.widgets.richtext.feature.feature.group" version="1.2.0.201706221838"/>
-      <unit id="org.eclipse.nebula.widgets.tablecombo.feature.feature.group" version="1.0.0.201706221838"/>
-      <unit id="org.eclipse.nebula.widgets.xviewer.feature.feature.group" version="1.0.0.201706221838"/>
-      <repository location="http://www.simantics.org/update/nebula/releases/1.3.0/release/"/>
-    </location>
-    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
-      <unit id="org.eclipse.nebula.widgets.nattable.core.feature.feature.group" version="1.5.0.201703192131"/>
-      <unit id="org.eclipse.nebula.widgets.nattable.core.source.feature.feature.group" version="1.5.0.201703192131"/>
-      <unit id="org.eclipse.nebula.widgets.nattable.extension.e4.feature.feature.group" version="1.1.0.201703192131"/>
-      <unit id="org.eclipse.nebula.widgets.nattable.extension.e4.source.feature.feature.group" version="1.1.0.201703192131"/>
-      <unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.feature.feature.group" version="1.5.0.201703192131"/>
-      <unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.source.feature.feature.group" version="1.5.0.201703192131"/>
-      <unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.feature.feature.group" version="1.1.0.201703192131"/>
-      <unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.source.feature.feature.group" version="1.1.0.201703192131"/>
-      <unit id="org.eclipse.nebula.widgets.nattable.extension.poi.feature.feature.group" version="1.5.0.201703192131"/>
-      <unit id="org.eclipse.nebula.widgets.nattable.extension.poi.source.feature.feature.group" version="1.5.0.201703192131"/>
-      <repository location="http://www.simantics.org/update/nebula/nattable/releases/1.5.0/repository/"/>
-    </location>
-    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
-      <unit id="org.eclipse.e4.tools.spies.feature.feature.group" version="0.17.0.v20170601-1400"/>
-      <repository location="http://www.simantics.org/update/e4/snapshots/org.eclipse.e4.tools/latest-oxygen/"/>
-    </location>
-    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
-      <unit id="org.eclipse.nebula.incubation.feature.feature.group" version="1.0.0.201708070950"/>
-      <unit id="org.eclipse.nebula.examples.incubation.feature.feature.group" version="1.0.0.201708070950"/>
-      <repository location="http://www.simantics.org/update/nebula/releases/1.3.0/incubation/"/>
-    </location>
-    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
-      <unit id="bouncycastle.bcmail-jdk14" version="138.0.0"/>
-      <unit id="bouncycastle.bcprov-jdk14" version="138.0.0"/>
-      <unit id="ch.qos.logback.classic" version="1.2.3"/>
-      <unit id="ch.qos.logback.classic.source" version="1.2.3"/>
-      <unit id="ch.qos.logback.core" version="1.2.3"/>
-      <unit id="ch.qos.logback.core.source" version="1.2.3"/>
-      <unit id="com.esotericsoftware.kryo" version="4.0.0"/>
-      <unit id="com.esotericsoftware.kryo.source" version="4.0.0"/>
-      <unit id="com.esotericsoftware.minlog" version="1.3.0"/>
-      <unit id="com.esotericsoftware.minlog.source" version="1.3.0"/>
-      <unit id="com.esotericsoftware.reflectasm" version="1.11.3"/>
-      <unit id="com.esotericsoftware.reflectasm.source" version="1.11.3"/>
-      <unit id="com.fasterxml.jackson.core.jackson-annotations" version="2.8.8"/>
-      <unit id="com.fasterxml.jackson.core.jackson-annotations.source" version="2.8.8"/>
-      <unit id="com.fasterxml.jackson.core.jackson-core" version="2.8.8"/>
-      <unit id="com.fasterxml.jackson.core.jackson-core.source" version="2.8.8"/>
-      <unit id="com.fasterxml.jackson.core.jackson-databind" version="2.8.8"/>
-      <unit id="com.fasterxml.jackson.core.jackson-databind.source" version="2.8.8"/>
-      <unit id="com.fasterxml.jackson.dataformat.jackson-dataformat-csv" version="2.8.8"/>
-      <unit id="com.fasterxml.jackson.dataformat.jackson-dataformat-csv.source" version="2.8.8"/>
-      <unit id="com.fasterxml.jackson.dataformat.jackson-dataformat-xml" version="2.8.8"/>
-      <unit id="com.fasterxml.jackson.dataformat.jackson-dataformat-xml.source" version="2.8.8"/>
-      <unit id="com.fasterxml.jackson.datatype.jackson-datatype-jsr310" version="2.8.8"/>
-      <unit id="com.fasterxml.jackson.datatype.jackson-datatype-jsr310.source" version="2.8.8"/>
-      <unit id="com.fasterxml.jackson.jaxrs.jackson-jaxrs-base" version="2.8.8"/>
-      <unit id="com.fasterxml.jackson.jaxrs.jackson-jaxrs-base.source" version="2.8.8"/>
-      <unit id="com.fasterxml.jackson.jaxrs.jackson-jaxrs-json-provider" version="2.8.8"/>
-      <unit id="com.fasterxml.jackson.jaxrs.jackson-jaxrs-json-provider.source" version="2.8.8"/>
-      <unit id="com.fasterxml.jackson.module.jackson-module-jaxb-annotations" version="2.8.8"/>
-      <unit id="com.fasterxml.jackson.module.jackson-module-jaxb-annotations.source" version="2.8.8"/>
-      <unit id="com.fasterxml.woodstox.woodstox-core" version="5.0.3"/>
-      <unit id="com.fasterxml.woodstox.woodstox-core.source" version="5.0.3"/>
-      <unit id="com.github.virtuald.curvesapi" version="1.4.0"/>
-      <unit id="com.github.virtuald.curvesapi.source" version="1.4.0"/>
-      <unit id="com.healthmarketscience.jackcess" version="2.1.3"/>
-      <unit id="com.healthmarketscience.jackcess.source" version="2.1.3"/>
-      <unit id="com.koloboke.api-jdk8" version="1.0.0"/>
-      <unit id="com.koloboke.api-jdk8.source" version="1.0.0"/>
-      <unit id="com.koloboke.compile" version="0.5.1"/>
-      <unit id="com.koloboke.compile.source" version="0.5.1"/>
-      <unit id="com.koloboke.impl-common-jdk8" version="1.0.0"/>
-      <unit id="com.koloboke.impl-common-jdk8.source" version="1.0.0"/>
-      <unit id="com.lowagie.text" version="2.1.7.b1"/>
-      <unit id="com.lowagie.text.source" version="2.1.7.b1"/>
-      <unit id="com.sun.jna" version="4.3.0"/>
-      <unit id="com.sun.jna.platform" version="4.3.0"/>
-      <unit id="com.sun.jna.platform.source" version="4.3.0"/>
-      <unit id="com.sun.jna.source" version="4.3.0"/>
-      <unit id="freemarker" version="2.3.23.stable"/>
-      <unit id="freemarker.source" version="2.3.23.stable"/>
-      <unit id="gnu.trove3" version="3.0.3"/>
-      <unit id="gnu.trove3.source" version="3.0.3"/>
-      <unit id="it.unimi.dsi.fastutil" version="7.2.1"/>
-      <unit id="it.unimi.dsi.fastutil.source" version="7.2.1"/>
-      <unit id="jakarta-regexp" version="1.4.0"/>
-      <unit id="javassist" version="3.20.0.GA"/>
-      <unit id="javassist.source" version="3.20.0.GA"/>
-      <unit id="javax.servlet-api" version="3.1.0"/>
-      <unit id="javax.servlet-api.source" version="3.1.0"/>
-      <unit id="javax.validation.api" version="1.1.0.Final"/>
-      <unit id="javax.validation.api.source" version="1.1.0.Final"/>
-      <unit id="javax.ws.rs-api" version="2.0.1"/>
-      <unit id="javax.ws.rs-api.source" version="2.0.1"/>
-      <unit id="net.jcip.annotations" version="1.0.0"/>
-      <unit id="net.jcip.annotations.source" version="1.0.0"/>
-      <unit id="net.ucanaccess" version="3.0.7"/>
-      <unit id="net.ucanaccess.source" version="3.0.7"/>
-      <unit id="org.antlr.runtime" version="3.5.2"/>
-      <unit id="org.antlr.runtime.source" version="3.5.2"/>
-      <unit id="org.apache.aries.spifly.core-internal" version="1.0.8"/>
-      <unit id="org.apache.aries.spifly.dynamic.bundle" version="1.0.8"/>
-      <unit id="org.apache.aries.spifly.weaver-internal" version="1.0.8"/>
-      <unit id="org.apache.aries.util" version="1.0.0"/>
-      <unit id="org.apache.commons.codec" version="1.10.0"/>
-      <unit id="org.apache.commons.codec.source" version="1.10.0"/>
-      <unit id="org.apache.commons.collections" version="3.2.2"/>
-      <unit id="org.apache.commons.collections.source" version="3.2.2"/>
-      <unit id="org.apache.commons.collections4" version="4.1.0"/>
-      <unit id="org.apache.commons.collections4.source" version="4.1.0"/>
-      <unit id="org.apache.commons.compress" version="1.12.0"/>
-      <unit id="org.apache.commons.compress.source" version="1.12.0"/>
-      <unit id="org.apache.commons.io" version="2.4.0"/>
-      <unit id="org.apache.commons.io.source" version="2.4.0"/>
-      <unit id="org.apache.commons.lang" version="2.6.0"/>
-      <unit id="org.apache.commons.lang.source" version="2.6.0"/>
-      <unit id="org.apache.commons.logging" version="1.2.0"/>
-      <unit id="org.apache.commons.logging.source" version="1.2.0"/>
-      <unit id="org.apache.commons.math3" version="3.6.1"/>
-      <unit id="org.apache.commons.math3.source" version="3.6.1"/>
-      <unit id="org.apache.log4j" version="1.2.17"/>
-      <unit id="org.apache.log4j.source" version="1.2.17"/>
-      <unit id="org.apache.lucene4.analyzers-common" version="4.9.0.b0003"/>
-      <unit id="org.apache.lucene4.analyzers-common.source" version="4.9.0.b0003"/>
-      <unit id="org.apache.lucene4.core" version="4.9.0.b0003"/>
-      <unit id="org.apache.lucene4.core.source" version="4.9.0.b0003"/>
-      <unit id="org.apache.lucene4.queries" version="4.9.0.b0003"/>
-      <unit id="org.apache.lucene4.queries.source" version="4.9.0.b0003"/>
-      <unit id="org.apache.lucene4.queryparser" version="4.9.0.b0003"/>
-      <unit id="org.apache.lucene4.queryparser.source" version="4.9.0.b0003"/>
-      <unit id="org.apache.lucene4.sandbox" version="4.9.0.b0003"/>
-      <unit id="org.apache.lucene4.sandbox.source" version="4.9.0.b0003"/>
-      <unit id="org.apache.pdfbox" version="2.0.3"/>
-      <unit id="org.apache.pdfbox.fontbox" version="2.0.3"/>
-      <unit id="org.apache.pdfbox.fontbox.source" version="2.0.3"/>
-      <unit id="org.apache.pdfbox.source" version="2.0.3"/>
-      <unit id="org.apache.pdfbox.xmpbox" version="2.0.3"/>
-      <unit id="org.apache.pdfbox.xmpbox.source" version="2.0.3"/>
-      <unit id="org.apache.xmlbeans" version="2.6.0"/>
-      <unit id="org.bouncycastle.bcmail-jdk14" version="1.38.0"/>
-      <unit id="org.bouncycastle.bcmail-jdk14.source" version="1.38.0"/>
-      <unit id="org.bouncycastle.bcprov-jdk14" version="1.38.0"/>
-      <unit id="org.bouncycastle.bcprov-jdk14.source" version="1.38.0"/>
-      <unit id="org.bouncycastle.bctsp-jdk14" version="1.38.0"/>
-      <unit id="org.bouncycastle.bctsp-jdk14.source" version="1.38.0"/>
-      <unit id="org.eclipse.collections.eclipse-collections-api" version="8.1.0"/>
-      <unit id="org.eclipse.collections.eclipse-collections-api.source" version="8.1.0"/>
-      <unit id="org.eclipse.collections.eclipse-collections" version="8.1.0"/>
-      <unit id="org.eclipse.collections.eclipse-collections.source" version="8.1.0"/>
-      <unit id="org.glassfish.hk2.api" version="2.5.0.b32"/>
-      <unit id="org.glassfish.hk2.api.source" version="2.5.0.b32"/>
-      <unit id="org.glassfish.hk2.locator" version="2.5.0.b32"/>
-      <unit id="org.glassfish.hk2.locator.source" version="2.5.0.b32"/>
-      <unit id="org.glassfish.hk2.osgi-resource-locator" version="1.0.1"/>
-      <unit id="org.glassfish.hk2.osgi-resource-locator.source" version="1.0.1"/>
-      <unit id="org.glassfish.hk2.utils" version="2.5.0.b32"/>
-      <unit id="org.glassfish.hk2.utils.source" version="2.5.0.b32"/>
-      <unit id="org.glassfish.jersey.bundles.repackaged.jersey-guava" version="2.25.1"/>
-      <unit id="org.glassfish.jersey.bundles.repackaged.jersey-guava.source" version="2.25.1"/>
-      <unit id="org.glassfish.hk2.external.aopalliance-repackaged" version="2.5.0.b32"/>
-      <unit id="org.glassfish.hk2.external.aopalliance-repackaged.source" version="2.5.0.b32"/>
-      <unit id="org.glassfish.jersey.core.jersey-client" version="2.25.1"/>
-      <unit id="org.glassfish.jersey.core.jersey-client.source" version="2.25.1"/>
-      <unit id="org.glassfish.jersey.core.jersey-common" version="2.25.1"/>
-      <unit id="org.glassfish.jersey.core.jersey-common.source" version="2.25.1"/>
-      <unit id="org.glassfish.jersey.core.jersey-server" version="2.25.1"/>
-      <unit id="org.glassfish.jersey.core.jersey-server.source" version="2.25.1"/>
-      <unit id="org.glassfish.jersey.ext.jersey-entity-filtering" version="2.25.1"/>
-      <unit id="org.glassfish.jersey.ext.jersey-entity-filtering.source" version="2.25.1"/>
-      <unit id="org.glassfish.jersey.media.jersey-media-json-jackson" version="2.25.1"/>
-      <unit id="org.glassfish.jersey.media.jersey-media-json-jackson.source" version="2.25.1"/>
-      <unit id="org.glassfish.jersey.media.jersey-media-multipart" version="2.25.1"/>
-      <unit id="org.glassfish.jersey.media.jersey-media-multipart.source" version="2.25.1"/>
-      <unit id="org.glassfish.jersey.containers.jersey-container-servlet-core" version="2.25.1"/>
-      <unit id="org.glassfish.jersey.containers.jersey-container-servlet-core.source" version="2.25.1"/>
-      <unit id="org.hsqldb.hsqldb" version="2.3.1"/>
-      <unit id="org.hsqldb.hsqldb.source" version="2.3.1"/>
-      <unit id="org.ini4j" version="0.5.4"/>
-      <unit id="org.ini4j.source" version="0.5.4"/>
-      <unit id="org.jboss.windup.decompiler.api.forge-addon" version="4.0.0.Beta1"/>
-      <unit id="org.jboss.windup.decompiler.api.forge-addon.source" version="4.0.0.Beta1"/>
-      <unit id="org.jboss.windup.decompiler.procyon" version="4.0.0.Beta1"/>
-      <unit id="org.jboss.windup.decompiler.procyon.source" version="4.0.0.Beta1"/>
-      <unit id="org.jboss.windup.decompiler.procyon.windup-procyon-compilertools" version="1.0.0.20160510"/>
-      <unit id="org.jboss.windup.decompiler.procyon.windup-procyon-compilertools.source" version="1.0.0.20160510"/>
-      <unit id="org.jboss.windup.decompiler.procyon.windup-procyon-core" version="1.0.0.20160510"/>
-      <unit id="org.jboss.windup.decompiler.procyon.windup-procyon-core.source" version="1.0.0.20160510"/>
-      <unit id="org.jboss.windup.decompiler.procyon.windup-procyon-reflection" version="1.0.0.20160510"/>
-      <unit id="org.jboss.windup.decompiler.procyon.windup-procyon-reflection.source" version="1.0.0.20160510"/>
-      <unit id="org.jboss.windup.utils.windup-utils.forge-addon" version="4.0.0.Beta1"/>
-      <unit id="org.jboss.windup.utils.windup-utils.forge-addon.source" version="4.0.0.Beta1"/>
-      <unit id="org.jdom2" version="2.0.6.b0001"/>
-      <unit id="org.jdom2.source" version="2.0.6.b0001"/>
-      <unit id="org.jfree.jchart" version="1.0.19"/>
-      <unit id="org.jfree.jchart.source" version="1.0.19"/>
-      <unit id="org.jfree.jcommon" version="1.0.23"/>
-      <unit id="org.jfree.jcommon.source" version="1.0.23"/>
-      <unit id="org.jsoup" version="1.8.3"/>
-      <unit id="org.jsoup.source" version="1.8.3"/>
-      <unit id="org.jvnet.mimepull" version="1.9.6"/>
-      <unit id="org.jvnet.mimepull.source" version="1.9.6"/>
-      <unit id="org.mozilla.rhino" version="1.7.7.1"/>
-      <unit id="org.mozilla.rhino.source" version="1.7.7.1"/>
-      <unit id="org.objenesis" version="2.2.0"/>
-      <unit id="org.objenesis.source" version="2.2.0"/>
-      <unit id="org.slf4j.api" version="1.7.25.b001"/>
-      <unit id="org.slf4j.api.source" version="1.7.25.b001"/>
-      <unit id="org.supercsv" version="2.4.0"/>
-      <unit id="org.supercsv.source" version="2.4.0"/>
-      <unit id="stax2-api" version="3.1.4"/>
-      <unit id="stax2-api.source" version="3.1.4"/>
-      <repository location="http://www.simantics.org/download/master/external-components/maven"/>
-    </location>
-    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
-      <unit id="org.apache.batik" version="1.8.0.201611220734"/>
-      <unit id="org.apache.poi.feature.feature.group" version="3.15.0.b0002"/>
-      <repository location="http://www.simantics.org/download/master/external-components/manual"/>
-    </location>
-    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
-      <unit id="org.simantics.sdk.feature.group" version="1.31.0"/>
-      <unit id="org.simantics.sdk.source.feature.group" version="1.31.0"/>
-      <repository location="http://www.simantics.org/download/master/sdk"/>
-    </location>
-  </locations>
-</target>
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>\r
+<?pde?>\r
+<!-- generated with https://github.com/mbarbero/fr.obeo.releng.targetplatform -->\r
+<target name="Simantics 1.31.0" sequenceNumber="1507722542">\r
+  <locations>\r
+    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">\r
+      <unit id="com.google.guava" version="21.0.0.v20170206-1425"/>\r
+      <unit id="com.google.guava.source" version="21.0.0.v20170206-1425"/>\r
+      <unit id="org.objectweb.asm" version="5.2.0.v20170126-0011"/>\r
+      <unit id="org.objectweb.asm.analysis" version="5.2.0.v20170126-0011"/>\r
+      <unit id="org.objectweb.asm.analysis.source" version="5.2.0.v20170126-0011"/>\r
+      <unit id="org.objectweb.asm.commons" version="5.2.0.v20170126-0011"/>\r
+      <unit id="org.objectweb.asm.commons.source" version="5.2.0.v20170126-0011"/>\r
+      <unit id="org.objectweb.asm.source" version="5.2.0.v20170126-0011"/>\r
+      <unit id="org.objectweb.asm.tree" version="5.2.0.v20170126-0011"/>\r
+      <unit id="org.objectweb.asm.tree.source" version="5.2.0.v20170126-0011"/>\r
+      <unit id="org.objectweb.asm.util" version="5.2.0.v20170126-0011"/>\r
+      <unit id="org.objectweb.asm.util.source" version="5.2.0.v20170126-0011"/>\r
+      <unit id="org.objectweb.asm.xml" version="5.2.0.v20170126-0011"/>\r
+      <unit id="org.objectweb.asm.xml.source" version="5.2.0.v20170126-0011"/>\r
+      <repository location="http://www.simantics.org/update/tools/orbit/downloads/drops/R20170516192513"/>\r
+    </location>\r
+    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">\r
+      <unit id="javax.xml" version="1.3.4.v201005080400"/>\r
+      <unit id="org.apache.commons.httpclient" version="3.1.0.v201012070820"/>\r
+      <unit id="org.apache.commons.httpclient.source" version="3.1.0.v201012070820"/>\r
+      <unit id="org.apache.xerces" version="2.9.0.v201101211617"/>\r
+      <unit id="org.apache.xml.resolver" version="1.2.0.v201005080400"/>\r
+      <unit id="org.apache.xml.serializer" version="2.7.1.v201005080400"/>\r
+      <unit id="org.eclipse.draw2d.feature.group" version="3.10.100.201606061308"/>\r
+      <unit id="org.eclipse.emf.sdk.feature.group" version="2.13.0.v20170609-0928"/>\r
+      <unit id="org.eclipse.epp.mpc.feature.group" version="1.6.0.v20170616-0843"/>\r
+      <unit id="org.eclipse.epp.mpc.source.feature.group" version="1.6.0.v20170616-0843"/>\r
+      <unit id="org.eclipse.mylyn.commons.feature.group" version="3.23.0.v20170503-0014"/>\r
+      <unit id="org.eclipse.mylyn.commons.identity.feature.group" version="1.15.0.v20170411-1844"/>\r
+      <unit id="org.eclipse.mylyn.commons.net" version="3.23.0.v20170411-1844"/>\r
+      <unit id="org.eclipse.mylyn.commons.net.source" version="3.23.0.v20170411-1844"/>\r
+      <unit id="org.eclipse.mylyn.commons.notifications.feature.group" version="1.15.0.v20170411-1844"/>\r
+      <unit id="org.eclipse.mylyn.commons.repositories.core" version="1.15.0.v20170411-1844"/>\r
+      <unit id="org.eclipse.mylyn.commons.repositories.core.source" version="1.15.0.v20170411-1844"/>\r
+      <unit id="org.eclipse.mylyn.commons.repositories.ui" version="1.15.0.v20170411-1844"/>\r
+      <unit id="org.eclipse.mylyn.commons.repositories.ui.source" version="1.15.0.v20170411-1844"/>\r
+      <unit id="org.eclipse.mylyn.context_feature.feature.group" version="3.23.0.v20170414-0629"/>\r
+      <unit id="org.eclipse.mylyn.monitor.feature.group" version="3.23.0.v20170411-1844"/>\r
+      <unit id="org.eclipse.mylyn.tasks.core" version="3.23.0.v20170602-2017"/>\r
+      <unit id="org.eclipse.mylyn.tasks.core.source" version="3.23.0.v20170602-2017"/>\r
+      <unit id="org.eclipse.mylyn.tasks.ui" version="3.23.0.v20170608-2055"/>\r
+      <unit id="org.eclipse.mylyn.tasks.ui.source" version="3.23.0.v20170608-2055"/>\r
+      <unit id="org.eclipse.mylyn.wikitext_feature.feature.group" version="3.0.6.201703111926"/>\r
+      <unit id="org.eclipse.mylyn.wikitext.ant.source" version="3.0.6.20170311142502"/>\r
+      <unit id="org.eclipse.mylyn.wikitext.mediawiki.source" version="3.0.6.20170311142502"/>\r
+      <unit id="org.eclipse.mylyn.wikitext.osgi.source" version="3.0.6.201703111926"/>\r
+      <unit id="org.eclipse.mylyn.wikitext.source" version="3.0.6.20170311142502"/>\r
+      <unit id="org.eclipse.userstorage.feature.group" version="1.1.0.v20170526-1605"/>\r
+      <unit id="org.eclipse.userstorage.oauth" version="1.0.0.v20170526-1605"/>\r
+      <unit id="org.eclipse.userstorage.oauth.source" version="1.0.0.v20170526-1605"/>\r
+      <unit id="org.eclipse.userstorage.source" version="1.1.0.v20170328-0205"/>\r
+      <unit id="org.eclipse.userstorage.ui.source" version="1.0.2.v20170526-1605"/>\r
+      <repository location="http://www.simantics.org/update/oxygen/"/>\r
+    </location>\r
+    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">\r
+      <unit id="org.apache.httpcomponents.httpclient" version="4.5.2.v20170210-0925"/>\r
+      <unit id="org.apache.httpcomponents.httpclient.source" version="4.5.2.v20170210-0925"/>\r
+      <unit id="org.apache.httpcomponents.httpcore" version="4.4.6.v20170210-0925"/>\r
+      <unit id="org.apache.httpcomponents.httpcore.source" version="4.4.6.v20170210-0925"/>\r
+      <unit id="org.eclipse.core.runtime.feature.feature.group" version="1.2.0.v20170518-1049"/>\r
+      <unit id="org.eclipse.e4.core.tools.feature.feature.group" version="4.7.0.v20170515-1617"/>\r
+      <unit id="org.eclipse.e4.core.tools.feature.source.feature.group" version="4.7.0.v20170515-1617"/>\r
+      <unit id="org.eclipse.ecf.core.feature.feature.group" version="1.4.0.v20170516-2248"/>\r
+      <unit id="org.eclipse.ecf.core.feature.source.feature.group" version="1.4.0.v20170516-2248"/>\r
+      <unit id="org.eclipse.ecf.core.ssl.feature.feature.group" version="1.1.0.v20170110-1317"/>\r
+      <unit id="org.eclipse.ecf.core.ssl.feature.source.feature.group" version="1.1.0.v20170110-1317"/>\r
+      <unit id="org.eclipse.ecf.filetransfer.feature.feature.group" version="3.13.7.v20170516-2248"/>\r
+      <unit id="org.eclipse.ecf.filetransfer.feature.source.feature.group" version="3.13.7.v20170516-2248"/>\r
+      <unit id="org.eclipse.ecf.filetransfer.httpclient4.feature.feature.group" version="3.13.7.v20170516-2248"/>\r
+      <unit id="org.eclipse.ecf.filetransfer.httpclient4.feature.source.feature.group" version="3.13.7.v20170516-2248"/>\r
+      <unit id="org.eclipse.ecf.filetransfer.httpclient4.ssl.feature.feature.group" version="1.1.0.v20170110-1317"/>\r
+      <unit id="org.eclipse.ecf.filetransfer.httpclient4.ssl.feature.source.feature.group" version="1.1.0.v20170110-1317"/>\r
+      <unit id="org.eclipse.ecf.filetransfer.ssl.feature.feature.group" version="1.1.0.v20170110-1317"/>\r
+      <unit id="org.eclipse.ecf.filetransfer.ssl.feature.source.feature.group" version="1.1.0.v20170110-1317"/>\r
+      <unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="1.1.0.v20170418-0708"/>\r
+      <unit id="org.eclipse.equinox.sdk.feature.group" version="3.13.0.v20170531-1133"/>\r
+      <unit id="org.eclipse.help.feature.group" version="2.2.100.v20170612-0950"/>\r
+      <unit id="org.eclipse.help.source.feature.group" version="2.2.100.v20170612-0950"/>\r
+      <unit id="org.eclipse.platform.feature.group" version="4.7.0.v20170612-1255"/>\r
+      <unit id="org.eclipse.platform.source.feature.group" version="4.7.0.v20170612-1255"/>\r
+      <unit id="org.eclipse.rcp.feature.group" version="4.7.0.v20170612-1255"/>\r
+      <unit id="org.eclipse.rcp.source.feature.group" version="4.7.0.v20170612-1255"/>\r
+      <unit id="org.eclipse.releng.tools.feature.group" version="3.9.100.v20170516-0717"/>\r
+      <unit id="org.eclipse.sdk.ide" version="4.7.0.I20170612-0950"/>\r
+      <unit id="org.eclipse.swt.tools.feature.feature.group" version="3.106.0.v20170503-0851"/>\r
+      <repository location="http://www.simantics.org/update/eclipse/updates/4.7/"/>\r
+    </location>\r
+    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">\r
+      <unit id="org.eclipse.nebula.cwt.feature.feature.group" version="1.0.0.201706221838"/>\r
+      <unit id="org.eclipse.nebula.effects.stw.feature.feature.group" version="1.0.0.201706221838"/>\r
+      <unit id="org.eclipse.nebula.examples.feature.feature.group" version="1.0.4.201706221838"/>\r
+      <unit id="org.eclipse.nebula.examples.release.feature.feature.group" version="1.1.0.201706221838"/>\r
+      <unit id="org.eclipse.nebula.feature.feature.group" version="1.3.0.201706221838"/>\r
+      <unit id="org.eclipse.nebula.visualization.feature.feature.group" version="2.0.0.201706221838"/>\r
+      <unit id="org.eclipse.nebula.widgets.cdatetime.feature.feature.group" version="1.0.0.201706221838"/>\r
+      <unit id="org.eclipse.nebula.widgets.compositetable.feature.feature.group" version="1.0.0.201706221838"/>\r
+      <unit id="org.eclipse.nebula.widgets.gallery.feature.feature.group" version="1.0.0.201706221838"/>\r
+      <unit id="org.eclipse.nebula.widgets.ganttchart.feature.feature.group" version="1.0.0.201706221838"/>\r
+      <unit id="org.eclipse.nebula.widgets.grid.feature.feature.group" version="1.0.0.201706221838"/>\r
+      <unit id="org.eclipse.nebula.widgets.oscilloscope.feature.feature.group" version="1.3.0.201706221838"/>\r
+      <unit id="org.eclipse.nebula.widgets.paperclips.feature.feature.group" version="2.0.0.201706221838"/>\r
+      <unit id="org.eclipse.nebula.widgets.pgroup.feature.feature.group" version="1.0.0.201706221838"/>\r
+      <unit id="org.eclipse.nebula.widgets.pshelf.css.feature.feature.group" version="1.0.0.201706221838"/>\r
+      <unit id="org.eclipse.nebula.widgets.pshelf.feature.feature.group" version="1.0.0.201706221838"/>\r
+      <unit id="org.eclipse.nebula.widgets.richtext.feature.feature.group" version="1.2.0.201706221838"/>\r
+      <unit id="org.eclipse.nebula.widgets.tablecombo.feature.feature.group" version="1.0.0.201706221838"/>\r
+      <unit id="org.eclipse.nebula.widgets.xviewer.feature.feature.group" version="1.0.0.201706221838"/>\r
+      <repository location="http://www.simantics.org/update/nebula/releases/1.3.0/release/"/>\r
+    </location>\r
+    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">\r
+      <unit id="org.eclipse.nebula.widgets.nattable.core.feature.feature.group" version="1.5.0.201703192131"/>\r
+      <unit id="org.eclipse.nebula.widgets.nattable.core.source.feature.feature.group" version="1.5.0.201703192131"/>\r
+      <unit id="org.eclipse.nebula.widgets.nattable.extension.e4.feature.feature.group" version="1.1.0.201703192131"/>\r
+      <unit id="org.eclipse.nebula.widgets.nattable.extension.e4.source.feature.feature.group" version="1.1.0.201703192131"/>\r
+      <unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.feature.feature.group" version="1.5.0.201703192131"/>\r
+      <unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.source.feature.feature.group" version="1.5.0.201703192131"/>\r
+      <unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.feature.feature.group" version="1.1.0.201703192131"/>\r
+      <unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.source.feature.feature.group" version="1.1.0.201703192131"/>\r
+      <unit id="org.eclipse.nebula.widgets.nattable.extension.poi.feature.feature.group" version="1.5.0.201703192131"/>\r
+      <unit id="org.eclipse.nebula.widgets.nattable.extension.poi.source.feature.feature.group" version="1.5.0.201703192131"/>\r
+      <repository location="http://www.simantics.org/update/nebula/nattable/releases/1.5.0/repository/"/>\r
+    </location>\r
+    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">\r
+      <unit id="org.eclipse.e4.tools.spies.feature.feature.group" version="0.17.0.v20170601-1400"/>\r
+      <repository location="http://www.simantics.org/update/e4/snapshots/org.eclipse.e4.tools/latest-oxygen/"/>\r
+    </location>\r
+    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">\r
+      <unit id="org.eclipse.nebula.incubation.feature.feature.group" version="1.0.0.201708070950"/>\r
+      <unit id="org.eclipse.nebula.examples.incubation.feature.feature.group" version="1.0.0.201708070950"/>\r
+      <repository location="http://www.simantics.org/update/nebula/releases/1.3.0/incubation/"/>\r
+    </location>\r
+    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">\r
+      <unit id="bouncycastle.bcmail-jdk14" version="138.0.0"/>\r
+      <unit id="bouncycastle.bcprov-jdk14" version="138.0.0"/>\r
+      <unit id="ch.qos.logback.classic" version="1.2.3"/>\r
+      <unit id="ch.qos.logback.classic.source" version="1.2.3"/>\r
+      <unit id="ch.qos.logback.core" version="1.2.3"/>\r
+      <unit id="ch.qos.logback.core.source" version="1.2.3"/>\r
+      <unit id="com.esotericsoftware.kryo" version="4.0.0"/>\r
+      <unit id="com.esotericsoftware.kryo.source" version="4.0.0"/>\r
+      <unit id="com.esotericsoftware.minlog" version="1.3.0"/>\r
+      <unit id="com.esotericsoftware.minlog.source" version="1.3.0"/>\r
+      <unit id="com.esotericsoftware.reflectasm" version="1.11.3"/>\r
+      <unit id="com.esotericsoftware.reflectasm.source" version="1.11.3"/>\r
+      <unit id="com.fasterxml.jackson.core.jackson-annotations" version="2.8.8"/>\r
+      <unit id="com.fasterxml.jackson.core.jackson-annotations.source" version="2.8.8"/>\r
+      <unit id="com.fasterxml.jackson.core.jackson-core" version="2.8.8"/>\r
+      <unit id="com.fasterxml.jackson.core.jackson-core.source" version="2.8.8"/>\r
+      <unit id="com.fasterxml.jackson.core.jackson-databind" version="2.8.8"/>\r
+      <unit id="com.fasterxml.jackson.core.jackson-databind.source" version="2.8.8"/>\r
+      <unit id="com.fasterxml.jackson.dataformat.jackson-dataformat-csv" version="2.8.8"/>\r
+      <unit id="com.fasterxml.jackson.dataformat.jackson-dataformat-csv.source" version="2.8.8"/>\r
+      <unit id="com.fasterxml.jackson.dataformat.jackson-dataformat-xml" version="2.8.8"/>\r
+      <unit id="com.fasterxml.jackson.dataformat.jackson-dataformat-xml.source" version="2.8.8"/>\r
+      <unit id="com.fasterxml.jackson.datatype.jackson-datatype-jsr310" version="2.8.8"/>\r
+      <unit id="com.fasterxml.jackson.datatype.jackson-datatype-jsr310.source" version="2.8.8"/>\r
+      <unit id="com.fasterxml.jackson.jaxrs.jackson-jaxrs-base" version="2.8.8"/>\r
+      <unit id="com.fasterxml.jackson.jaxrs.jackson-jaxrs-base.source" version="2.8.8"/>\r
+      <unit id="com.fasterxml.jackson.jaxrs.jackson-jaxrs-json-provider" version="2.8.8"/>\r
+      <unit id="com.fasterxml.jackson.jaxrs.jackson-jaxrs-json-provider.source" version="2.8.8"/>\r
+      <unit id="com.fasterxml.jackson.module.jackson-module-jaxb-annotations" version="2.8.8"/>\r
+      <unit id="com.fasterxml.jackson.module.jackson-module-jaxb-annotations.source" version="2.8.8"/>\r
+      <unit id="com.fasterxml.woodstox.woodstox-core" version="5.0.3"/>\r
+      <unit id="com.fasterxml.woodstox.woodstox-core.source" version="5.0.3"/>\r
+      <unit id="com.github.virtuald.curvesapi" version="1.4.0"/>\r
+      <unit id="com.github.virtuald.curvesapi.source" version="1.4.0"/>\r
+      <unit id="com.healthmarketscience.jackcess" version="2.1.3"/>\r
+      <unit id="com.healthmarketscience.jackcess.source" version="2.1.3"/>\r
+      <unit id="com.koloboke.api-jdk8" version="1.0.0"/>\r
+      <unit id="com.koloboke.api-jdk8.source" version="1.0.0"/>\r
+      <unit id="com.koloboke.compile" version="0.5.1"/>\r
+      <unit id="com.koloboke.compile.source" version="0.5.1"/>\r
+      <unit id="com.koloboke.impl-common-jdk8" version="1.0.0"/>\r
+      <unit id="com.koloboke.impl-common-jdk8.source" version="1.0.0"/>\r
+      <unit id="com.lowagie.text" version="2.1.7.b1"/>\r
+      <unit id="com.lowagie.text.source" version="2.1.7.b1"/>\r
+      <unit id="com.sun.jna" version="4.3.0"/>\r
+      <unit id="com.sun.jna.platform" version="4.3.0"/>\r
+      <unit id="com.sun.jna.platform.source" version="4.3.0"/>\r
+      <unit id="com.sun.jna.source" version="4.3.0"/>\r
+      <unit id="freemarker" version="2.3.23.stable"/>\r
+      <unit id="freemarker.source" version="2.3.23.stable"/>\r
+      <unit id="gnu.trove3" version="3.0.3"/>\r
+      <unit id="gnu.trove3.source" version="3.0.3"/>\r
+      <unit id="it.unimi.dsi.fastutil" version="7.2.1"/>\r
+      <unit id="it.unimi.dsi.fastutil.source" version="7.2.1"/>\r
+      <unit id="jakarta-regexp" version="1.4.0"/>\r
+      <unit id="javassist" version="3.20.0.GA"/>\r
+      <unit id="javassist.source" version="3.20.0.GA"/>\r
+      <unit id="javax.servlet-api" version="3.1.0"/>\r
+      <unit id="javax.servlet-api.source" version="3.1.0"/>\r
+      <unit id="javax.validation.api" version="1.1.0.Final"/>\r
+      <unit id="javax.validation.api.source" version="1.1.0.Final"/>\r
+      <unit id="javax.ws.rs-api" version="2.0.1"/>\r
+      <unit id="javax.ws.rs-api.source" version="2.0.1"/>\r
+      <unit id="net.jcip.annotations" version="1.0.0"/>\r
+      <unit id="net.jcip.annotations.source" version="1.0.0"/>\r
+      <unit id="net.ucanaccess" version="3.0.7"/>\r
+      <unit id="net.ucanaccess.source" version="3.0.7"/>\r
+      <unit id="org.antlr.runtime" version="3.5.2"/>\r
+      <unit id="org.antlr.runtime.source" version="3.5.2"/>\r
+      <unit id="org.apache.aries.spifly.core-internal" version="1.0.8"/>\r
+      <unit id="org.apache.aries.spifly.dynamic.bundle" version="1.0.8"/>\r
+      <unit id="org.apache.aries.spifly.weaver-internal" version="1.0.8"/>\r
+      <unit id="org.apache.aries.util" version="1.0.0"/>\r
+      <unit id="org.apache.commons.codec" version="1.10.0"/>\r
+      <unit id="org.apache.commons.codec.source" version="1.10.0"/>\r
+      <unit id="org.apache.commons.collections" version="3.2.2"/>\r
+      <unit id="org.apache.commons.collections.source" version="3.2.2"/>\r
+      <unit id="org.apache.commons.collections4" version="4.1.0"/>\r
+      <unit id="org.apache.commons.collections4.source" version="4.1.0"/>\r
+      <unit id="org.apache.commons.compress" version="1.12.0"/>\r
+      <unit id="org.apache.commons.compress.source" version="1.12.0"/>\r
+      <unit id="org.apache.commons.io" version="2.4.0"/>\r
+      <unit id="org.apache.commons.io.source" version="2.4.0"/>\r
+      <unit id="org.apache.commons.lang" version="2.6.0"/>\r
+      <unit id="org.apache.commons.lang.source" version="2.6.0"/>\r
+      <unit id="org.apache.commons.logging" version="1.2.0"/>\r
+      <unit id="org.apache.commons.logging.source" version="1.2.0"/>\r
+      <unit id="org.apache.commons.math3" version="3.6.1"/>\r
+      <unit id="org.apache.commons.math3.source" version="3.6.1"/>\r
+      <unit id="org.apache.log4j" version="1.2.17"/>\r
+      <unit id="org.apache.log4j.source" version="1.2.17"/>\r
+      <unit id="org.apache.lucene4.analyzers-common" version="4.9.0.b0003"/>\r
+      <unit id="org.apache.lucene4.analyzers-common.source" version="4.9.0.b0003"/>\r
+      <unit id="org.apache.lucene4.core" version="4.9.0.b0003"/>\r
+      <unit id="org.apache.lucene4.core.source" version="4.9.0.b0003"/>\r
+      <unit id="org.apache.lucene4.queries" version="4.9.0.b0003"/>\r
+      <unit id="org.apache.lucene4.queries.source" version="4.9.0.b0003"/>\r
+      <unit id="org.apache.lucene4.queryparser" version="4.9.0.b0003"/>\r
+      <unit id="org.apache.lucene4.queryparser.source" version="4.9.0.b0003"/>\r
+      <unit id="org.apache.lucene4.sandbox" version="4.9.0.b0003"/>\r
+      <unit id="org.apache.lucene4.sandbox.source" version="4.9.0.b0003"/>\r
+      <unit id="org.apache.pdfbox" version="2.0.3"/>\r
+      <unit id="org.apache.pdfbox.fontbox" version="2.0.3"/>\r
+      <unit id="org.apache.pdfbox.fontbox.source" version="2.0.3"/>\r
+      <unit id="org.apache.pdfbox.source" version="2.0.3"/>\r
+      <unit id="org.apache.pdfbox.xmpbox" version="2.0.3"/>\r
+      <unit id="org.apache.pdfbox.xmpbox.source" version="2.0.3"/>\r
+      <unit id="org.apache.xmlbeans" version="2.6.0"/>\r
+      <unit id="org.bouncycastle.bcmail-jdk14" version="1.38.0"/>\r
+      <unit id="org.bouncycastle.bcmail-jdk14.source" version="1.38.0"/>\r
+      <unit id="org.bouncycastle.bcprov-jdk14" version="1.38.0"/>\r
+      <unit id="org.bouncycastle.bcprov-jdk14.source" version="1.38.0"/>\r
+      <unit id="org.bouncycastle.bctsp-jdk14" version="1.38.0"/>\r
+      <unit id="org.bouncycastle.bctsp-jdk14.source" version="1.38.0"/>\r
+      <unit id="org.eclipse.collections.eclipse-collections-api" version="8.1.0"/>\r
+      <unit id="org.eclipse.collections.eclipse-collections-api.source" version="8.1.0"/>\r
+      <unit id="org.eclipse.collections.eclipse-collections" version="8.1.0"/>\r
+      <unit id="org.eclipse.collections.eclipse-collections.source" version="8.1.0"/>\r
+      <unit id="org.glassfish.hk2.api" version="2.5.0.b32"/>\r
+      <unit id="org.glassfish.hk2.api.source" version="2.5.0.b32"/>\r
+      <unit id="org.glassfish.hk2.locator" version="2.5.0.b32"/>\r
+      <unit id="org.glassfish.hk2.locator.source" version="2.5.0.b32"/>\r
+      <unit id="org.glassfish.hk2.osgi-resource-locator" version="1.0.1"/>\r
+      <unit id="org.glassfish.hk2.osgi-resource-locator.source" version="1.0.1"/>\r
+      <unit id="org.glassfish.hk2.utils" version="2.5.0.b32"/>\r
+      <unit id="org.glassfish.hk2.utils.source" version="2.5.0.b32"/>\r
+      <unit id="org.glassfish.jersey.bundles.repackaged.jersey-guava" version="2.25.1"/>\r
+      <unit id="org.glassfish.jersey.bundles.repackaged.jersey-guava.source" version="2.25.1"/>\r
+      <unit id="org.glassfish.hk2.external.aopalliance-repackaged" version="2.5.0.b32"/>\r
+      <unit id="org.glassfish.hk2.external.aopalliance-repackaged.source" version="2.5.0.b32"/>\r
+      <unit id="org.glassfish.jersey.core.jersey-client" version="2.25.1"/>\r
+      <unit id="org.glassfish.jersey.core.jersey-client.source" version="2.25.1"/>\r
+      <unit id="org.glassfish.jersey.core.jersey-common" version="2.25.1"/>\r
+      <unit id="org.glassfish.jersey.core.jersey-common.source" version="2.25.1"/>\r
+      <unit id="org.glassfish.jersey.core.jersey-server" version="2.25.1"/>\r
+      <unit id="org.glassfish.jersey.core.jersey-server.source" version="2.25.1"/>\r
+      <unit id="org.glassfish.jersey.ext.jersey-entity-filtering" version="2.25.1"/>\r
+      <unit id="org.glassfish.jersey.ext.jersey-entity-filtering.source" version="2.25.1"/>\r
+      <unit id="org.glassfish.jersey.media.jersey-media-json-jackson" version="2.25.1"/>\r
+      <unit id="org.glassfish.jersey.media.jersey-media-json-jackson.source" version="2.25.1"/>\r
+      <unit id="org.glassfish.jersey.media.jersey-media-multipart" version="2.25.1"/>\r
+      <unit id="org.glassfish.jersey.media.jersey-media-multipart.source" version="2.25.1"/>\r
+      <unit id="org.glassfish.jersey.containers.jersey-container-servlet-core" version="2.25.1"/>\r
+      <unit id="org.glassfish.jersey.containers.jersey-container-servlet-core.source" version="2.25.1"/>\r
+      <unit id="org.hsqldb.hsqldb" version="2.3.1"/>\r
+      <unit id="org.hsqldb.hsqldb.source" version="2.3.1"/>\r
+      <unit id="org.ini4j" version="0.5.4"/>\r
+      <unit id="org.ini4j.source" version="0.5.4"/>\r
+      <unit id="org.jboss.windup.decompiler.api.forge-addon" version="4.0.0.Beta1"/>\r
+      <unit id="org.jboss.windup.decompiler.api.forge-addon.source" version="4.0.0.Beta1"/>\r
+      <unit id="org.jboss.windup.decompiler.procyon" version="4.0.0.Beta1"/>\r
+      <unit id="org.jboss.windup.decompiler.procyon.source" version="4.0.0.Beta1"/>\r
+      <unit id="org.jboss.windup.decompiler.procyon.windup-procyon-compilertools" version="1.0.0.20160510"/>\r
+      <unit id="org.jboss.windup.decompiler.procyon.windup-procyon-compilertools.source" version="1.0.0.20160510"/>\r
+      <unit id="org.jboss.windup.decompiler.procyon.windup-procyon-core" version="1.0.0.20160510"/>\r
+      <unit id="org.jboss.windup.decompiler.procyon.windup-procyon-core.source" version="1.0.0.20160510"/>\r
+      <unit id="org.jboss.windup.decompiler.procyon.windup-procyon-reflection" version="1.0.0.20160510"/>\r
+      <unit id="org.jboss.windup.decompiler.procyon.windup-procyon-reflection.source" version="1.0.0.20160510"/>\r
+      <unit id="org.jboss.windup.utils.windup-utils.forge-addon" version="4.0.0.Beta1"/>\r
+      <unit id="org.jboss.windup.utils.windup-utils.forge-addon.source" version="4.0.0.Beta1"/>\r
+      <unit id="org.jdom2" version="2.0.6.b0001"/>\r
+      <unit id="org.jdom2.source" version="2.0.6.b0001"/>\r
+      <unit id="org.jfree.jchart" version="1.0.19"/>\r
+      <unit id="org.jfree.jchart.source" version="1.0.19"/>\r
+      <unit id="org.jfree.jcommon" version="1.0.23"/>\r
+      <unit id="org.jfree.jcommon.source" version="1.0.23"/>\r
+      <unit id="org.jsoup" version="1.8.3"/>\r
+      <unit id="org.jsoup.source" version="1.8.3"/>\r
+      <unit id="org.jvnet.mimepull" version="1.9.6"/>\r
+      <unit id="org.jvnet.mimepull.source" version="1.9.6"/>\r
+      <unit id="org.mozilla.rhino" version="1.7.7.1"/>\r
+      <unit id="org.mozilla.rhino.source" version="1.7.7.1"/>\r
+      <unit id="org.objenesis" version="2.2.0"/>\r
+      <unit id="org.objenesis.source" version="2.2.0"/>\r
+      <unit id="org.slf4j.api" version="1.7.25.b001"/>\r
+      <unit id="org.slf4j.api.source" version="1.7.25.b001"/>\r
+      <unit id="org.supercsv" version="2.4.0"/>\r
+      <unit id="org.supercsv.source" version="2.4.0"/>\r
+      <unit id="stax2-api" version="3.1.4"/>\r
+      <unit id="stax2-api.source" version="3.1.4"/>\r
+      <repository location="http://www.simantics.org/download/master/external-components/maven"/>\r
+    </location>\r
+    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">\r
+      <unit id="org.apache.batik" version="1.8.0.201611220734"/>\r
+      <unit id="org.apache.poi.feature.feature.group" version="3.15.0.b0002"/>\r
+      <repository location="http://www.simantics.org/download/master/external-components/manual"/>\r
+    </location>\r
+    <location includeMode="slicer" includeAllPlatforms="true" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">\r
+      <unit id="org.simantics.sdk.feature.group" version="0.0.0"/>\r
+      <unit id="org.simantics.sdk.source.feature.group" version="0.0.0"/>\r
+      <repository location="http://www.simantics.org/download/master/sdk"/>\r
+    </location>\r
+  </locations>\r
+</target>\r
index b67572b3f1cef49458d76142cd468d8b95cdf772..15c82f8322e697a0f489662372a3ecbf826c9d0e 100644 (file)
@@ -5,6 +5,6 @@ with source allEnvironments
 include "http://www.simantics.org/download/master/org.simantics.sdk.build.targetdefinition.tpd"
 
 location "http://www.simantics.org/download/master/sdk" {
-       org.simantics.sdk.feature.group
-       org.simantics.sdk.source.feature.group
+       org.simantics.sdk.feature.group lazy
+       org.simantics.sdk.source.feature.group lazy
 }