Included Jaxen in the platform's external-components 16/1616/1
authorTuukka Lehtonen <tuukka.lehtonen@semantum.fi>
Wed, 21 Mar 2018 16:07:51 +0000 (18:07 +0200)
committerTuukka Lehtonen <tuukka.lehtonen@semantum.fi>
Wed, 21 Mar 2018 16:07:51 +0000 (18:07 +0200)
JDom2 requires Jaxen in its classpath to perform non-validating XML
parsing and it is not available at the moment in its classpath.

refs #7833

Change-Id: I961370f9c09c10dd61fe49f0147cd32716f010ef

releng/org.simantics.sdk.build.p2.site/pom.xml

index 49d48ea77823a98d50c1fe68e8ea7308fe092293..4eceda52c3d2b83a777021e7234eb01d4acf14cf 100644 (file)
@@ -13,6 +13,7 @@
         <lucene.version>4.9.0</lucene.version>
         <lucene.version.actual>4.9.0.b0003</lucene.version.actual>
         <lucene.prefix>org.apache.lucene4</lucene.prefix>
+        <jaxen.version>1.1.6</jaxen.version>
         <jdom.version>2.0.6</jdom.version>
         <jdom.version.actual>2.0.6.b0001</jdom.version.actual>
         <jackson.version>2.8.8</jackson.version>
                                         <Import-Package>!org.apache.lucene.*,*;resolution:=optional</Import-Package>
                                     </instructions>
                                 </artifact>
+                                <artifact>
+                                    <id>jaxen:jaxen:${jaxen.version}</id>
+                                    <source>true</source>
+                                </artifact>
                                 <artifact>
                                     <id>org.jdom:jdom2:${jdom.version}</id>
                                     <source>true</source>