I think i got dis grpc finally figured out part: after this give up 09/2109/1
authorjsimomaa <jani.simomaa@gmail.com>
Tue, 4 Sep 2018 14:13:42 +0000 (17:13 +0300)
committerjsimomaa <jani.simomaa@gmail.com>
Tue, 4 Sep 2018 14:13:42 +0000 (17:13 +0300)
gitlab #98

Change-Id: If77df59d67623725210e9d4e74ed235c63d92905

releng/io.grpc/pom.xml
releng/org.simantics.sdk.build.p2.site/pom.xml

index 0de8ea7c6d3699a937d66f9c9e3769a0cfd8f0aa..9dc3f9bdcf0258cec98b959a0f9638ac901b0719 100644 (file)
@@ -3,7 +3,7 @@
     <modelVersion>4.0.0</modelVersion>
     <properties>
         <grpc.version>1.14.0</grpc.version>
-        <grpc.version.actual>1.14.0.b006</grpc.version.actual>
+        <grpc.version.actual>1.14.0.b007</grpc.version.actual>
     </properties>
 
     <groupId>io.grpc</groupId>
             <version>${grpc.version}</version>
             <scope>runtime</scope>
         </dependency>
+        <dependency>
+            <groupId>io.grpc</groupId>
+            <artifactId>grpc-stub</artifactId>
+            <version>${grpc.version}</version>
+            <scope>runtime</scope>
+        </dependency>
+        <dependency>
+            <groupId>io.grpc</groupId>
+            <artifactId>grpc-protobuf</artifactId>
+            <version>${grpc.version}</version>
+            <scope>runtime</scope>
+        </dependency>
+        <dependency>
+            <groupId>io.grpc</groupId>
+            <artifactId>grpc-protobuf-lite</artifactId>
+            <version>${grpc.version}</version>
+            <scope>runtime</scope>
+        </dependency>
     </dependencies>
 
     <build>
                                 filter:="(osgi.serviceloader=io.grpc.ManagedChannelProvider)";
                                 cardinality:=multiple
                         </Require-Capability>
-                        <Require-Bundle>com.google.guava</Require-Bundle>
+                        <Require-Bundle>
+                            com.google.guava,
+                            com.google.protobuf,
+                            com.google.api.grpc.proto-google-common-protos
+                        </Require-Bundle>
                         <Import-Package>*;resolution:=optional</Import-Package>
                         <Bundle-Version>${grpc.version.actual}</Bundle-Version>
                     </instructions>
index 83e0e802d372d591be7ca381d2e4d0c5a6870250..87df82cfe3b4d8cf4ca3c32215da0b98eb68b932 100644 (file)
@@ -23,7 +23,7 @@
         <slf4j.version>1.7.25</slf4j.version>
         <slf4j.version.actual>1.7.25.b001</slf4j.version.actual>
         <grpc.version>1.14.0</grpc.version>
-        <grpc.version.actual>1.14.0.b006</grpc.version.actual>
+        <grpc.version.actual>1.14.0.b007</grpc.version.actual>
         <protobuf.version>3.5.1</protobuf.version>
     </properties>
 
                                     <id>io.grpc:io.grpc:${grpc.version}</id>
                                     <source>true</source>
                                 </artifact>
-                                <!-- <artifact>
-                                    <id>io.grpc:grpc-core:${grpc.version}</id>
-                                    <source>true</source>
-                                    <override></override>
-                                    <instructions>
-                                        <Export-Package>
-                                            io.grpc;version="${grpc.version}",
-                                            io.grpc.inprocess;version="${grpc.version}",
-                                            io.grpc.internal;version="${grpc.version}",
-                                            io.grpc.util;version="${grpc.version}"
-                                        </Export-Package>
-                                        <Import-Package>!com.google.errorprone.annotations,*</Import-Package>
-                                        <Require-Capability>
-                                            osgi.extender;
-                                                filter:="(osgi.extender=osgi.serviceloader.processor)",
-                                            osgi.serviceloader;
-                                                filter:="(osgi.serviceloader=io.grpc.ServerProvider)";
-                                                cardinality:=multiple,
-                                            osgi.serviceloader;
-                                                filter:="(osgi.serviceloader=io.grpc.ManagedChannelProvider)";
-                                                cardinality:=multiple
-                                        </Require-Capability>
-                                        <Bundle-Version>${grpc.version.actual}</Bundle-Version>
-                                    </instructions>
-                                </artifact>
-                                <artifact>
-                                    <id>io.grpc:grpc-context:${grpc.version}</id>
-                                    <source>true</source>
-                                    <override></override>
-                                    <instructions>
-                                        <Bundle-Version>${grpc.version.actual}</Bundle-Version>
-                                        <Fragment-Host>io.grpc.core</Fragment-Host>
-                                    </instructions>
-                                </artifact>-->
-                                <artifact>
-                                    <id>io.grpc:grpc-stub:${grpc.version}</id>
-                                    <source>true</source>
-                                </artifact>
-                                <artifact>
-                                    <id>io.grpc:grpc-protobuf:${grpc.version}</id>
-                                    <source>true</source>
-                                </artifact>
                                 <artifact>
                                     <id>io.grpc:grpc-netty:${grpc.version}</id>
                                     <source>true</source>
                                              io.netty.handler;bundle-version="4.1.27",
                                              io.netty.handler-proxy;bundle-version="4.1.27",
                                              io.netty.resolver;bundle-version="4.1.27",
-                                             io.netty.transport;bundle-version="4.1.27"
+                                             io.netty.transport;bundle-version="4.1.27",
+                                             io.grpc
                                         </Require-Bundle>
                                         <Import-Package>!io.netty.*,*;resolution:=optional</Import-Package>
                                         <Require-Capability>