Fixing wrong ID's for modelled tests
[simantics/platform.git] / bundles / org.simantics.tests.modelled.ui / plugin.xml
1 <?xml version="1.0" encoding="UTF-8"?>\r
2 <?eclipse version="3.4"?>\r
3 <plugin>\r
4    <extension\r
5          point="org.eclipse.ui.editors">\r
6       <editor\r
7             default="false"\r
8             name="STS Test Editor"\r
9             class="org.simantics.tests.modelled.ui.STSTestEditor"\r
10             id="org.simantics.tests.ui.stsTestEditor">\r
11       </editor>\r
12    </extension>\r
13    <extension\r
14          point="org.eclipse.core.expressions.definitions">\r
15       <definition\r
16             id="org.simantics.tests.ui.inSTSTestEditor">\r
17          <with\r
18                variable="activePartId">\r
19             <equals\r
20                   value="org.simantics.tests.ui.stsTestEditor">\r
21             </equals>\r
22          </with>\r
23       </definition>\r
24    </extension>\r
25    <extension\r
26          point="org.simantics.ui.resourceEditorAdapter">\r
27        <adapter\r
28             label="STS Test Editor"\r
29             priority="1"\r
30             editorId="org.simantics.tests.ui.stsTestEditor"\r
31             type_uris="http://www.simantics.org/Tests-1.0/STSTest">\r
32       </adapter>\r
33    </extension>\r
34    <extension\r
35          point="org.eclipse.ui.views">\r
36       <e4view\r
37             class="org.simantics.tests.modelled.ui.STSTestRunnerView"\r
38             id="org.simantics.tests.modelled.ui.stsTestRunnerView"\r
39             name="STS Test Runner View"\r
40             restorable="true">\r
41       </e4view>\r
42    </extension>\r
43 \r
44 </plugin>\r